Jump to content

Freeze+BSOD after updating to µtorrent 1.8.1 with Vista Ultimate+SP1


Recommended Posts


I have been using µtorrent for 10 months with Windows Vista Ultimate 32 + Kaspersky 2009 AV + Hardware (YOGGIE) firewall without any troubles.

After upgrading to µtorrent 1.8.1, I ALWAYS get a BOSD after some time. (Sometimes immediately, sometimes after a few minutes or hours)

Needless to say that I had never had a BOSD before with Vista in general and with µtorrent in particuliar.

I am connected to the Internet with a Wireless connection. I have also updated Windows Vista to SP1.

Any idea?


Link to comment
Share on other sites


Quick reply!

-My WIFI adapter (Intel® Wireless WIFI Link 4965AGN is up to date (according to Windows Device Manager). I nevertheless find a more recent driver on Intel's Website that I am going to try.

-Sorry, but I don't know how to get a ".dmp file from the minidump folder off of the windows folder"

If I get to the Task Manager Window and right click on µtorrent, I can create a dump file called utorrent.dmp: Is that it?

If so, how do I post it since it cannot be opened in a word processor?


Link to comment
Share on other sites

Thanks for your replies:

1.I have run µtorrent with an Ethernet cable: NO BOSD

Thus the Wireless connection seems to be the problem

2.Despite Windows indicates my Wireless Card driver is up to date, I have found, downloaded and installed a new one from Intel's website: same problem: BOSD with µtorrent AND a Wireless connection.

3.I realise that I also have recently changed from Kaspersky AntiVirus 2007 to KAV 2009.

According to http://forum.utorrent.com/viewtopic.php?id=47624; I am going to uninstall it, see what happens and let you know.

4.By the way still dunno where to find the minidup file. Don't have no c:\windows\minidump


Link to comment
Share on other sites

Nope: a quick BOSD without notice. No messages.

I have got 2 laptops, both of them with the same WIFI adapter, running with the same OS (Vista Ultimate +SP1 +Updates), programs etc etc including KAV 2009, µtorrent 1.8.1: both face the same issue in the same conditions: downloading with µtorrent with a wireless connection = BOSD

-Opening µtorrent using a wireless connection WITHOUT downloading anything: no problems

-Downloading with µtorrent with an Ethernet cable: No problems

Link to comment
Share on other sites

Here is the message I get with the BSOD after having "Disabled automatic restarting on crash"

(By the way I don't know how to enable crash dumping...)

Blah blah blah etc then (sugggestions as to remove recently installed programs etc...) then:

technical information:

stop: 0x0000007F (0x000000008, 0x903D3130, 0x00000000, 0x00000000)

Link to comment
Share on other sites

Jondo, I am having the same problem on the XP, but with the same wireless adapter updated to latest driver (v12.1.1.0).

Anyway, enabling memory dump after a crash, on Vista:

go to: System Properties, Advanced Tab, Click "Settings" in the "Startup and Recovery" section. In the drop-down under "Write Debugging Information," choose either minidump, kernel dump or complete memory dump.

By the way, unless requested to, I wouldn't do the complete memory dump as it can take a loooooong time.

Hope this helps.


Link to comment
Share on other sites


I am only offered in the above mentioned drop list between:

-Small Memory Dump (64k) and

-Kernel Memory Dump

I assume small memory dump is the same as minidump?

I am going to try again a Wireless connection + µtorrent with KAV 2009 disabled, and if it does not work with KAV 2009 uninstalled.

Will let you know if this solves the problem...(Which would let me without an antivirus...)

Link to comment
Share on other sites

I have tried everything: I have probably found out what is responsible for the BOSD:

-I have re-installed a fresh and new system with Windows Vista Ultimate 32 Bits on my 2 computers (including SP1)

-I have updated my drivers including my WIFI device drivers

-ABSOLUTELY NO other softwares are installed on this fresh installation (no Office nothing, no AV etc etc)

-I use µtorrent with a wire AND a WIFI connection without ANY PROBLEMS

-I install my Yoggie CardPro (see http://www.yoggie.com) hardware firewall device (KAV runs on it, but not only KAV)

-An Ethernet Connection + µtorrent: still no problems

-If I make a WIFI Connection=> BOSD

So, the responsible definitely is this device. Now the problem is to find why.

Link to comment
Share on other sites

I also am having a similar problem. Currently I am running Vista Business (SP1 + Updates) on an ethernet connection. I have been downloading with uTorrent for a VERY long time (2-3years) with NO problems. I also have had no BSOD's until this point, except for when I try to install SATA DVD drives.

What really disconcerns me about my situation is that when this happened in uTorrent I decided to try bitTorrent and the same exact thing happened so now I know that it is a system error.

The crashes in uTorrent happen pretty frequently. I have only gotten 3 or 4 BSOD's on this matter. They happen when I am downloading for long periods of time.

I am also running COMODO Firewall Pro.

I have the minidump files but do not know how to attach them. Also on a side note I am unable to read the .dmp files in my Log Viewer. I get the error: "Checksum mismatch on the manifest files."

Thanks for any help.

Link to comment
Share on other sites

  • 2 weeks later...

Jondo - Don't get your hopes up yet but...

Today I got a klif.sys file from Kaspersky Support to replace the one on my pc and four hours of uTorrent downloading my screen is neither blue nor dead! I will leave it going all night and maybe after 24 hours or so I will stop expecting the BSOD. If all goes well I will ask them if this is a general fix or one specific to my configuration.


1) I am on Win XP and not Vista

2) They sent me this after disappearing for a month with my full memory dump

3) As I said, it's only 4 hours in and a lot can happen in the next 20...

Will come back tomorrow with the result but, touch wood, it's looking good.



26 hours on and still no blue screen. I chose a huge file and kept the thing downloading non-stop. Also been using FTP and HTTP during this test and nothing seems to make it unhappy in the slightest.

Have asked Kaspersky about the file and will post their answer.

Really could be light at the end of the tunnel here.


My message:

OK, I got the file and replaced the one on my PC. 26 hours constant use of uTorrent later, still no blue screen. I think this file has fixed it. Thank you very very much.

One more question before I close the ticket. Is this file a general fix, or is it just for me? I ask because a couple of people on the uTorrent forum are having the same problem as me (uTorrent, Intel Wifi Link 4965AGN card and Kaspersky 2009 product - although one is running MS Vista and not XP), will they be able to use the same kilf.sys file that I was given or not?

Kaspersky Reply:

Hi, They will issue the critical fix tomorrow (a new version will be posted on the main site www.kaspersky.co.uk/productupdates) so you should be able to download this version

While not answering my question, I guess the fix tomorrow should do the trick. Good luck.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...