Jump to content

Can't add new torrents via Web UI


Recommended Posts


When I select a local torrent file and hit "ok" button the field with path to the .torrent file clears and nothing happens.

In the uT log it only shows:

[2008-10-27 19:23:26] HTTP: IP GET /gui/?action=add-file

in Web UI logger tab it shows:

[19:23:26] JS error: [2] Expected ')'

I've tried different .torrent files that work fine in uT itself.

Also checked all directories where uT would download and move files/torrents to, they all are writable for uT (the directories are actually on a mapped network drive and as I said above, uT doesn't have problem using them when torrents added locally)

Using uT v1.8.1 build 12639 (beta)

uT download webui.zip by itself, so I assume its the latest.

Thank you.

Link to comment
Share on other sites

Yes, I did.

The error in WebUI log does look suspicious, doesn't it? hmm...looks like a bug...maybe...?

Now, if someone CAN add new torrent via WebUI, can you tell me what version or at least what is the MD5 hash for the webui.zip you have?

mine is EAD3769D75657FF109355D8BF27BAA3B


Just tried WebUI v0.360 - same effect torrent not being added, but no error in WebUI logger tab.

Here is what LiveHTTPHeader showed:


POST /gui/?action=add-file HTTP/1.1

Host: mycomputer

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/2008092417 Firefox/3.0.3

Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

Accept-Language: en-us,en;q=0.5

Accept-Encoding: gzip,deflate

Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7

Keep-Alive: 300

Connection: keep-alive

Referer: http://mycomputer/gui/

Authorization: Basic blah=

Content-Type: multipart/form-data; boundary=---------------------------7342278226913

Content-Length: 17964


Content-Disposition: form-data; name="torrent_file"; filename="mytorrentfile.torrent"

Content-Type: application/x-bittorrent

torrent content here


And the response was:

HTTP/1.x 300 ERROR

Connection: keep-alive

Content-Length: 15

Content-Type: text/html

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...