Jump to content

Poor download speed


Recommended Posts

I have been trying everything to get this download speed up and i cannot seem to get it to move to a good settings to do that.

Right now my utorrent (1.8.1) is downloading 18-40 kb/s, spikes at 100 -at times- and i limited my upload to 35 kb/s and only have one active torrent. The torrent i am testing on has 1140 seeds and 11056 peers.I have tried all kinds of settings in the bandwidth section but its currently at global 100 / max 40 / upload 4. My provider is a company called Mountain Cable in Canada and they 'do not' limit torrents...they just suck at uploading and even tested at Glasnost. I am running on a x9000, 4 gigs and 7200 RPM hd and this is on a ethernet gigabyte connection to a gigabyte router (DIR-655).

Turned off resolve ip, upnp, nat-pmp, DHT, firewall (both router and windows), virus scanner

Edited Forced encryption, forwarded port on 58### (green), patched TCPIP.sys to 50, used TCPOptimizer.exe

i did the slackware test and i could get up to 790 kbs but with any other torrents i hardly hit max 100


Link to comment
Share on other sites

Leave uTorrent's advanced setting net.max_halfopen set to 8 (or less) even though you patched windows. Raising it tends to just burn more bandwidth...reducing speeds beyond the 1st minute or 2 of starting a torrent.

2nd link in my signature for conservative settings for uTorrent based on upload speed/bandwidth.

Link to comment
Share on other sites

Sorry missed that info. :P

See if the OpenOffice test torrent (mentioned in 1st link of my signature) downloads faster.

It would be good to have that as a baseline for what your connection CAN do.

Beyond that, not much else you can try except this kind of stealth/encryption tricks in uTorrent:


...Or an encrypted proxy if you think the problem is ISP-related BitTorrent throttling.

Doing the reverse might work...lowering outgoing encryption to enabled instead of forced.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...