Jump to content

Disk Overloaded 100%


Spoonhead

Recommended Posts

Coalesce_write_size is not for Disk Overloaded. If you read http://utorrent.com/faq.php you'd see other things to check.

Go to the speed tab, Disk Statistics, what do you see? Is your cache being filled? How large is it? What does Ctrl-P > Advanced > Disk Cache look like?

What type and number are the drives you're reading to/writing from?

Link to comment
Share on other sites

OK. Starting with Speed tab... it's to the right of General. You see it next to "Logger" ;) If you can't see these, press F5 to show the details pane (you can also use the View menu). The first drop down will take you from upload+download / upload / download / Disk Statistics ;)

As far as the hard drive... If you go to system properties (right click on my computer, properties) and then to Hardware > Device Manager... go to the IDE controller, and check the channels are in CURRENT MODE DMA (x) anywhere from 1-9. If it is in PIO, you will need to remove the controller, and reboot.

Link to comment
Share on other sites

ahhh yeahh i have the speed tab and disk statistics. sorry i thought u were referring to an option in preferences.

My controllers are all ATA and SATA,

there are two channels called ATA Channel 0

and one called ATA Channel 1

Serial ATA Storage Controller - 2828

Serial ATA Storage Controller - 2850

Ive just uninstalled norton internet security and replaced it with avast due to other reasons and rebooted so ill post details of what the speed tab is telling me a soon as the problem re-ocurrs.

thanks 4 the help so far!!!

Link to comment
Share on other sites

Crappy settings >_>

Try only enabling the following (disable anything else):

- Reduce memory usage when the cache is not needed

- Enable caching of idsk writes"

- Write out untouched blocks every 2 minutes

- Enable caching of disk reads

- Turn off read caching if the upload speed is slow

- Remove old blocks from the cache

- Disable Windows caching of disk reads

What are your connection's maximum download and upload rates anyhow?

Link to comment
Share on other sites

okay so the changes i ve made are...

ive unchecked "write out finished pieces immediatly"

ive unchecked "disable windows chaching of disk writes"

cheked "Disable windows caching if disk reads"

my connection is supposed to be just 2mb but its actually like just over 1mb.

It still does it after that, it just doesnt write to file at all, not even once.

I mean sometimes it does and then just overloads later.

I havent increased the chache to 100, should i still do that?

Okay, ive had just about enough of this. There is no point in me downloading anything now.

It downoads it to cache but the chache is never or hardly written. I have left utorrent running after finishing a download and it refuses to write to disk at all. Therefore i can use files that it has in chache but as soon as i close the app the cache is cleared and the torrent drops below 99.9% again.

What the hell could i be doing wrong? this is a relativley new laptop so i dont imagine its a hardware problem.

Link to comment
Share on other sites

Usually stopping writing is actually a problem with incompatible software interfering with the Disk Cache settings (shown over different versions of Windows from 2K3-2K8).

If you disable disk cache then the writing is most certainly external and therefore Windows has the problem for whatever reason. However if not, then what you could try is turning off the two windows bypass turn on write out pieces immediately and try toggling the "reduce cache when not needed" option :/

Link to comment
Share on other sites

Ive changed the settings so that any kind of caching is disabled. This works for me. the disk just writes it as it downloads. I dont know if this is harmful to the download speed or the hard disk in the long run but it works.

however occasionally utorrent will still decide to use the cache even though it has been disabled. The bar underneath "write statistics" does not fill up with the green indicator but the amount of memory used in the cache is shown besides that.

when this happens it hardly writes to disk if at all just like it used to when the chaches were enabled.

does this mean it will just keep overloading the cache? and does anybody have any idea what causes that t happen even though i have the settings configured so that it shouldnt?

Link to comment
Share on other sites

Disk Overloaded means your hard drive is too slow for the operations you're giving it. The reason for the cache is to avoid this... buffering data until the bottleneck clears (can be streaming, or background tasks, for instance). However if this is regular and persistent, you need to verify your hard drive channels are in CURRENT MODE DMAx (a number)... you can find your channels under the disk controller item(s) of the Device Manager (start > run > devmgmt.msc)

Link to comment
Share on other sites

Occasional hiccups are to be expected... say when you're unpacking a large file, or playing HD video, or editing a large document/image. This is usually impacted timeframe and clears up... especially in times where your system RAM is low (paging to disk is definitely more time-consuming than running from RAM). I don't know about using disk cache when it's explicitly disabled... how often are we talking?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
×
×
  • Create New...