Jump to content

uTorrent 1.8.1: No Incoming Connections Error (No Router)


Recommended Posts


I have a cable internet connection with a modem and NO router.

Modem is not a combination modem and has no router functionality (I've double checked) - Model: Motorola SB5102

Its connected to my desktop with a hard wire ethernet cable

My download speed is 5Mbits/sec (actual: 4924 kbits/sec)

My upload speed is 512kbits/sec (actual: 490 kbits/sec)

I use a dynamic IP address with dynamic DNS in my TCP/IP settings

I have looked at the windows firewall and the F-Secure Anti-virus firewall and I've put uTorrent as an exception in both

I've had routers with wireless modems in the past and port forwarding has been a piece of cake. This situation is unique and I thought I don't need to port forward, yet my uTorrent client reports a "Yellow triangle with an exclamation mark" stating that there are no incoming connections.

Any suggestions/comments would be greatly appreciated.

Thank you! :)

Link to comment
Share on other sites

More than likely, one or both of the software firewalls is causing the problem.

Try removing one of your software firewalls (windows by completely disabling or F-Secure by uninstalling.)

Often, allowing internet use to uTorrent is not enough...because the software firewalls will still block unsolicited incoming connections. :(

Link to comment
Share on other sites

Thanks for the response. I tried disabling the Windows Firewall by switching it off and almost instantly the little triangle switched to the very delightful green circle with a check mark signifying the network connections are OK. I went ahead and clicked on it and tried to test if the port forward is done, it says there is an Error. Soon after, the green check disappeared and the triangle with the exclamation mark returned.

However, when I disabled the F-Secure firewall the green OK returned. But I think this is unsafe to not have a decent firewall? Why isn't the making utorrent an exception on the firewall working with F-Secure?

I have owned modems with wireless routers in the past on the same machine with F-Secure and a port forward with a router is very straight-forward and easy to do. This modem without router is quite a challenge!

Could it be anything else?

Link to comment
Share on other sites

Thank you! Well the part about the "Custom Rule" is the right one!

I think its very unsafe to "allow all" traffic because then F-Secure simply becomes a dummy firewall which is there just for namesake and it allows all incoming and outgoing connections without any alerts.

Here's what I did: I wrote down the port number that utorrent was set to, which was 31615 and then used F-Secure to open TCP and UDP ports for the 31615. It works like a charm! Here's the KB from F-Secure's site:


Thank you Switeck for suggesting it was something to do with the firewall and "thelittlefire" for giving me the idea and the right words for the keyword search! LOL!

Merci! Danke! Thank-you!

Link to comment
Share on other sites

Happy to hear you solved it. :D If you can filter by process name, all traffic for utorrent.exe is the easy way, but you indeed hit the nail on the head with the KB article.

For future reference as you say, use the PORT you set in Preferences as the port for the rule and use the same trigger port rule . . though I think they fibbed a bit, standard assigned service ports go up to 1024, so 1025-65534 would work just as well. You don't need to make both rules if you or your router don't work so well with DHT enabled... don't create the UDP rule.

Link to comment
Share on other sites

I tried following their KB completely with their port numbers for both DHT and UDP and it wouldn't work till I realised I need to add my port for utorrent, so I added 31615 in the responder ports for TCP and UDP. The initiator range had 1025-65534 that covered the 31615 in its range for both TCP and UDP

Then I wasn't sure what was the problem so I created both, now that I think of it, you're right, UDP is unnecessary.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...