Jump to content

Need help with port forwarding.


Recommended Posts

Hi. Sorry for the long post, but please bare with me.

I recently bought a d-link dir300. Up until a week ago I was using a Motorola 5100E cable modem. My laptop had XP sp2 with NOD 32 and Comodo firewall. So, I installed the router, a friend of mine helped me with the settings and everything was working fine apart from utorrent. I went to postforward.com, read the directions and managed to forward a port. Great, right?

Well, there was one problem. All the antispyware and antivirus programs that I tried after I established the wireless network wouldn't update. As far as I remember, the NOD 32 which was installed before did update, but I'm not 100% sure. Trying different options, I disabled the proxy server for the LAN in Internet Options and ticked Automatically detect settings. Now everything worked fine.

However, the next day I installed NIS 2008 and messed around in the router settings, so it's probably one of those two that caused the problem. I did enable TCP and UDP traffic for utorrent in NIS with the same port I used in the router. I even shut it down completely to check if it was causing the problem. The port still wouldn't forward. Then I tried DMZ in the router. Still nothing.

These are the router settings which I may have changed accidentally (being the noob that I am):

Enable SPI : NO

Enable UPnP : NO

Enable WAN Ping Respond : YES


Utorrent settings at the moment:


Nat-mapping: YES

Windows firewall exception: YES (it's turned off anyway)

Also, is it possible that changing the proxy port in Internet options caused the problem (even though it's ticked off)?

I'm not sure what info will be helpful for you so please ask me and I'll tell you. Thanks.

Link to comment
Share on other sites

NOD is uninstalled but it was just an antivirus and Comodo is turned off. Uninstalling it at the moment.

BTW, the other pc in the network has the same problems even though only NOD and Comodo are installed, so I'm guessing the problem is at the router level.

Any ideas?

*UPDATE* Wow, thanks man. I just uninstalled Comodo and the port magically opened... :) I thought since it was turned off it wouldn't interfere with NIS, but obviously I thought wrong. Not only that, but it somehow interfered with the other PC's connection as well. Thanks again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...