Archived

This topic is now archived and is closed to further replies.

n8dawg412

driver irql not less or equal error while using utorrent

Recommended Posts

I have been having the same issues that a lot of individuals have been having with their computers where they are one moment using their computer and utorrent is running and then the next thing they know the blue screen of death pops up and displays the error message "driver irql not less or equal" and then after it restarts it says "windows has recovered from a serious error". I get the usual sysdata.xml and minidump error detail.

I am using the ATI Radeon 9200 and the drivers are up to date. What is weird is that whenever I am using utorrent it will crash and give the blue screen of death. This usually only happens however when I secure my wireless connection with WPA and it will crash after several hours of using utorrent. When I secure my internet using WEP it happens like once in a blue moon. Not sure why that would matter if it was WPA or WEP.

I have used several forums to try and help my case but it still has not covered the exact problem I am having.

http://thevistaforums.com/lofiversion/index.php/t34128.html

http://forum.utorrent.com/viewtopic.php?pid=289498#p289498

I will also point out that I am not using a USB internet connection, I have an ethernet cord for my wired connection. Any help would be great and I have been working on updating all of my other drivers right now hoping that would help, but I was not sure if there is anything else I could do.

Share this post


Link to post
Share on other sites

Can you post the minidumps in \Windows\minidumps to mediafire? Pack them in a zip/rar/7zip archive first.

...or are they ndis.sys related crashes?

Share this post


Link to post
Share on other sites

I am sorry but I am not that knowledgeable regarding minidumps and am not too sure about if they would be "ndis.sys" related crashes... could you explain what that would be

I will work on doing that but what exactly is mediafire?

Share this post


Link to post
Share on other sites

http://www.mediafire.com/

BSOD's sometimes list the file connected to the crash near the bottom. Are you on XP or vista? If you press the Windows Key + R, put %windir%\minidump in and press enter, it should show a folder with a bunch of minidumps (.dmp's).

Share this post


Link to post
Share on other sites

DEFAULT_BUCKET_ID: GRAPHICS_DRIVER_FAULT

IMAGE_NAME: ati2dvag.dll

Did you already try to get help? Looks like ATi's driver is causing the crash, though that's weird imo. Is that the only crash you get (DRIVER IRQL)? And the ATi drivers are up to date?

Share this post


Link to post
Share on other sites

I previously earlier that day deleted all of my .dmp files. Yes, the driver IRQL is the only crash I will get each and every time... it would display the blue screen of death and then say "driver irql not less or equal". I have an HP like I said so I ran my HP total care and did a driver check and it never showed that I had my ATI driver out of date. I also downloaded a program called "driver detective" and it listed my ATI driver as up to date.

Share this post


Link to post
Share on other sites

well what is strange is that i am using that website to try and find my driver and I have a ATI Mobility Radeon 9200... but I don't see it as a choice. Still trying to figure it out

But found this website which has an update for the driver... wondering if it is legit... any thoughts?

http://drivers.softpedia.com/get/GRAPHICS-BOARD/ATI/ATI-Mobility-Radeon-9000-9200-9600-9700-41.shtml

or

http://www.driverskit.com/freedownload/Video_Card/Ati/Radeon_9200_9100_6_14_10_6414/10463.html

or

http://www.new-drivers.com/files/display/ATI/Radeon%20Mobility/?gclid=CM2jsaj095YCFRQhnAodzDfrYA

Share this post


Link to post
Share on other sites

yeah i tried 9600 and they made me use a validation tool and then when I tried to run it, it told me that it wouldn't work. I am trying to post on ATI's forum to see if someone knows what the latest driver is for my card so we will see... but you are sure that the crashes are from my driver

Share this post


Link to post
Share on other sites

Yes, unless you have a virus that's installed as a graphics driver and is pretending to be a part of ATI :P

Share this post


Link to post
Share on other sites

I found a solution and was able to update my drive by the use of a program called: mobility modder... but I wanted to make sure that my driver was still not faulty and was going to post my dump files on mediafire again so that you could take a look at them one more time. Thanks for your help btw.

Here is the link:

http://www.mediafire.com/?sharekey=0bfea85a7ed59ca0d2db6fb9a8902bda

Share this post


Link to post
Share on other sites

Probably caused by : ati2dvag.dll ( ati2dvag+2ed80 )

*******************************************************************************

* *

* Bugcheck Analysis *

* *

*******************************************************************************

THREAD_STUCK_IN_DEVICE_DRIVER (ea)

The device driver is spinning in an infinite loop, most likely waiting for

hardware to become idle. This usually indicates problem with the hardware

itself or with the device driver programming the hardware incorrectly.

If the kernel debugger is connected and running when watchdog detects a

timeout condition then DbgBreakPoint() will be called instead of KeBugCheckEx()

and detailed message including bugcheck arguments will be printed to the

debugger. This way we can identify an offending thread, set breakpoints in it,

and hit go to return to the spinning code to debug it further. Because

KeBugCheckEx() is not called the .bugcheck directive will not return bugcheck

information in this case. The arguments are already printed out to the kernel

debugger. You can also retrieve them from a global variable via

"dd watchdog!g_WdBugCheckData l5" (use dq on NT64).

On MP machines (OS builds <= 3790) it is possible to hit a timeout when the spinning thread is

interrupted by hardware interrupt and ISR or DPC routine is running at the time

of the bugcheck (this is because the timeout's work item can be delivered and

handled on the second CPU and the same time). If this is the case you will have

to look deeper at the offending thread's stack (e.g. using dds) to determine

spinning code which caused the timeout to occur.

DEFAULT_BUCKET_ID: GRAPHICS_DRIVER_FAULT

BUGCHECK_STR: 0xEA

PROCESS_NAME: aim.exe

MODULE_NAME: ati2dvag

IMAGE_NAME: ati2dvag.dll

Share this post


Link to post
Share on other sites

Wireless dongle? That sadly isn't enough with default settings. Wireless drivers are generally good 1) when you have a dedicated card 2)when multiple adapter software doesn't fight for "management" BUT they don't work so well when talking about wireless adapters (USB/Firewire/etc) or x64 unless you pay for high quality. Lower concurrent connections below 100. .. Make your own thread or at least put in USEFUL information if/when you respond again please.

Share this post


Link to post
Share on other sites

I have a similar problem:

1- utorrents runs for a little (a minute or less) then I get the BSOD.

2- The computer reboots automatically.

Note: this ONLY happens when utorrent is running, otherwise this computer has never crashed.

I have been using utorrent for a couple of years without problems, this has started recently, not sure if after updating to the latest version or if after updating the latest MS fixes....

I managed to copy the BSOD error once:

DRIVER IRQL NOT LESS OR EQUAL

*** STOP: 0X000000D1 (0X89800000,0X00000002,0X00000000,0XBA29D988)

*** V22n51.SYS -address BABA29D988 base at BA229000, DateStamp 404c5c4c

I searched all forums and did not find a solution, but found a lot of instruction on how to post, so I am giving here as much info as I can, I hope it is the right way to about it...

I have a Tablet running WINXP Pro for Tablet SR2.

Display: Intel Extreme Graphic 2 -- Latest driver

AVAST -- utorrent and bittorrent p2p disabled

I searched for minidumps on all drives: none found .

I searched for .dmp on all drives: none found.

This is the HiJackThis Log:

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 00:01:02, on 8/01/2009

Platform: Windows XP SP2 (WinNT 5.01.2600)

MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

Boot mode: Normal

Running processes:

C:\WINDOWS\System32\smss.exe

C:\WINDOWS\system32\winlogon.exe

C:\WINDOWS\system32\services.exe

C:\WINDOWS\system32\lsass.exe

C:\WINDOWS\system32\svchost.exe

C:\WINDOWS\System32\svchost.exe

C:\Program Files\Common Files\Microsoft Shared\Ink\KeyboardSurrogate.exe

C:\Program Files\Accessories\AntiVirus\Avast4\aswUpdSv.exe

C:\Program Files\Accessories\AntiVirus\Avast4\ashServ.exe

C:\WINDOWS\SYSTEM32\WISPTIS.EXE

C:\WINDOWS\System32\tabbtnu.exe

C:\WINDOWS\Explorer.EXE

C:\WINDOWS\system32\ctfmon.exe

C:\Program Files\Common Files\Microsoft Shared\Ink\TCServer.exe

C:\WINDOWS\system32\LEXBCES.EXE

C:\WINDOWS\system32\spoolsv.exe

C:\WINDOWS\system32\LEXPPS.EXE

C:\Program Files\Synaptics\SynTP\SynTPLpr.exe

C:\Program Files\Common Files\Microsoft Shared\Ink\TabTip.exe

C:\Program Files\Synaptics\SynTP\SynTPEnh.exe

C:\WINDOWS\AGRSMMSG.exe

C:\Program Files\On Screen Display\Hotkey.exe

C:\Program Files\Easy Menu\EasyTray.exe

C:\Program Files\Battery miser\batterymiser.exe

C:\PROGRA~1\ACCESS~1\ANTIVI~1\Avast4\ashDisp.exe

C:\Program Files\Lexmark X1100 Series\lxbkbmgr.exe

C:\Program Files\Common Files\Apple\Mobile Device

Support\bin\AppleMobileDeviceService.exe

C:\Program Files\Java\jre6\bin\jusched.exe

C:\Program Files\Lexmark X1100 Series\lxbkbmon.exe

C:\Program Files\Bonjour\mDNSResponder.exe

C:\Program Files\Java\jre6\bin\jqs.exe

C:\Program Files\Accessories\Multimedia\iTunes\iTunesHelper.exe

C:\Program Files\IP Operator\IPOperator.exe

C:\Program Files\Accessories\PrintScreen\PrintScreen.exe

C:\Program Files\Accessories\TomTom HOME 2\HOMERunner.exe

C:\Program Files\Accessories\CDBurnerXP\NMSAccessU.exe

C:\WINDOWS\System32\svchost.exe

C:\Program Files\Accessories\File Handling\Powerdesk7\pddlghlp.exe

C:\Program Files\Accessories\AntiVirus\Avast4\ashMaiSv.exe

C:\Program Files\Accessories\AntiVirus\Avast4\ashWebSv.exe

C:\Program Files\iPod\bin\iPodService.exe

C:\WINDOWS\System32\svchost.exe

C:\WINDOWS\system32\igfxsrvc.exe

C:\Program Files\Mozilla Firefox\firefox.exe

C:\Program Files\Accessories\File Handling\Powerdesk7\PDExplo.exe

D:\1Data\Dowloads\Utilities\Anty Spyware\HiJackThis\HiJackThis.exe

C:\Program Files\Accessories\File Handling\Powerdesk7\PDExplo.exe

R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet

Settings,ProxyOverride = *.local

O2 - BHO: Adobe PDF Reader Link Helper -

{06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common

Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll

O2 - BHO: Java Plug-In SSV Helper -

{761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program

Files\Java\jre6\bin\ssv.dll

O2 - BHO: Java Plug-In 2 SSV Helper -

{DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program

Files\Java\jre6\bin\jp2ssv.dll

O2 - BHO: JQSIEStartDetectorImpl - {E7E6F031-17CE-4C07-BC86-EABFE594F69C} -

C:\Program Files\Java\jre6\lib\deploy\jqs\ie\jqs_plugin.dll

O4 - HKLM\..\Run: [TabletTip] "C:\Program Files\Common Files\microsoft

shared\ink\tabtip.exe" /resume

O4 - HKLM\..\Run: [synTPLpr] C:\Program Files\Synaptics\SynTP\SynTPLpr.exe

O4 - HKLM\..\Run: [synTPEnh] C:\Program Files\Synaptics\SynTP\SynTPEnh.exe

O4 - HKLM\..\Run: [AGRSMMSG] AGRSMMSG.exe

O4 - HKLM\..\Run: [KeybdUtility] "C:\Program Files\On Screen

Display\Hotkey.exe"

O4 - HKLM\..\Run: [EasyMenu] C:\Program Files\Easy Menu\EasyTray.exe

O4 - HKLM\..\Run: [batterymiser] C:\Program Files\Battery

miser\batterymiser.exe

O4 - HKLM\..\Run: [TabletWizard] C:\WINDOWS\help\SplshWrp.exe

O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ACCESS~1\ANTIVI~1\Avast4\ashDisp.exe

O4 - HKLM\..\Run: [igfxtray] C:\WINDOWS\system32\igfxtray.exe

O4 - HKLM\..\Run: [igfxhkcmd] C:\WINDOWS\system32\hkcmd.exe

O4 - HKLM\..\Run: [igfxpers] C:\WINDOWS\system32\igfxpers.exe

O4 - HKLM\..\Run: [Lexmark X1100 Series] "C:\Program Files\Lexmark X1100

Series\lxbkbmgr.exe"

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program

Files\Java\jre6\bin\jusched.exe"

O4 - HKLM\..\Run: [AppleSyncNotifier] C:\Program Files\Common

Files\Apple\Mobile Device Support\bin\AppleSyncNotifier.exe

O4 - HKLM\..\Run: [QuickTime Task] "C:\Program

Files\Apple\QuickTime\QTTask.exe" -atboottime

O4 - HKLM\..\Run: [iTunesHelper] "C:\Program

Files\Accessories\Multimedia\iTunes\iTunesHelper.exe"

O4 - HKLM\..\Run: [iPOperator] "C:\Program Files\IP Operator\IPOperator.exe"

-aUtOsTaRtFrOmReG

O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe

O4 - HKCU\..\Run: [Gadwin PrintScreen 2.6] C:\Program

Files\Accessories\PrintScreen\PrintScreen.exe /nosplash

O4 - HKCU\..\Run: [TomTomHOME.exe] "C:\Program Files\Accessories\TomTom HOME

2\HOMERunner.exe"

O4 - HKUS\S-1-5-19\..\Run: [TabletWizard] %windir%\help\wizard.hta (User

'LOCAL SERVICE')

O4 - HKUS\S-1-5-20\..\Run: [TabletWizard] %windir%\help\wizard.hta (User

'NETWORK SERVICE')

O4 - HKUS\S-1-5-18\..\Run: [Picasa Media Detector] C:\Program

Files\Accessories\Multimedia\Picasa2\PicasaMediaDetector.exe (User 'SYSTEM')

O4 - HKUS\.DEFAULT\..\Run: [Picasa Media Detector] C:\Program

Files\Accessories\Multimedia\Picasa2\PicasaMediaDetector.exe (User 'Default

user')

O4 - Startup: Dialog Helper.lnk = C:\Program Files\Accessories\File

Handling\Powerdesk7\pddlghlp.exe

O8 - Extra context menu item: E&xport to Microsoft Excel -

res://C:\PROGRA~1\MICROS~2\OFFICE11\EXCEL.EXE/3000

O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} -

C:\PROGRA~1\MICROS~2\OFFICE11\REFIEBAR.DLL

O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} -

C:\Program Files\Messenger\msmsgs.exe

O9 - Extra 'Tools' menuitem: Windows Messenger -

{FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program

Files\Messenger\msmsgs.exe

O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) -

http://www.update.microsoft.com/windowsupdate/v6/V5Controls/en/x86/client/wuw

eb_site.cab?1205756375460

O16 - DPF: {6E32070A-766D-4EE6-879C-DC1FA91D2FC3} (MUWebControl Class) -

http://www.update.microsoft.com/microsoftupdate/v6/V5Controls/en/x86/client/m

uweb_site.cab?1205757342170

O16 - DPF: {CF40ACC5-E1BB-4AFF-AC72-04C2F616BCA7} (get_atlcom Class) -

http://www.adobe.com/products/acrobat/nos/gp.cab

O16 - DPF: {EA1B8527-E422-4909-825A-70BE0694F18E} (PortfolioManagerWT

ProfileManager Class) -

https://online.westpac.com.au/wtoa/wtOtherAccounts/portfoliomanagerwt.cab

O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} -

C:\PROGRA~1\COMMON~1\Skype\SKYPE4~1.DLL

O23 - Service: Apple Mobile Device - Apple Inc. - C:\Program Files\Common

Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe

O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - ALWIL Software -

C:\Program Files\Accessories\AntiVirus\Avast4\aswUpdSv.exe

O23 - Service: avast! Antivirus - ALWIL Software - C:\Program

Files\Accessories\AntiVirus\Avast4\ashServ.exe

O23 - Service: avast! Mail Scanner - ALWIL Software - C:\Program

Files\Accessories\AntiVirus\Avast4\ashMaiSv.exe

O23 - Service: avast! Web Scanner - ALWIL Software - C:\Program

Files\Accessories\AntiVirus\Avast4\ashWebSv.exe

O23 - Service: Bonjour Service - Apple Inc. - C:\Program

Files\Bonjour\mDNSResponder.exe

O23 - Service: Google Updater Service (gusvc) - Google - C:\Program

Files\Google\Common\Google Updater\GoogleUpdaterService.exe

O23 - Service: iPod Service - Apple Inc. - C:\Program

Files\iPod\bin\iPodService.exe

O23 - Service: Java Quick Starter (JavaQuickStarterService) - Sun

Microsystems, Inc. - C:\Program Files\Java\jre6\bin\jqs.exe

O23 - Service: LexBce Server (LexBceS) - Lexmark International, Inc. -

C:\WINDOWS\system32\LEXBCES.EXE

O23 - Service: Macromedia Licensing Service - Unknown owner - C:\Program

Files\Common Files\Macromedia Shared\Service\Macromedia Licensing.exe

O23 - Service: NMSAccessU - Unknown owner - C:\Program

Files\Accessories\CDBurnerXP\NMSAccessU.exe

O23 - Service: ServiceLayer - Nokia. - C:\Program Files\PC Connectivity

Solution\ServiceLayer.exe

-------End of file - 8118 bytes

This is the Process Explorer Log:

Process PID CPU Description Company Name

System Idle Process 0 96.04

Interrupts n/a 0.99 Hardware Interrupts

DPCs n/a Deferred Procedure Calls

System 4

smss.exe 348 Windows NT Session Manager Microsoft Corporation

csrss.exe 416 Client Server Runtime Process Microsoft Corporation

winlogon.exe 440 Windows NT Logon Application Microsoft Corporation

services.exe 788 Services and Controller app Microsoft Corporation

svchost.exe 968 Generic Host Process for Win32 Services Microsoft Corporation

tcserver.exe 596 Microsoft Tablet PC Component Microsoft Corporation

tabtip.exe 1544 0.99 Microsoft Tablet PC Component Microsoft Corporation

igfxsrvc.exe 2892 igfxsrvc Module Intel Corporation

svchost.exe 1048 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1088 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1200 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1404 Generic Host Process for Win32 Services Microsoft Corporation

aswUpdSv.exe 1640 avast! Antivirus updating service ALWIL Software

ashServ.exe 1696 avast! antivirus service ALWIL Software

LEXBCES.EXE 1012 LexBce Service Lexmark International, Inc.

LEXPPS.EXE 1156 LEXPPS.EXE Lexmark International, Inc.

spoolsv.exe 1144 Spooler SubSystem App Microsoft Corporation

AppleMobileDeviceService.exe 2068 Apple Mobile Device Service Apple Inc.

mDNSResponder.exe 2188 Bonjour Service Apple Inc.

jqs.exe 2240 Java Quick Starter Service Sun Microsystems, Inc.

NMSAccessU.exe 2516

svchost.exe 2560 Generic Host Process for Win32 Services Microsoft Corporation

ashMaiSv.exe 3180 avast! e-Mail Scanner Service ALWIL Software

ashWebSv.exe 3224 avast! Web Scanner ALWIL Software

iPodService.exe 3416 iPodService Module Apple Inc.

alg.exe 3808 Application Layer Gateway Service Microsoft Corporation

svchost.exe 2644 Generic Host Process for Win32 Services Microsoft Corporation

lsass.exe 800 LSA Shell (Export Version) Microsoft Corporation

keyboardsurrogate.exe 1352 Microsoft Tablet PC Component Microsoft Corporation

wisptis.exe 2044 Microsoft Tablet PC Component Microsoft Corporation

tabbtnu.exe 252 Tablet PC Buttons Service Microsoft Corporation

explorer.exe 468 0.99 Windows Explorer Microsoft Corporation

ctfmon.exe 476 CTF Loader Microsoft Corporation

SynTPLpr.exe 1340 TouchPad Driver Helper Application Synaptics, Inc.

SynTPEnh.exe 1576 Synaptics TouchPad Enhancements Synaptics, Inc.

AGRSMMSG.exe 1616 SoftModem Messaging Applet Agere Systems

HotKey.exe 920 HotKey LG Electronics

EasyTray.exe 1736 EasyTray

batterymiser.exe 1756 Battery miser LG Electronics Inc.

ashDisp.exe 1900 avast! service GUI component ALWIL Software

lxbkbmgr.exe 2016 Lexmark X1100 Series Button Manager Lexmark International, Inc.

lxbkbmon.exe 2096 Lexmark X1100 Series Button Monitor Lexmark International, Inc.

jusched.exe 2088 Java Platform SE binary Sun Microsystems, Inc.

iTunesHelper.exe 2392 iTunesHelper Module Apple Inc.

IPOperator.exe 2408 IPOperator MFC Application

PrintScreen.exe 2464 PrintScreen captures the contents of the screen with a single keystroke. Gadwin Systems, Inc.

HOMERunner.exe 2512 System Tray application for TomTom HOME TomTom

pddlghlp.exe 2796 PowerDesk Dialog Helper Avanquest Software USA, Inc.

firefox.exe 3608 Firefox Mozilla Corporation

PDExplo.exe 1920 PowerDesk Pro Avanquest Software USA, Inc.

procexp.exe 1328 0.99 Sysinternals Process Explorer Sysinternals - www.sysinternals.com

PDExplo.exe 3572 PowerDesk Pro Avanquest Software USA, Inc.

HiJackThis.exe 3820 HijackThis Trend Micro Inc.

Process: System Idle Process Pid: 0

Name Description Company Name Version

----------------

If any of you knowledgable guys has the patience to go through all this ulabagula, you are a hero!

Thank you for any help to fix this problem.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.