Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 1.9 alpha 15380

Recommended Posts

It's bug or I'm doing something wrong (settings are default...) ?

And if this isn't a bug, how can I restore upload limit like it was in 1.8.2... ?

real upload is 2x higher than upload limit, in version 1.8.2, I remember that this worked properly...

hs9btx.png

Share this post


Link to post
Share on other sites

Yeah, it's great how it can get so much more out of the upload in my connection without effecting anything else!

If I was operating under restrictive upload limits the lose of control would be dissconcerting.

Share this post


Link to post
Share on other sites

For this version, I have a query.

I wonder why is it that when I set the uTorrent options to be using only a single port for both outgoing and incoming connections (so that I can use QOS settings to set priority on it), I can't seem to get it work for my Windows XP x64 system. It does work on my existing Windows XP x32 system. I have checked settings on both uTorrent's configuration windows and they are already the same.

Can anyone help me out on this?

Thanks in advance.

Share this post


Link to post
Share on other sites

uPnP doesn't work if there is no active network connection when µTorrent starts.

[2009-06-27 19:43:38] UPnP: Unable to map port 127.0.0.1:28767 with UPnP.

Only seems to start working again after disabling/re-enabling uPnP.

Share this post


Link to post
Share on other sites

My guess would be that right now, V 1.8.3 is very much like 1.9 but with less bugs... So my preference would be (and is) to use 1.8.3 WITH bt.transp_disposition=15 and net.calc_overhead = true until this 1.9 release is in sync with 1.8.3 latest changes...

Share this post


Link to post
Share on other sites

@Virtual_ManPL

i believe its a bug and it has to do something with the uTP. in 1.8.3 the u/l goes over the limit whenever the incoming uTP is enabled (bt.transp_disposition = 15)

Share this post


Link to post
Share on other sites

I've just woken up the the "can't save dump" crash dialog... Windows takes over and I get the DEP balloon.

Bizzare, DEP has been supported for years, hasn't it?

I have 3 crash dumps, but MegaUpload doesn't seem to have an easy way of uploading any more, suggestions?

(build 15380 on server 08 sp2)

Share this post


Link to post
Share on other sites

Wow, I don't believe it, that I reach over 121Kb/sec after the installations, before this my speed was utter slow which is below 20Kb/sec. Well done, I'll continue use 1.9 if it is good connections and speed... :)

Share this post


Link to post
Share on other sites

@Rafi Of course! My faulty memories' fault. If I wasn't shaped so much right now I probably could have figured that out on my own.

I think it had something to do with the interference on my wifi bridge.. or the dns cache on my router dying... still crashing is bad. I have not been able to reproduce since changing the channel on my wifi and rebooting both routers anyway.

Crash Dumps: http://www.mediafire.com/?sharekey=eeca0337c7664e3f67cd7f7bd65f7eefe04e75f6e8ebb871

Share this post


Link to post
Share on other sites

Ever since installing 1.8.3 my connection is either yellow or red. With 1.8.2 (build 14xxx) I always had a green connection. Can't find build 14xxx anywhere either :(

Share this post


Link to post
Share on other sites
Reply to Kiwi

For this version, I have a query.

I wonder why is it that when I set the uTorrent options to be using only a single port for both outgoing and incoming connections (so that I can use QOS settings to set priority on it), I can't seem to get it work for my Windows XP x64 system. It does work on my existing Windows XP x32 system. I have checked settings on both uTorrent's configuration windows and they are already the same.

Can anyone help me out on this?

Thanks in advance.

Hey Kiwi I have observed this phenomenon as well and the way I got through with this is the following. Before I begin, my QOS has been administered from my Linksys Router running Tomato. Now initially I had one rule and it was port based, uTorrent ran with a mind of its' own. Now what I changed to that worked was having two rules both were still port based and now also protocol based, one for UDP and the other for TCP. I gave the TCP transmissions a Higher Priority compared to the UDP. Another way doing this is to have a single TCP and Port based rule set to whatever Priority you like. The reasoning for this is that uTP built into uTorrent is designed to rate limit the UDP part of the connection automatically, it doesn't perform well when outside influence is put in place. What I have observed is that with both TCP and UDP on the same QOS lane, uTP doesn't seem to stay ahead of the QOS curve (a uTP frequency cycle issue?)

So again, I have a bad way of explaining things, but what I'm saying is that you should make two lanes for both the UDP and TCP parts of the transmission, preferable with UDP being either lower (hence it can perform better as a way to help TCP by sensing congestions faster) or auto govern itself with no rule put in place for the UDP aspect of the connection on that port.

Hey is a next beta coming? This is seemingly more and more becoming like Google Projects as things just won't come out of Beta? Please folks spare me the knee jerk reaction for saying that last sentence an old timer here just can't help but wonder?

Edit: On second reading, I seem to have replied in a tangent. But you need to give more details. Simplest thing is to do a step by step approach. First reset all settings back to default, and re change things until you find what is wrong. Change the settings in the Advanced settings page last, as that maybe where the problem is coming from.

My hunch is that the problem could be that there may internally (through the Advanced settings) be two IP's uTorrent is trying to bind with ... net.outgoing_ip, and net.bind_ip. I believe the conflict is that there is two IP's trying to use one Port. Or the problem could be that the Advanced setting net.outgoing_port has a port associated to it and you didn't see it. More info would be good in this case, but if you want to give it a crack my settings (which is similar) is the following for those problem settings outline:

net.bind_ip is (empty space) [Default]

net.outgoing_ip is (empty space) [Default]

net.outgoing_port is 0 [Default]

[Default] means that it is the default setting, and you can reset it from the Advanced settings page. All other settings are done through the non-Advanced settings page, primarily in your case the Connections settings page is your place to set things right. So then set your port (it encompasses both TCP and UDP), and make sure "Add Windows Firewall exception" setting is checked off. Now remove the Windows Firewall rule you made manually (if you did?), as it could conflict with the Auto rule exception that uTorrent will make on start-up.

Hope it helps, and the top part is for the QOS setup later on ;)

Share this post


Link to post
Share on other sites

@KnifeyWifey: Maybe just to be sure it still maintained ;)

But the more interesting question for me is, who am I uploading to at this rate?

qsv605.jpg

Share this post


Link to post
Share on other sites

niksus said: "who am I uploading to at this rate?"

You're uploading to that 1 seed you're connected to. At such a high download speed, ALL the reply messages and continuation messages you have to send back to the seed is about 1/20th as fast as your download speed. :(

It'd probably be slightly less if the torrent used larger pieces.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.