Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 1.9 alpha 15380

Recommended Posts

I just found something interesting with µTorrent 1.9 and I'm not sure why.

I was using it on a Windows 2k3 server that i have on the same network as my notebook (Vista) (which I usually use for µTorrent, but figured I could run it on the server because its always on). Anyways, so I installed µTorrent 1.9 to give it a shot on W2k3 because it was working beautifully for me on my notebook but it didn't perform as well on the server.

I was puzzled at this because if I ran it on my notebook and the server (both clients using different ports [poor little router]) my notebook's speed would be much faster then the servers. I pondered this for a few days, tired to make the settings the same for both, at least the ones I though would make a difference, but all with no luck.

Then it hit me, why not try using the same settings.dat file for the W2k3 client as I do on my notebook. So I made a backup of the fresh file from µTorrent 1.9 and copied over my other copy. Now the downloads are acting similar.

The only thing that I think is special about the file from my notebook is that it is for the days of µTorrent 1.8 where as the W2k3 file if fresh from 1.9. I'm not sure on what has changed in this file but something is making a difference.

Just thought I would let this out, and if there is any test that I should run let me know. Has anyone else noticed something similar?

P.S. Both computers are running the latest beta. The settings file has survived though all 1.8.x excluding 1.8.2 as it came out after 1.9.

Share this post


Link to post
Share on other sites

It's probably because versions of Windows before Vista had really badly tuned TCP/IP stack defaults. There are various programs around on the internet to tune it. Or just load w2k8 / vista or w2k8r2 / 7 which has a completely new one with sensible defaults.

:-)

edit: http://www.unblocka.com/ seems virus free, if ugly.

Share this post


Link to post
Share on other sites

Neronut , why don't you send/post for the devs those two sets of your dat files so they can analyze the differences ?

Share this post


Link to post
Share on other sites

Because it's not part of the bittorrent protocol and it is contrary to the goals of bittorrent and µTorrent.

Also, this is not a feature request thread.

Share this post


Link to post
Share on other sites

then where can i ask or this request ?

this ability is in BitSpirit but only between its own users not other i think we can ask peers and seeds some impotant things while on a runnign torrent

tell me the request page plz

Share this post


Link to post
Share on other sites

Ya, the speed performance jumped when i switched to it.

it was chugging along at about 20 kB/sec, then when switched it jumped to about 200 kB/sec. Weird I know.

Share this post


Link to post
Share on other sites

I have been using alpha build 14589 for a while now and it has been quite stable on my windows7 i7 box.

I find the uTP/bandwith_control or whatever is responsible for the link/ISP congestion control outstanding.

So good in fact that I don't use the scheduler anymore and still don't get complaints from the wifey about slow internets.

Recently I tried the 14659 build but it seems to have issues with download AND upload speed. I have always been able

to max out my upload but not with this build. I tried changing the value of bt.transp_disposition to values other than 255

without improvement.

I have rolled back to the previous build.

Share this post


Link to post
Share on other sites

ya my µTorrent 1.9 alpha 14659 also face the same problem in windows vista ultimate.....

Update = I have rolled back to the previous build 14589 to max up my upload

Share this post


Link to post
Share on other sites

menu - advanced->bandwidth allocation seems to have very little effect (if at all) in this release (uTP+TCP|255)

two torrents with the same # peers/seeds (~120 connected for each) seems to get an even DL speed even if one is defined with high bandwidth allocation and the other - low. Both are multi-files torrents all set to "normal" priority

Share this post


Link to post
Share on other sites

Hi guys, first of all.. NICE WORK.

Second, i ahave a problem, my utorrent does not automaticly update. ( i already check the options table )

And if i click "Check for update" it still says me that the is no update available this time.. Can you help??

Thanks

Share this post


Link to post
Share on other sites

this might be a stupid question, but im gonna go for it anyway :):

is there a way to enable ONLY uTP connections? since my ISP seems to manipulate tcp connections and as soon as Im connected to a tcp peer my bandwidth is lowered.

Thank you

Share this post


Link to post
Share on other sites

i read that and i was just wondering if uTP can help me since my problem is NOT throttling, their limitations seem to be based on protocol not port. My question still stands, whether you think it helps me or not, can you enable uTP connections ONLY?

Share this post


Link to post
Share on other sites

i did try the build but didnt know about that option, thank you, this answers my question. now is there anything like that for incomings?

thanks for quick and constructive replies.

OK i found the info its "bt.transp_disposition 10" for uTP connections only in 1.9

Share this post


Link to post
Share on other sites

My router Freezes( Crashes )Up with latest alpha build of uTorrent sad <- afto unplug to get my internet back..

This happens in like 2-5minutes after I opened uTorrent with 5 files

I dunno how to get enough data to get this uTorrents bug fixed..

I am using TRENDnet TW100-BRF114 <-I dunno why it can't handle the new packet sizes or something else made by uTorrent

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.