Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 1.9 alpha 15380

Recommended Posts

-diskio.no_zero=true

What's the advantage here? Doesn't that mean that it won't preallocate the space required for the file? Isn't the preallocation a good thing for lowering incesant disk writing and file fragmentation?

Share this post


Link to post
Share on other sites

HELLO.

help me please..

after installing the new version now i can download on full speed1!!! thanks !!!

BUT!!!

im getting BSODs all the time with TCPIP error...

what should i do!?

Share this post


Link to post
Share on other sites

osmosis: http://forum.utorrent.com/viewtopic.php?id=46473

superbizho: A BSOD with tcpip.sys indicates bad networking drivers. Update your drivers. If that doesn't work, make a new thread with µT build number, network adapter being used, if it's a wireless, and your ISP. Also make sure you are configured properly, no YouTube settings. Configure using #1, and if you still have issues after configuring with #1 and updating your drivers, try the conservative settings in #2.

1: http://www.utorrent.com/setup_guide.php

2: http://forum.utorrent.com/viewtopic.php?id=34259

Share this post


Link to post
Share on other sites
Firon:

We'll have a new alpha...

oh ? this is a major fix, regressing uT from beta to alpha, eh ? ... :P

btw, will this attend to the inaccurate speed limiters' issue too ?

Share this post


Link to post
Share on other sites

right... it still can be... you just have to change one word in the code... :)

Share this post


Link to post
Share on other sites

is it possible to have different bt.transp_disposition options for LAN (10.* 192.168.* 172.x.*) and for Intrenet?

On LAN I have full 100mbit UL/DL with TCP and <10mbit with uTP.

and on "normal" internet with uTP I have better speed than TCP.

Share this post


Link to post
Share on other sites

@ bt.transp_disposition = 15, XP SP2, ADSL 1.6Mbps/160Kbps ,2 DL tasks 1 seeding task, 2 slots per task, calc_overhead = true

- download limiter is still broken in here ... :(

- upload speed (measured with external tool) is still above the UL limit (~200 connected peers, calc_overhead=true)

- clearing of the main listview on download click in the RSS view - is still happening

99590894.jpg

By rafi_d

36999410.jpg

By rafi_d

Share this post


Link to post
Share on other sites

Thanks for the 14981.

Since uTP is now optimized for "full" MTU of 1500, any directions about tweaking Win AFD's FastSendDatagramThreshold value ? Is default 1024 ok or can be optimized for 1500?

http://technet.microsoft.com/en-us/library/bb726981.aspx

http://technet.microsoft.com/en-us/library/cc781532.aspx

And so, FastCopyReceiveThreshold ?

Thanks again. GREAT NEWS, DEP finally!

Share this post


Link to post
Share on other sites

@rafi

Any tips on how I can reproduce this? Does it happen when uTP is disabled (bt.transp_disp = 5)?

It's been working perfectly for me since this fix, any hints would be appreciated.

Share this post


Link to post
Share on other sites

Same thing as rafi here. Vista SP1. Cannot limit upload. Tryed bt.transp_disp = 5 bt.transp_disp = 15, all the same. Forced limit upload at 15k, and it's at 50k. BUT, if I limit it to 3k, then the actual speed is around 15-20k. Hope this info helps.

Share this post


Link to post
Share on other sites

I can't set upload limit in 14981.

When bt.transp_disposition=15 and up limit = 10kB, it upload 40+KB all the way ( my conn is 1M ADSL which has 50~KB/s ul ).

Share this post


Link to post
Share on other sites
arvid:

Any tips on how I can reproduce this? Does it happen when uTP is disabled (bt.transp_disp = 5)?

It's been working perfectly for me since this fix, any hints would be appreciated.

Well, I can see that a few other users have reported the issue, most with ADSL and low UL (maybe this is the case the issue manifests itself more) . What I can suggest for you is to try the same configuration (I'll email you my dat files) and focus on low UL limit (~10-15K). Make sure you measure with some external tool .

AS for the test conditions: 2 DL tasks and one seeding task with ~3-4 slots was enough to cause it. Make sure you have a popular torrents (~1000+ peers).

It was no effort at all to "break" the DL limit. with the UL limit - it was more "difficult" to see it on the speed graph, but you could see it easily with an external tool.

I guess we can count on the the report you had in the 1.8.3 thread that with TCP it performed good, but you are more interested in uTP , right ? ...

I can only point out one more thing, that in my case - I am behind a NAT and had to change the external IP with my ISP ( actually switch to another ISP) a few times during the download. Maybe it is related.

good luck!

Share this post


Link to post
Share on other sites
hharis:

last night with new 14981 i set net.calc_overhead to false;

uploads are good.

Yes, same here... I think you are on to something... here is what I get with one torrent downloading:

When I start a torrent DL with calc_overhead - true - DL limiter fail to work correctly (also if I turn it off afterwords). Only when I turn it to false AND ONLY then start the torrent - it works... :)

Pay attention also to the fact that the UL shows a big overhead and drops almost the full 10K I allocated when the DL is only 50K ... :(

edit:

also - with trans_disposition = 5 - all is well... so, as expected, it's the new code that should be blamed...

61028341.jpg

By rafi_d

Share this post


Link to post
Share on other sites

glad to help...

its still cca 20% slower dawnload with 1.9 14981 then with 1.8.3 14984.

but there are not so many 1.9 useres.

Share this post


Link to post
Share on other sites

Using 1.9 14981.

For the bt.transp_disposition setting.

1 - outgoing TCP

2 - outgoing uTP

4 - incoming TCP

8 - incoming uTP

Specific combinations:

255 - both TCP and uTP, incoming + outgoing (future-proof setting, always will mean this)

15 - both TCP and uTP, incoming + outgoing (default)

Right ?

So if I use 28 in the bt.transp_disposition setting, I should only get uTP connections, right ? When I'm using 28, I get uTP AND TCP connections... To get only uTP, I have to set it to 10. What I'm I doing wrong ?

Share this post


Link to post
Share on other sites

It's a bitfield, that means you have to add them. So to get TCP only you use 1 + 4 = 5, to get uTP only you use 8 + 2 = 10, et cetera. 255 just happens to include all of them - if you used 254, you wouldn't get outgoing TCP.

Share this post


Link to post
Share on other sites

@rafi Thanks a lot! I managed to reproduce this. It was connected to a recent change in 1.9 and should not affect 1.8.3. It will be fixed in the next 1.9 alpha.

Share this post


Link to post
Share on other sites

no problem. so, should we better use 1.8.3 for now? or it's kind of a single-quick-fix/alpha in the 1.9x tree here?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.