Jump to content

µTorrent 1.9 alpha 15380


Firon

Recommended Posts

in the 14981 global speed limit was fixed, but per-torrent limit (torrent context menu -> Bandwidth Allocation -> Set Download limit) is still broken.

I was using both a global and per torrent restriction and it still had a mind of its own :S

Link to comment
Share on other sites

  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Is there a way to disable all internal rate-limiting / automatic speed thingies? I'm having a terrible time getting uTorrent to properly fill its upload? This wasn't a problem on 1.8.x and isn't a problem on other P2P apps (eMule does it perfectly). But 1.9 sometimes seem to cap itself well below the available bandwidth. It even seems to do this for downloading. It starts of fast, but then slowly moves down and for some reason, people start snubbing me. Vuze or Halite don't seem to have this problem, not do other P2P apps.

Already tried doing a clean install of uTorrent, cleaning out all files in the Application Data folder and using the default settings.

Link to comment
Share on other sites

I keep getting UDP port mapping errors with UPnP

[2009-04-15 18:41:03]  UPnP: Discovered host: http://192.168.1.1:2869/IGatewayDeviceDescDoc[2009-04-15 18:41:03]  UPnP: TCP port 34056 -> 192.168.1.80:34056 is already mapped. Not re-mapping.[2009-04-15 18:41:03]  UPnP: ERROR mapping UDP port 34056 -> 192.168.1.80:34056. Deleting mapping and trying again: (718) The port mapping entry specified conflicts with a mapping assigned previously to another client[2009-04-15 18:41:03]  UPnP: Removed UDP port 34056[2009-04-15 18:41:03]  UPnP: ERROR mapping UDP port 34056 -> 192.168.1.80:34056: (718) The port mapping entry specified conflicts with a mapping assigned previously to another client[2009-04-15 19:01:06]  UPnP: Discovered host: http://192.168.1.1:2869/IGatewayDeviceDescDoc[2009-04-15 19:01:06]  UPnP: TCP port 34056 -> 192.168.1.80:34056 is already mapped. Not re-mapping.[2009-04-15 19:01:06]  UPnP: ERROR mapping UDP port 34056 -> 192.168.1.80:34056. Deleting mapping and trying again: (718) The port mapping entry specified conflicts with a mapping assigned previously to another client[2009-04-15 19:01:06]  UPnP: Removed UDP port 34056[2009-04-15 19:01:06]  UPnP: ERROR mapping UDP port 34056 -> 192.168.1.80:34056: (718) The port mapping entry specified conflicts with a mapping assigned previously to another client[2009-04-15 19:21:06]  UPnP: Could not map UPnP Port on this pass, retrying.[2009-04-15 19:21:09]  UPnP: Discovered host: http://192.168.1.1:2869/IGatewayDeviceDescDoc[2009-04-15 19:21:09]  UPnP: TCP port 34056 -> 192.168.1.80:34056 is already mapped. Not re-mapping.[2009-04-15 19:21:09]  UPnP: ERROR mapping UDP port 34056 -> 192.168.1.80:34056. Deleting mapping and trying again: (718) The port mapping entry specified conflicts with a mapping assigned previously to another client[2009-04-15 19:21:09]  UPnP: Removed UDP port 34056[2009-04-15 19:21:09]  UPnP: ERROR mapping UDP port 34056 -> 192.168.1.80:34056: (718) The port mapping entry specified conflicts with a mapping assigned previously to another client[2009-04-15 19:33:03]  UPnP: Discovered host: http://192.168.1.1:2869/IGatewayDeviceDescDoc[2009-04-15 19:33:03]  UPnP: Removed TCP port 34056[2009-04-15 19:33:03]  UPnP: Mapped TCP port 44365 -> 192.168.1.80:44365[2009-04-15 19:33:03]  UPnP: TCP port 44365 -> 192.168.1.80:44365 mapped successfully.[2009-04-15 19:33:03]  UPnP: ERROR mapping UDP port 44365 -> 192.168.1.80:44365. Deleting mapping and trying again: (718) The port mapping entry specified conflicts with a mapping assigned previously to another client[2009-04-15 19:33:03]  UPnP: Removed UDP port 44365[2009-04-15 19:33:03]  UPnP: ERROR mapping UDP port 44365 -> 192.168.1.80:44365: (718) The port mapping entry specified conflicts with a mapping assigned previously to another client

WHy is the TCP happily mapping? When I look at whats mapped with UPnP it shows µTorrent (TCP) only. Weird.

Link to comment
Share on other sites

I'm not sure if this has been mentioned or not, and I've tried to search in this thread, but is DHT, Local Peer Discovery and Peer Exchange supposed to be disabled by default in this version? Even if I turn it on in preferences, the status is always "not allowed" regardless of tracker.

Link to comment
Share on other sites

I see, thanks for your help.

Looks like Bell has started doing something to the uTP traffic. When I have bt.transp_disposition set to 10, I can't seem to connect to anyone. When I have it set to 15, I can connect, but it seems to be throttled. I'm using port 1723 if that matters.

After resetting my modem, I ran uTorrent again with bt.transp_disposition set to 10. I can connect to peers, but the speed seems throttled at the ISP's usual throttle limits. Though after I changed the port to 1723, the speed seemed to jump right up. I set bt.transp_disposition to 15 and changed the settings to enable DHT, Local Peer Discovery and Peer Exchange and changed the Encryption setting to Enabled and allowed legacy incoming connections; the speed slowed down within a few minutes. I changed the setting back to 10, disabled DHT, LPD and PEX, forced Encryption and disallowed legacy connections and the speeds increased once again.

I then tested the bt.transp_disposition setting once again by setting it back to 15. Speed did not seem to be throttled.

Link to comment
Share on other sites

@animeking: Bell has a tendency to throttle for about 16:00 till 2:00 although depending on load they will lighten up a bit (30kB/sec -> ~50kB/sec [which is a lot for Bell apparently]). I noticed that your original post was at 17:53 but the edit was at 1:16 which the speed increase matches the timing of them letting more flow though.

The uTP issue may be similar to mine where the client isn't mapping the UDP ports with UPnP (this would only happen if it was enabled in the client and your router supported it.) If the port won't map the uTP speed will be brutally slow. If this is the case, the second time you tried it may have actually mapped the proper ports which would help the speeds greatly.

Link to comment
Share on other sites

i know bt.transp_disposition settings are on a lot of pages but I cant find what im looking for. Ive been trying to play around with the bitfield but couldnt get this result:

Incoming: uTP ONLY

Outgoing: both uTP and TCP

Can some1 help with this?

( 1.9 alpha 14981 thats why i post here)

Thank you

Link to comment
Share on other sites

When µTorrent starts, It tries to open the Windows Firewall. But this attempt is always a failure : "[2009-04-24 11:59:10] Error opening Windows firewall: 0x80070005 Acces denied." because this action is limited to the accounts with admin rigths.

Windows detects automaticaly that the application must have an acces to the firewall, and displays the popup of configuration, and preserves the settings. Why not remove this action since useless ?

Link to comment
Share on other sites

Why not remove this action since useless ?

a) There is a setting to turn it off. (Options -> Connections)

B) If you run with the rights to alter the firewall (not necessarily full admin), it is not 'useless' but quite useful.

Link to comment
Share on other sites

I've installed the latest 1.9 build 14981 alpha from the 1.77 stable and whereas before I can saturate my wireless 802.11n line (where even browsing no longer works or works VERY sluggishly), now it uses only about half the bandwidth. Using MS Vista, and even copying from a network share can also saturate my connection but latest uTorrent can't. I'm downloading from a server one floor down from me.

It's all local transfer, no other network activity. Is uTorrent doing QoS and throttling back? I already have a router to shape the traffic if needed. I immediately switched back and traffic is once again blazing fast. You might wonder why I use uTorrent for local LAN transfers and the reason is because for time consuming, huge transfers, whereas any lengthy interruptions will cause a failure, uTorrent will gracefully resume.

What settings should I use for 1.9 alpha so as to get maximum LAN transfers between computers or is this slowdown a "bug" of uTP?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...