Archived

This topic is now archived and is closed to further replies.

Ultima

File association bug...

Recommended Posts

Right, so I was trying to merge some threads, and somehow, the Move Posts feature screwed up and deleted both threads. Not so nice. I'm recreating the thread, but I can't recover the old posts in their original forms (sorry about that!).

At any rate, the main issue was that there was apparently a bug in OS X that was causing applications to crash when they tried to look for applications associated with certain file types. That means almost any application can crash, including Safari and Firefox, but it was most commonly seen crashing Finder (because that's where most users open their .torrent files from). This may have been aggrevated by an issue in µTorrent.

v0.9.0.1 is supposed to gave fixed the bug, but several users have experienced crashes in that version indicating otherwise.

Edit: Hm, I still have a copy of the first page of the original thread in my browser cache.

Share this post


Link to post
Share on other sites
I may not have my associations set correctly, but every time I download a torrent and double click it, rather than it open utorrent and add it to the torrent list it crashes finder. The same thing happens if utorrent is allready running. The only way I can add the torrent is by dragging it into the window or by right clicking it and click open with utorrent even though utorrent is the default app to open that type of file. Is any one else having these issues?
It's a problem with Finder, not uTorrent. The devs are working on a workaround for this though. If you want, submit a bugreport to apple at http://bugreport.apple.com as well.

/edit: Just to update: It's a bug with OS X and uTorrent's info.plist. Not Finder. Sorry about that.

hmm thats weird!!! Do you know why does it work with transmission and vuze?
Repair you disk permissions by going to finder applications then utilities then disk utility select you disk under then click on first aid tab click on repair disk permissions.
I'm not quite sure why it is crashing Finder here, i'll have to defer that one to the devs.

And repairing permissions isn't going to do anything here.

Yea you're right, I just tried to repair the permissions the same thing happens. Thanks for forwarding it on to the guru's hope they can fix it.
Yes, my finder also crashes when I double click a torrent file associated to uTorrent
Indeed, known issue. I'm not completely certain it's a Finder issue. AFAIK, the devs didn't actually comment on the problem when it was found during internal testing, so the actual cause has not yet been determined.
Odd, seems to work fine for me currently, not sure if it's because of how I deal with torrents though.. rather than opening them in Finder from the "Downloads" folder, I use the "Downloads stack", which hasn't caused an issue so far.
I tried torrent through download stacks and same issue. :(
Yup i just did that can it crashed my dock and finder at the same time, by using the stack or the finder to open it....crashes!
the only way for me to actually open the torrents at the mo is to right click > open with > utorrent
For the record, you can also drag and drop torrents into uTorrent. Or open them from uTorrent once the app is already opened.
+1

Me too - double clicking crashes the finder and the dock

OS 10.5.5 PPC G4 1.25Ghz

Technically, it's a bug in mac os that causes any application that tries to find a default app for a file extension which causes Finder/Dock and other apps that will try to do it to crash. Hopefully Apple will fix that.

Having said that, I'm guessing the bug is triggered by our Info.plist so I'm hoping I'll be able to work-around that in µTorrent by changing µTorrent's Info.plist.

I've noticed the same bug, but it appears to produce different behaviour dependant on whether uTorrent is already running.

If uTorrent is not running, opening the torrent file from Firefox (by clicking a download link with the correct associations set within Firefox) causes uTorrent to launch but does not add the torrent. Double clicking in the download window causes Firefox to crash as previously reported. If uTorrent is already running, opening the torrent file from Firefox(by clicking a download link with the correct associations set within Firefox) produces the expected result - the torrent is added to the queue. However, double clicking the torrent file in the download window still causes Firefox to crash even if uTorrent is running and has previously added files properly when a download link was clicked.

The problem with opening torrent files from Finder appears to be different, as it continues to crash Finder regardless of whether uTorrent is already running.

Not sure why this would be the case, but a workaround appears to be opening uTorrent prior to clicking the download link in Firefox (and having the file associations set in Firefox to open torrent files with uTorrent).

same here,

when i associate .torrent files to uTorrent:

- opening from finder causes crash of finder (relaunch)

- opening from safari's downloads list causes crash of safari

repairing permissions doesn't solve anything

(for me it's not finder bug)

(for me it's not finder bug)

As kjk said' date=' though, it never was a Finder bug to begin with -- it's an OS X bug that is potentially aggrevated by something funky in µTorrent. Any application can crash in the same way Finder is for most users here (as you've seen with Firefox and Safari).[/quote']

I am also having the same problem. I am unable to open torrents associated with uTorrent and when I try Finder crashes. I also cannot right click on the torrent file and select Open or Open With. The only way to have the torrent added is from within uTorrent through File, Open Torrent.
I just want to report that using µtorrent version 0.9.0 and it is working fine for me. I'm using Mac OS X 10.5.5 Intel.

I have µtorrent as my default .torrent handler within Firefox and have no trouble launching .torrent files into µtorrent from that browser. Also, I'm able to double-click .torrent files from any location and have µtorrent download the files. This is with µtorrent closed or running.

I think that if people who are running this on OS X are going to report an issue, they need to specify their operating system and version as there are differences between the Intel and PPC that may cause issues since µtorrent is officially supporting Intel at the moment.

This bug isn't architecture or system dependent. Happens on my Intel mac.
Don't just repair permissions from the utility app. I boot-up with my installation disc and run repairs from it rather than my harddrive.
I'm running Leopard 10.5.5 and have this issue where Finder restarts itself. I wanted it as my default file handler in Firefox, however I cannot. Like many posters here I have not found a solution.
An update that fixes this problem will be released soon.
very nice... thanks

I just downloaded Utorrent version 0.91 and it works no more issues with associations or finder crashing. Great work guys!

Share this post


Link to post
Share on other sites

File association now works,however upon double clicking a torrent file uTorrent launches but does not start the torrent. Double clicking the torrent again, once uTorrent is open starts it.

Getting closer. :)

Share this post


Link to post
Share on other sites

i was experiencing a similar issue. Here is the fix that I discovered.

select a torrent file and CMD + I to get info.

then select µtorrent as the application to open with.

then click change all and voila.

done

Share this post


Link to post
Share on other sites