Jump to content

uTorrent won't port forward suddenly


Recommended Posts

I've recently switched to BeThere (UK), great speeds, great for torrents, but apparently bad for utorrent.

Now, i've tried this with both the supplied "BeBox" and my own Linksys router. Torrents aren't blocked because Vuze connects fine (thought i'd better check it wasn't traffic shaping). uTorrent seems to work on the downstairs pc (router -> wired downstairs, wireless to this pc upstairs).

I tried to download a torrent today, and utorrent wouldn't connect to DHT. Odd, since it was working fine up until the switch, and it had been working fine on the computer downstairs. I have no idea what's going on. I've forwarded the port through the router, which i did once a while ago and then never bothered again after i realised that utorrent seemed to be coping fine without me doing it.

Is there any reason why it's not forwarding correctly - or indeed at all? The router says the port's open, but uTorrent patently disagrees :P


Link to comment
Share on other sites

I'm not sure I could understand your post.

When you say that your pc can't connect to DHT, do you mean it won't connect to any peers or just that DHT won't work (excuse my ignorance).

Are you saying that:

1) both pc's are connected via the same router and that both are portforwarded with static ip's using the same port?

2)Utorrent is telling you that the port is blocked?

3) One pc (connected to router via cable) works fine but the other wirelessly connected PC is presenting the DHT and or peer connection problem?

I'm not saying that I can help you - just that perhaps others will be able to if they can understand the exact problem.

Good luck.

Edit: if utorrent is telling you the port is blocked on both pc's I'd assume that it is indeed blocked, no matter what the router is showing. Just keep trying and maybe change the port altogether.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...