Jump to content

default download location not being saved


Recommended Posts

It probably is. Not to worry.

Strange thing is, later on I was not connectible. I could connect to others, (but only 1 person from the using 50) but they could not connect to me. I noticed this as my upload went from 100k to 0 on every torrent I tried, as well as ones I was seeding. Utorrent would report that the port was open (green in the bottom right). The port was forwarded, (same port number as Vuze) even the websites that tests if the port was open said it was. Also the Mac firewall stated that utorrent accepts incoming connections, but alas nothing, I was not connectable.

Rebooting the Mac, the router, removing utorrent from apps folder and deleting the information left in the Library application support folder would not help. For some strange reason I am no longer connectable with utorrent but was before.

I am sure you guys will make utorrent for the Mac great, as when it was working it was working very well and fast. But for now as I am not connectable I will have to go back to Vuze, and live with the slowdown and the system hog. Good luck.


Link to comment
Share on other sites

Hey, me too. This is truly bizzare. And it's not just the Downloads folder, it's a whole bunch of arbitrary preferences not being saved.

I have two Macs, a Macbook Pro (Intel) and a Mac Mini (G4 PPC). On the Macbook, it is working just fine, but on the Mac Mini, the prefs are just not being saved consistently. It WAS working ok, but now it isn't. I have already tried the following:

-Deleted uTorrent folder from /Application Support.

-Deleted the .com.bittorrent.plist (or whatever it is) file from /Library/Preferences

-Deleted the application bundle, re-downloaded and re-installed.

-Checked file permissions on all of the above, so they're definitely writeable.

And yet, the problem persists. I strongly suspect there is a significant bug in the parsing of preference data, but only in certain conditions. Sometimes, a few preferences will save, after which they'll remain the same, but other times no changes take.

Consider this a major bug I'd say. Hopefully the developers will be able to figure it out.



Edit: Just from reading the above posts, it appears all of us having this problem are having it on PPC Macs. Likewise with me - my Intel Macbook is working just fine.

Link to comment
Share on other sites

Ok its confirmed its a bug with the PowerPC Binary. From what has been stated it does not affect Intel Chips but G based Chips.

Now when the code for PowerPC has been polished, we will see if it happens again (it shouldn't as it has been stated here).

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...
  • 1 month later...

I can only confirm evilvampire's post.

I have a 1,5 ghz powerbook G4 running 10.5.6 Leopard.

Whenever i change the "default download location" the new settings seem never to be saved somewhere.

This actually makes Utorrent unusable to me, because i do only have little internal hard disk space.

I don't know anything about programming and stuff, but everyone of my friends and me is happily looking forward to have a functionable and good Utorrent application for mac.

I have tried the following:

- Azureus:

It and it's java seams to eat my CPU and RAM.


even worse than the above azureus and a hell of unnecessary features


slimmer than Azureus but sucks too, eats my computer...


What is so annoying about transmission is that it looks like a really slim application, but if you added 50 torrents and ran only 5 of them ALL torrent clients i tried heavily sucked.

All clients slow my computer down like hell and the even more disturbing thing is that i can't even give back to the bittorrent community.


Because every single client i ever used was providing terribly slow download when giving more than 20 kb upload...

...what would you do?

(Just to give an example, i know i'm in a Utorrent forum) If i set my transmission's upload speed limit to "unlimited" it kills my download. It looks like:

120kb UP / 37,4kb DOWN .... all that running 3 to 50 torrents, nothing i do can troubleshoot this, i can't really upload.

Please dear Utorrent mac developers, please take care of this stupid circumstance with your app.

Otherwhise the bittorrent community will allways call me a "stealer", "hit and run" or a "f*ing leecher".



Link to comment
Share on other sites

1st off, you have a relatively slow computer. So current apps and OS may bog down the CPU more often than people on 2.0GHz Dual procs.

I have seen web browsing eat a G4 processor on leopard.

2nd I suggest you check out some basic torrent info sites. Most of the problems you have issues with can be fixed by understanding how bittorrent works. You will always cripple your download speed if you saturate your upload bandwidth. Also you need to know if your ISP throttles your seeds. If they do you will need to get the correct encryption on your outbound packets or you will eventually lose all your site memberships. I run uTorrent and Transmission (sometimes) and have on average 2-3% proc usage. I can get my downloads to upwards of 1.5-2.5MB/s with no more drain on the cpu than downloading at 56KB/s. So I wouldn't blame Mac torrent apps in general. If you do some searching you will have the knowledge and you will succeed.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...