Jump to content

Any plans for a fix for speed issues behind routers?


Recommended Posts

Hey everyone,

I have had a nightmare of a time trying to get utorrent to download on my routers. I even went out and bought two new different ones and they all had the EXACT same issue. Here's the details:

I started with a WRT54GS V6 with the factory firmware update. It worked GREAT!! Then I decided to experiment with wireless bridging, so I bought a second WRT54GS which was a version 7.2. I then upgraded the firmware to DD-WRT v24 sp1. BIG MISTAKE! While the interface and features are very nice, no matter what I tried, Utorrent doesn't work. It shows me having an upload of around 50 kb/s even though I have it set to 100 and my dl stays around 1kb/s or so, but never goes up no matter how many seeds the torrent has or not.

So I tripple checked all of my settings, ports properly forwarded, firewalls turned off even, DHT disabled, setting max. connections to 30, I literally tried everything in 8+ hours and none of it made a single bit of difference. All Utorrent did was show the same speeds mentioned above and lag my connection out terribly bad. So I reversed the firmware back to factory on the WRT54GS v7.2 and then loaded the latest firmware provided by Linksys and tried again. No luck, exact same thing. Then I decided to perhaps test my computer itself and so I bypassed my router and connected straight to the modem and I got the awesome fast speeds I normally would get prior to my project.

I have a web server I recently started and I correctly have forwarded the ports on it to be reached by the world wide web, so it's definitely not an issue of not forwarding my ports correctly. I can go to my domain name and it directs as it's suppose to, both http and ftp access.

So in hopes of putting an end to the madness, I returned the WRT54GS V7.2 and bought a BEFSR41 v3.4 wired router and guess what . . . SAME FREAKIN THING!!!! Another 3-4 hours of going through every solution listed online and to no fortune. I then connected my WRT54GS v6 to the BEFSR41 and set it up as an AP for my wireless PCs. I gave it another go and I finally tested it being connected wirelessly and it actually works. But if I'm wired to either router, it won't work. This really sucks, because I have a very fast connection and it's neutered over a wireless connection. But every attempt from a wired connection to either router just chokes my network and fails when utorrent is loaded.

Oh, and the issue with the connection only exists when utorrent is running. It gradually begins to choke up after starting utorrent until I get the same connection problems like everyone else is reporting. I began to think perhaps it's an issue with newer versions of Linksys routers, but a quick Google search shows even Netgear customers are having issues with it too. Is there some "behind the scenes" conspiracy to put an end to torrents by making firmware/hardware incompatible with torrent apps? And has this become a common enough of an issue to where the developers are looking at the software and not at the consumer's hardware? I would like to think there is a fix for my issue, which the simplest would be me being able to revert my WRT54GS v6 back to a Linksys Firmware, but unfortunately there's no reversion software at this time to revert a version 6. How lucky can one get. . . .

Is there perhaps something that may possibly help resolve this issue? Something that wasn't posted in 2006 and that actually works unlike the 40+ other techniques I've already tried over and over again. Thanks for any help!

Link to comment
Share on other sites

Your ISP, ComCast, may have a minor influence on your results as they do disrupt BitTorrent traffic.

Your router/s also have extremely long TCP and UDP timeouts by default...which need to be reduced to no more than 5 minutes (using custom firmware) to prevent their memory tables filling up with entries for ips that disconnected hours ago.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...