Jump to content

Vista and slow download problem


Recommended Posts


I know that this topic was posted already, but I've found solution which worked for me - maybe for other user will it work too? Basicly problem with uTorrent (1.8.1 - now 1.8.2) on my computer was simple - very slow downloads (about 30 kB/s - limited download on status bar was off, ration - about 7, upload with 80% of total upload speed, many seeds/peers, tracker online, so everything was ok). Nothing worked - port forward, read & apply to setup guide, every solution on uTorrent forum & on other websites... I've didn't do one thing - patch TCPIP.sys file. Before applying patch I've tried solution which "increase the compatibility of Vista with older networking devices":

Disable the IP Helper service:

1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter

2. Scroll down to the IP Helper service, right click on it and select Properties

3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"

4. Then click on "Stop" to stop the service from running in the current session

5. Click OK to exit the dialog

Disable IPv6: (that I've disabled earlier)

1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter

2. Right click on each network connection and select "Properties"

3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)

4. Click OK to exit the dialog

NOTE: You should do this for each network connection.

Disable the DHCP Broadcast Flag:

Link: http://support.microsoft.com/default.aspx/kb/928233

1. Hold the Windows key and type R, enter regedit and press Enter.

2. Locate and then click the following registry subkey:

3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}

4. In this registry path, click the (GUID) subkey to be updated.

5. If the key DhcpConnForceBroadcastFlag does not exist, use the Edit menu, point to New, and then click DWORD (32-bit) Value. In the New Value #1 box, type DhcpConnForceBroadcastFlag, and then press ENTER. If the key exists, skip this step.

6. Right-click DhcpConnForceBroadcastFlag, and then click Modify.

7. In the Value data box, type 0, and then click OK.

8. Close Registry Editor.

NOTE: You should do this for each and every GUID subkey.

NOTE2: (GUID) is a mnemonic for the individual subkeys, the actual text "GUID" does not appaer.


Now everything works just fine. I've got very good download speed, everything works just perfectly. If it solution was already posted, I'm sorry - maybe I miss it.

Best regards

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...