Jump to content

Bittorrent crashes Connection -- tried the usual, read the FAQs


Recommended Posts

Whenever I use Bittorrent or utorrent, the application works well for a few minutes, but then I lose my connection.

I've tried plugging directly into the modem. (I use a TrendNet Wireless-N router, though I always plug in my main desktop.)

I've tried powercycling (in fact, I have to in order to regain my connection).

I've tried progressively lowering total connections from 800 to 500 to 200 to 50 to 20, and even to one! I've tried this for downloads and uploads.

I've tried progressively lowering the download speed cap and the upload speed cap, similarly to the above, including extremely low caps.

I've tried limiting half-open connections from 8 to 4 to 1.

I've used many speed tests from many sources (and gotten the impression that they're *all* wildly inaccurate) and set my upload speed accordingly, then also, like above, whittled it progressively.

I've disabled DHT and UPnP (including router-side UPnP).

I've disabled Windows Firewall and all other firewalls -- I've used the in-program utility to confirm that the port being used is indeed open. I have no antivirus OR antispyware programs that run regularly (I install, scan, uninstall, every few days -- and, yes, I've scanned recently with several of the well-known anti-malware programs like Spybot, as well as Avast! and ClamWin).

I've gotten new drivers for my NICs, and even tried rolling back to older drivers. I even bought a nice PCI NIC card (my mobo has two onboard ethernet controllers as well).

I've tried Windows 7 Ultimate (x64) and Windows Vista basic x64.

I've tried static a static IP.

I've tried switching out my Cat-5e's for Cat-6s.

I've perused (and heeded) Switeck's suggestions at http://forum.utorrent.com/viewtopic.php?id=34259 and http://forum.utorrent.com/viewtopic.php?pid=192027#p192027

I use a Motorola SURFBoard, but it hasn't been "neutered" by my ISP.

I've hacked my half-open connections with TCP-Z and it's reported at 252.

I've reinstalled utorrent, being sure to clear the registry of any residue.

I've reinstalled Windows 7 and reinstalled Windows Vista (basic x64).

I've swapped motherboards (which, yes, I realize may imply that this is a modem or router problem, but read above: I've plugged directly into the modem.)

To try to be more specific, I load up utorrent, then it connects to and starts downloading from six downloads (my current limit). My upload speed quickly hits its max (currently a conservative 75kB/s, though I easily upload around 256kB/s max), then my download speed takes about three minutes to reach around 200-400kB/s. After somewhere between two and six minutes (it's not consistent), the reported download/upload speeds drops quickly (about 30 seconds) to zero, at which point I can't access the internet at all, and I am forced to powercycle my modem and router (though I could probably use Windows' "repair" or release/renew from IPconfig, but I'm sitting right next to the boxes, so it's easy to just pull the plug out the back).

Firefox is able to download multiple files at a total download speed of 3 MB/s (yes, big B) without ever "crashing" the connection. OpenOffice.org, for example, will crash my connection via torrent, but has no problems downloading smoothly and *fast* via Firefox.

I have a Core 2 Q6600, running Windows 7 Ultimate, on a Gigabyte mobo, 2 gigs 1200Mhz DDR2... I use a Motorola SURFBoard SB5100... don't know what other specifications would be necessary...

ANY help, or even ideas I haven't tried, would be GREATLY appreciated. I am a d/l addict and have many torrents that are only partially completed :(

Link to comment
Share on other sites

Maximum upload rate: 75, automatic unchecked, alternate upload rate unchecked.

My connection runs steadily at 256kB/s (2Mbit/s), so 75kB/s should be a very conservative choke-preventing estimate.

Global Download Rate limiting: 0 (unlimited) -- I've tried limiting it progressively, as well

Current connections setup:

Global max: 80

Max per torrent: 20

UL slots/torrent: 3

additional upload slots, checked

I've reduced these as far as 1, 1, 1 and 3, 2, 1, just to check -- problem continued, so it's not number of connections.

I believe that my ISP, Comcast, is likely blocking bittorrent traffic, and I plan on calling them and yelling at them, but I doubt I'll get anywhere. Glasnost reports Comcast as the biggest offender for such blocking, and their test crashed my internet -- the only time my connection has dropped from activity by a web-browser.

AFAIK, Comcast blocks bittorrent traffic by isolating known common torrenting ports, right? So can I sidestep this by picking a different port to forward utorrent through?

Comcast is NOT blocking, throttling, or interrupting my torrent traffic, as all tests and information seemed to indicate. Even the test run by Glasnost.com crashed my internet connection -- the ONLY time my connection has ever dropped from browser activity -- which seemed a surefire sign. However, I'm running through a fully-encrypted VPN right now, and I'm anonymous, yet the problem still continues as described. What could I possibly be missing, here?

Please respond, at least with a "Wow, that's crazy, it looks like you tried everything; apparently God hates you and thinks you have too much pr0n," just to let me know I'm not shouting into a well :(

Also: I know there are many posts about W7, but none about *this* problem. I'm not having the 99% problem or low speeds. My speeds are phenomenal during the five to ten minutes they last.

EDIT: Strangely enough, while no setting seems to completely prevent the connection drop, I've noticed that some settings do delay it. For example, accepting incoming legacy connections almost instantly drops my connection, as does disabling encryption. So perhaps Comcast *does* throttle my traffic, but that's not the only problem. Setting the max half-open connections high (like 200-ish) doesn't crash my connection, but it seems to mildly decrease how long the connection lasts, as do increases of the global connections, upload speed (into choking range), and number of concurrent active downloads. Even the number of downloads in the queue appears to have an impact. So with extremely conservative settings, my connection lasts for about half an hour, but with liberal settings (many connections, no upload limit, etc.), my connection lasts about five minutes... This could also be merely apparent, of course... :sigh:

EDIT2: Nope, it was just "merely apparent:" I just tried a run with 1000 global connections and 250 half-open connections, with 200 concurrent downloads. I stayed up around 3MB/s (my connection's max) for over half an hour, the longest I've gotten in weeks. So it really has nothing to do with connections. But I was plugged into my modem directly, I was fully encrypted and not accepting legacy connections, so it isn't my ISP. I was on a fully-updated, high-grade PCI NIC card, so I doubt that it's my ethernet controller. And I haven't read about this problem with other SURFboards. Though I'm on W7, which has many problems with torrenting, I haven't seen *this* problem on the boards before, and I would have expected some particular threshold to cause W7 to drop the connection. But that should have been breached sooner than 40 minutes, right? Not to mention that this connection interruption *requires* a power-cycle -- no netsh or ipconfig or NetBIOS command will repair it, nor will W7's gui-triggered "repair" operation, which I would expect to work if W7 killed my connection (right?). It still sounds like Comcast is sending a RST packet, but they shouldn't be able to tell that it's torrent traffic when I'm on a random port (not stealthed) and my outgoings are encrypted (right?). So what's left? I think at this point, I'm going to try a new modem next, but I'm sick of wasting money. Plus, I have a big home network, and whenever I try torrenting through my router (which was the highest-rated on newegg :shrug:), the connection drops MUCH more quickly, and I hate the idea of being unable to use my router anymore...

This really sucks: last year towards the end of summer, in the same place, with the same hardware, and the same ISP, I torrented literally terabytes, with no problem, unencrypted. BAH!

Link to comment
Share on other sites

I have ComCast as well.

Reduce other connection types as far as possible all at once rather than testing them separately.

If you haven't already, disable Resolve IPs and disable DHT.

Disable UPnP, NAT-PMP, LPD as well.

I don't trust the reliability of either Windows 7 or Windows Vista (basic x64), mostly due to driver issues.

Link to comment
Share on other sites

THANK you for the response :)

I feel obliged to point out that I've been messing with this for about two weeks. And I'm an obsessive person; I also consider myself pretty computer-savvy. The problem with being computer-savvy is that when there are 500 possible causes, I'm still apt to miss one, so I greatly appreciate your suggestions. (So, yes, I've tried reducing them all at once, too.)

When I said that I reduced connections, I meant that I did it as all logical permutations. In other words, I work like a scientist:

Is it global connections? I'll check this by gradually reducing global connections while keeping all other settings static, until global connections = 2 (one for UL, one for DL).

Is it half-open connections? FIRST, I reset global connections to its default, then start whittling away at half-open connections, in a similar fashion. THEN, I will, while half-open connections are at a low enough threshold to discount it as a cause, begin ALSO lowering global connections. Because, of course, for any two potential causes, there are four possibilities: A is the cause, B is the cause, A and B are joint causes, neither A nor B are causes.

This gets very tedious as I add more and more possibilities. Obviously, the easiest way to go is to first reduce ALL potential possibilities below their threshold, then when the connection works, pile things on until it breaks. However, I can't even create that scenario! In other words, with ALL connections set to, maybe 5-ish (very low), UL max set to 10, half-opens set to 1, IPs disabled, DHT disabled, UPnP, NAT-PMP, LPD all disabled (including in the router's settings, when using the router), ports forwarded correctly, plugged directly into the modem, using a modern PCI NIC card with up-to-date drivers, a solid (in this case, expensive) Cat cable (tried 5e and 6), a fully-encrypted VPN tunnel... STILL, the connection breaks. The obvious next shot would be the modem, but that in no way explains why a couple torrent connections at a low speed breaks the connection, but several (or even dozens) of max-speed firefox downloads don't.

Clearly, I must be missing something. If it's W7, what would be the cause? Obviously, *some* people are using W7 for d/ling successfully. I know that many aren't. But if it's drivers, it makes little sense that several NIC cards and two on-board Ethernet controllers all cause the same problem, even when the on-boards have W7 drivers. And, again, why only torrents?

Glasnost's test causes my connection to drop, even though I do it through iexplore or firefox, which seems to imply port issues. But (1) shouldn't encryption counter that? and (2) I've scanned all of my incomings for stealthed ports, and found very few (which I'm not using for torrents).

There's also the issue that connection amounts seem to have no impact on the duration of my connection. I'm currently going in 5-to-30-minute spurts with globals at 900 and half-opens at 200; the spurts are also 5 to 30 minutes when using globals at 20 and half-opens at 1! The same is true about enabling DHT, UPnP, etc. -- no effect on connection duration. Strangely enough, though, disabling encryption crashes the connection almost immediately.

My only thought is this: it's a combination of things: W7 compatibility (perhaps with uTorrent itself? or one of its settings?), Comcast port-blocking (port-screwing, technically, with RST packets, AFAICT), and maybe a poopy modem (though other users of the Motorola SURFBoards report no such problems)...

I have an old XP Pro disk... maybe I'll try dual-booting and see how it works for torrenting.

PS: What is LPD? Also, for disabling IP resolving, it's that way in default, right?

EDIT: Well, I found a solution, but it's a terrible solution. At least it may say something about the problem -- by limiting my upload speed to 1kB/s (can't cut it entirely), I last around 2 to 3 *hours* before my connection drops, conspicuously longer than before (5 to 30 minutes). In fact, I dropped after two hours on the first try; since reconnecting, it's been about 1.5 hours and no drop yet...

I'd hate to be a leecher, but what does this mean?

Link to comment
Share on other sites

I don't know if I don't know all the other settings you're using with it.

And even then I can only guess.

Maybe worth reading for ideas... "Windows Vista freezes?":


BitTorrent clients put a bigger strain on networking cards than regular web browsing...because regular web browsing doesn't normally have 30+ connections active at once.

LPD (Local Peer Discovery under preferences, BitTorrent) and Resolve IP (right-click in PEERS window of an active torrent) are enabled by default...I'm asking you to disable them both along with other uTorrent features.

Link to comment
Share on other sites

I'd be happy to post up some screenies if that's what you're asking for ;) And I really do greatly appreciate that you're even here helping me!

Local Peer Discovery I had off, and I was thinking of the peer.resolve.countries or something like that, which is off by default, but I have now disabled the IP resolution under the peer tab (shouldn't that be an option somewhere in the options?).

I realize the bigger strain, but as I said, I've tried lowering half-opens to 1 and globals to 2, and the crash still happens. The ONLY setting that has held my connection up is lowering UL speed to 1kB/s, and reducing UL slots to 1. As far as other settings, assume I've tried every logical permutation of them, always defaulting to the more conservative (lower connections, lower half-opens, disabled DHT and UPnP).

But NOW, I've gone all night this last try (for the first time since Summer), with global at 900, half-opens at 200, and UL max at 1. In fact, I had 50 concurrent downloads and they spent most of the night maxing out my connection around 2MB/s.

The tradeoff is that I've become a (*shudder*) leecher...

God knows that once I figure this out, I'll be doing a LOT of seeding ;)

Link to comment
Share on other sites

  • 4 months later...

I found this while searching for a solution for my problem that is pretty much exactly like yours, mine keeps disconnecting/connecting about 3-10 times until nic crashes. Only solution so far is limiting the upload to 100k/s (only takes a longer time to crash)

I have win xp pro. And i have tried same things as you. even the torrent program does not seem to matter.

Link to comment
Share on other sites

it was not the card... next in line is the cisco 575 lre, but i guess that means i have to change isp, because i dont think i can find a replacement for that... well. i guess its time to upgrade to 100/100 and +10€ month...

/takes off the "i have fast connection" hat.

(i tried with completely different computer, same connection)

Link to comment
Share on other sites

  • 10 months later...

Hi I have the exact same problem with a slight twist that may help with diagnosis.

I have upgraded from vista 64bit to windows 7 64bit. I had the problem with vista but it has got much worse with windows 7. I also have on board wireless N adapter and then bought a additional adapter to try and cure the problem only I bought a usb Linksys wirless N adapter.

Symptoms are that the on board adapter crashes and cannot be repaired or disabled in device manager. computer works normally until restart when it hangs. Only a complete power down of the mother board will fix the adapter.

The usb adapter is the same symptoms and even unplugging and plugging it back in will not work. Sometimes it will be recognised in a different usb port but never back in the original socket.

Basicly under vista I'd get a connection for a short while and that was doubled with two adapters to crash. I made do after trying similar setting changes that are on this forum with no effect.

On windows 7 the problem is worse only keeping a connection for a few mins.

Reducing upload speed to 1 seems to cure the problem.

The key hear is it seems to be crashing the usp port and the adapters diver.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...