Jump to content

Intermittent Port Forwarding or Throttling?


oldnoob

Recommended Posts

I'm scratching my head over a problem that I've recently been experiencing with uTorrent. Everything worked well for many months, and then recently my speed has fallen off. It is better in the middle of the night but even that seems variable. Here's what I can tell you:

Router: Belkin F5D7230-4 Wireless G; also have used a US Robitics USR5461. Same problem with both.

Computers: (1) Vista machine hardwired to router, Vista, dynamic IP, not running uTorrent; (2) Asus G1S-A1 laptop, Vista, static IP, wireless to router and running uTorrent 1.8.2; (3) Asus P4C800-E Deluxe desktop, Win XP, static IP, wireless to router and running uTorrent 1.8.1

Setup: Both uTorrent machines set up with static IPs outside the router DHCP range. Both machines and router portforwarded as per Portforward.com instructions. Connection speeds ~ 4500 down and 450 up, so I have used xx/384k in the speedguide. Have tried many different port numbers. For uTorrent 1.8.2, I see Vista firewall TCP and UDP exceptions. I later added an exception for the uTorrent app -- that didn't make any difference.

Test results: Green light comes on - that has never been a problem. I tried the Open Office torrent. Has been running for several minutes and flatlined at 17 kB/s. Right now it is 9:15 AM on Sat. Yet, periodically, in the morning or middle of the night I can get speeds of 200...or not...I can't really predict it. So, on the surface it looks like throttling, which I know my provider (Shaw Cable) does.

However, when I test the portforwarding with the uTorrent tester, the test fails much of the time. And I see this in the DL, which might start off with a burst and then die once the port closes (or at least that's what it looks like). I also tried http://www.canyouseeme.org and and https://www.grc.com/x/portprobe=YOURPORTNUMBER to test open ports. Same results -- sometimes good, sometimes not.

Does this sound like throttling or is there something I am missing? Too bad if it is the former -- they are my only option as a high speed ISP. TIA for any advice on this.

Link to comment
Share on other sites

Your router may not be able to handle 100 connections/sessions at once.

DHT and Resolve IPs can overrun that by themselves. :(

What are the TCP and UDP timeouts set to?

They need to be no more than 300 seconds for TCP and 60 seconds for UDP.

2nd link in my signature for alternate uTorrent settings based on your upload max.

...even that may have too many global and per-torrent connections at once for your router. :(

Link to comment
Share on other sites

Thanks for the speedy reply. OK, yes, I have tried those alternate settings and they didn't seem to make a difference. I'm not sure where to get those timeout values -- can you point me please? A quick poke around with Google left me scratching my head...Vista auto-tuning and so on. Also, I have the same issue with an XP machine.

However, in the meantime, I found that the Belkin supports UPnP. When I switched that on and ticked the box in uTorrent 1.8.2 -- WOW!! Someone turned on the tap. :D I now get rates in excess of 500 kB/s on just a single torrent -- and not one the benchmark tests. So it looks like it is something I am doing in my setup. Strange. I really don't get it. Any ideas? In the meantime, my problem appears resolved but I am still curious if anyone has a clue on this.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...