Jump to content

Upload Speed Issues (details inside)


Recommended Posts

I've currently got a 10mbit/1.5mbit connection and have limited my upload to 140 kb/s

The weird problem I've found is that recently my upload speed does rather weird things...

for instance I'm downloading two torrents and uploading one torrent.

At this time my total upload is at 60 kb/s, where the uploading torrent is at about 40 kb/s

Now whenever I stop the downloads the upload speeds up to 100+kb/s

My settings are basicly the same as the settings suggested in the suggested settings thread on this forum.

(per my 1.5 mbit up)

I'm kinda stumped with this problem as I find it odd that I cant seed properly while downloading.

I'm using the latest utorrent build 1.8.2 14458

Any ideas on what is causing this behaviour ?

Much obliged in advance.

Link to comment
Share on other sites

I didnt want to flood the topic but let me add all the specifics I can.

I run utorrent 1.8.2 14458 on vista ultimate (latest patches) 32-bit.

The port is forwarded correctly (shown as connectable and all checks come up ok)

Download max = 0 - Upload max = 140

Global connection max = 400 (tried 250)

Max connected peers per torrent - 80

Max number of upload slots per torrent - 7 (< 90% upload checkbox is on...tried disabling it)

Protocol encryption is enabled (not forced) - Allow incoming legacy connections is checked.

Maximum number of active torrents = 8

Max downloads = 6

Max Max Halfopen = 50 (tcpip.sys altered correctled...no errors in eventlog) - even with the default tcpip.sys the problem persists.

The odd part is that the drop isn't relative... I mean I can understand that if my isp is having a bandwidth issue that I can't reach my maximum upload (unlikely but possible) yet the total upload speed also decreases.

It has me rather stumped...


I've done some more testing and for some odd reason Azureus doesn't have this problem, yet I can't find anything wrong with my current configuration.

I hope someone has a brilliant idea and can help me track down this bug :)



Somehow it was related to a specific torrent...deleting it and then reloading it seemed to have solved the problem.

Odd part is that all settings were ok (atleast displayed ok)


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...