Jump to content

Seeding Torrents upload speed drops dramaticly when starting another


Trouble

Recommended Posts

Seeding Torrents upload speed drops dramaticly when starting another torrent.

I've been seeding a torrent to one/two peers at approximately 110/120 kbs, (max is 140kbs). yet it drops to 20 kbs when I start a download.

The download is limited to 20 kb/s upload (which totals approximately 140 kb/s)

My max connections is set to 250 and to 80 per torrent.

The way I understand how utorrent works this should not happen, sure the upload could drop a bit, but from 120 to 20 ?

Anyone know if this is a bug or if I may have accidently made a configuration mistake ?

I run the latest version of utorrent on vista 32 bit ultimate.

I've also read the faq/speedguides and tried the suggestions made there, as well as some troubleshooting on my own.

(Increasing max connections, monitoring system log, the logger tab, limiting upload a bit more etc etc)

I've never had this problem before and it only effects high speed connections...ie loads of connections at slower speeds seem to go without a problem.

Much obliged for any help you can give me,

Trouble

[edit] Further experiments show that the problem is triggered when a torrent is activated which has its upload speed limited.

Could this be a bug ?

(I want to limit some torrents so I can reserve more upload bandwidth for releasing new torrents)

[/edit]

Link to comment
Share on other sites

Your ISP (Chello) is known to disrupt/throttle BitTorrent traffic some, so that alone may be the cause. Though the way you describe it...seems very odd for them to do that! Normally pure seeding is most heavily disrupted.

Try disabling all at once: Resolve IPs, Find Local Peers, DHT and UPnP.

Resolve IPs can be enabled/disabled by RIGHT-clicking your mouse in the PEERS window of an active torrent.

Reduce half-open connections (net.max_halfopen) to 4-8, lower bt.connect_speed to only 4.

2nd link in my signature goes the other way -- using far fewer connections max than uTorrent's regular Speed Guide (CTRL+G). Connection overload is KNOWN to be a problem with innumerable USB devices, wireless connections (even just between computer and router), and crappy routers (Belkin and Linksys without 3rd party firmware in particular).

Link to comment
Share on other sites

Much obliged for the suggestions:

I've made the appropriate changes.

I generally use the settings suggested in the second link (and adjust if so required), but I tried the settings of the speedguide with no effect.

I did notice that if I limit the upload slots for the other torrents to 1 and set their priority to low and the seed to high that the problem doesnt occur.

It only occurs when I set the upload limit for the downloads and the download hits that upload cap.

[edit] It seems the suggested changes resolve the problem, yet it seems the utorrent now ignores the upload cap set per torrent... I've got three downloads limited to 10 kBs (for this test) and they all reach 20 kBs.

The settings which I changed:

net.max_halfopen 8 (unchanged)

bt.connect_speed 4 (old 20)

Resolve ips disabled (unchanged)

DHT disabled (enabled)

Discover local peers disabled (enabled) - both in the options menu and on the torrents

UPNP disabled (disabled)

I do use a wireless connection on a linksys router but with the dd wrt firmware.

[edit] Problem reoccured, however contrary to previous attempts a restart of utorrent was sufficient to resolve it this time.[/edit]

Link to comment
Share on other sites

It seems I have a variant of his problem... with me however my global upload limit works rather well.

I have only 1.5 mbit up so I limit my upload to 140 kbs and it usually maxes out at 140-145kb/s which is very acceptable.

My problem starts when I limit a torrents upload speed, which I do as to keep a decent speed for new torrents I uploaded and still be able to download a bit myself.

The more downloads I start (I normally limit to the suggested speed thread but deviated from this for testing purposes) the lower my upload becomes.

While this would be logical for the seed as it has to share with more other torrents, but the really weird thing is that my total upload drops further.

Where it was 140kbs it drops to 100kbs with a few downloads. (Total upload)

Running Vuze (Azureus) next to utorrent for the seed seems to bypass most of this problem, but its a pain assigning bandwidth this way.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...