Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 1.8.3 beta 15619

Recommended Posts

Well I was still on the old 1.8.3 for a while - managed to get it up to 675MB without noticing :)

But then I accidentally looked at taskmanager for something else, and, well, updated µTorrent :P

Share this post


Link to post
Share on other sites

Anyone having slow and unstable upload speeds using 1.8.3? I updated to this one from a previous version and now the upload speeds for torrents see-saws between 0(as shown for each of the 10 torrents) and maximum.

I tried the 1.9.x alpha version with no such problem. Is there a bug for 1.8.3

Encryption is disabled for both 1.8.3 and 1.9 as a basis for comparison. My router port is opened, shows green (nothing changed there), and I have not changed the max half opened port and can conform the evilid thing is still set to 50.

Share this post


Link to post
Share on other sites

I'm also getting virtually no upload, 0.x kB/s per torrent with the occasional bump to ~10 kB/s for some seconds, but it falls back to being dead again almost immediately.

Share this post


Link to post
Share on other sites

I'm a bit curious as to why the default bt.transp_disposition is at 13 which isn't of the mentioned values for 1.8.x (0-1-2-3).

Share this post


Link to post
Share on other sites

I downgradet back to 1.8.2. Cos the newest 1.8.3 build (14755) sufferes on bad bad download and upload speeds from MB:s to KB:s total bantwith 100KB/sec, Previous build of 1.8.3 worked just fine.

vista 32bit

Edit, reverted back to 1.8.2 works fine.

Share this post


Link to post
Share on other sites

> Even if for 1.9, shouldn't it be 15 default, and not 13?

For 1.8.3 the settings match 1.9, so according to the 1.9 thread (and what I've gathered in this thread)..

bt.transp_disposition is a bitfield, so the following numbers can be ADDED to get the desired effect:

1 - incoming TCP

2 - incoming uTP

4 - outgoing TCP

8 - outgoing uTP

Specific combinations:

5 - TCP incoming + outgoing only (uTP disabled)

13 - TCP incoming + outgoing with uTP outgoing only (1.8.3 default)

15 - both TCP and uTP, incoming + outgoing (1.9 default)

13 makes sense as the default for 1.8.3 (despite Firon saying it would be 0) because until all the kinks are worked out they don't want the client preferring uTP over TCP for incoming connections.

Share this post


Link to post
Share on other sites

Well, my task manager for windows sp2 has the following:

uTorrent.exe / 48,564K

No lock-ups, no crashes, last version I had a couple of lockups but now nothing is happening, everything is as it should be...

A small item to those running the Betas, if it acts flaky, don't uninstall and refuse to run it. Keep it going, as we saw w/ this version an update/patch whatever came out very quickly. We all need to keep documenting and posting our findings here, otherwise, what is the point in running the beta type series?

Share this post


Link to post
Share on other sites

I ran 14755 all day and it is working great for me provided I set bt.transp_disposition to 5. At 13 I see the ~0kbps uploads with occasional short bump ups that others have noted.

Also, the memory leak(s) have not shown up with this build. Thanks for the hard work.

Share this post


Link to post
Share on other sites

There's gotta be something weird going on with the uTP. 7 chokes my download to a fraction of its usual speed and 13 or 15 pretty much kill everything but I get my normal speed back as soon as I set it to 5.

Share this post


Link to post
Share on other sites
> Even if for 1.9, shouldn't it be 15 default, and not 13?

For 1.8.3 the settings match 1.9, so according to the 1.9 thread (and what I've gathered in this thread)..

bt.transp_disposition is a bitfield, so the following numbers can be ADDED to get the desired effect:

1 - incoming TCP

2 - incoming uTP

4 - outgoing TCP

8 - outgoing uTP

Specific combinations:

5 - TCP incoming + outgoing only (uTP disabled)

13 - TCP incoming + outgoing with uTP outgoing only (1.8.3 default)

15 - both TCP and uTP, incoming + outgoing (1.9 default)

13 makes sense as the default for 1.8.3 (despite Firon saying it would be 0) because until all the kinks are worked out they don't want the client preferring uTP over TCP for incoming connections.

Sorry, but I had the values swapped in that post and neglected to correct them.

1 and 2 are outgoing, 4 and 8 are incoming.

13 is thus TCP incoming + outgoing and UTP incoming only.

13 is the default because we want 1.8.3 to behave like 1.8.2, but still be able to handle incoming uTP better than previous versions (as it has 1.9's uTP handling code).

Share this post


Link to post
Share on other sites

Firon, what does "outgoing" uTP mean ? Initiating uTP connections ( like 1.9) ? or just being able to respond with uTP to uTP requests.

Share this post


Link to post
Share on other sites

k, thanks. So , in fact, issue like the incorrect download limit issue that was in 1.9, is now effecting 1.8.3 as well ? cause I was thinking to revert to 1.83 if this was fixed in there...

Share this post


Link to post
Share on other sites
Bundle has been implemented in 1.8.2, it's utorrent.exe with a torrent file (like a bundle program) to distribute uT with a specific torrent like a distro etc...

o0 like a self extracting ZIP file, but for torrents? neat

Share this post


Link to post
Share on other sites

Any progress on bundles having broken signatures? Broken is worse than none you know...

(And it's completely doable to have a valid signature, but takes a little more effort.)

Share this post


Link to post
Share on other sites

With beta 14755 uploads go down: when connect to a uTorrent 1.9 all other client are out.

bye

PS: Sorry for my bad english

Share this post


Link to post
Share on other sites

Hello guys, I can also testify that upload speeds (without tweaking advanced settings) are poor after a few minutes of use.

First ~5min it goes full speed then it just dies and stays around 2KB/s.

OK here is something I just noticed, when 1.8.3 is running, I can't connect to steam.

No port collision or anything like that.

Share this post


Link to post
Share on other sites

alright... now i totally fucked up my registries with this damned beta -.- i can't normally uninstall or install it / run it / or upload at a descent speed. and also, i can't even use the older version of it.

Share this post


Link to post
Share on other sites

@Ufis: what you don't save utorrent.exe (latest stable) and the beta in Program Files\uTorrent?

I do that and I have no problems to switch between the 2 versions, you just need to refuse shortcuts etc... when the beta installer appears, that's all.

When I want to remove a beta, I trash the .exe and remove exceptions in my firewall, that's enough.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.