Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 1.8.3 beta 15619

Recommended Posts

now many of the people using modem / router that have small UDP pinhole table, as it overflow it might crash or etc.

by arvid

The reason why this is a new problem in uTorrent 1.9 is because it uses uTP (which is a transport on top of UDP), you can disable this by setting the bt.transp_disposition to 13. (13 means, allow incoming TCP and uTP connections, but only make outgoing TCP connections).

now i using bt.transp_disposition "13" and use low global max connection, as it rarely crash now.

Share this post


Link to post
Share on other sites

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND

955 bob 20 0 349m 155m 25m S 0.0 7.7 143:32.88 firefox-bin

9421 root 20 0 126m 62m 23m R 5.3 3.1 348:55.82 Xorg

10058 bob 20 0 2607m 436m 18m S 1.0 21.5 14:49.58 uTorrent.exe

Build 14809, wine-1.1.17. The memory leak is for sure solved in Windows?

Share this post


Link to post
Share on other sites

Newest version doesnt fix it for me for issue of slow and falling upload speeds, and bt.transp_disposition is at default, which shows 13.

Share this post


Link to post
Share on other sites

bt.transp_disposition at 13 works great with 14809.

With bt.transp_disposition set at 15 I get a lot of uTP connections established, but upload drops way off still.

This may be coincidence, but I did notice that eventually my upload did increase to my full allotment, but the peers I were uploading to were all non-uT clients (no uTP connection). If a uTP connected client worked its way in to get sent a piece (U flag), the upload speed would tank for all peers until the uTP peer gets choked (u flag) again.

My router is a D-Link DGL-4300.

Share this post


Link to post
Share on other sites

Not here.

I have been trying different numbers and nothing but 15 works. Unfortunately with 15 I'm getting minimal download speed and no upload. I have been trying with lasttwo betas and with going back to last stable but I couldn't get that wroking agian. In last few days I realized I am addicted to torrents : /

Share this post


Link to post
Share on other sites

Yeah, it's working great for me at 13.

@Chaosu - Sounds like 15 isn't working for you...

I'm curious... What does it do at 13? 5?

I also found it necessary to stop all my torrents (to initiate the new connections) after changing bt.transp_disposition.

Share this post


Link to post
Share on other sites

There is something wrong with this build.

The client reports CRAZY speeds, capping completely the connection I have (I see an average above 750k sometimes, and that's a 7M adsl line). The problem is that even the upload is constant and capped at 40, while I know that I wouldn't be able to keep 40kb in upload if I maximize my download like that.

In fact my netspeed monitor shows that the download is indeed 750k, but the upload goes between 18k and 20k, exactly like it should realistically be. So utorrent is at least reporting upload speed incorrectly.

Share this post


Link to post
Share on other sites

Yes, it works fine (no upload drops) with bt.transp_disposition at 13 but no uTP connections.

With 15 works well too but upload is not so stable and a little lower.

bye

Share this post


Link to post
Share on other sites

Hmm.. here's something I've never seen before:

[2009-03-28 20:16:08]  QoS: running low (0.0 kB @ 0.0 kB), stepping up to 0.0 kB [ qos_rate: 0.0 kB bwc rate: 0.0 kB][2009-03-28 20:16:09]  QoS: running low (29.2 kB @ 28.3 kB), stepping up to 0.9 kB [ qos_rate: 0.0 kB bwc rate: 28.4 kB][2009-03-28 20:16:10]  QoS: running low (497.6 kB @ 497.6 kB), stepping up to 0.9 kB [ qos_rate: 0.0 kB bwc rate: 497.6 kB][2009-03-28 20:16:11]  QoS: running low (151.2 kB @ 151.2 kB), stepping up to 0.9 kB [ qos_rate: 0.0 kB bwc rate: 151.9 kB][2009-03-28 20:16:12]  QoS: running low (263.4 kB @ 255.5 kB), stepping up to 0.9 kB [ qos_rate: 0.0 kB bwc rate: 255.7 kB][2009-03-28 20:16:13]  QoS: running low (263.4 kB @ 255.5 kB), stepping up to 0.9 kB [ qos_rate: 0.0 kB bwc rate: 308.8 kB]

What does it all mean? :)

Share this post


Link to post
Share on other sites

Even if official rules for UDP trackers get codified...it will probably be longer before many trackers start converting to that format. Which means even if uTorrent supported official UDP tracker rules it couldn't use them at first. :(

Share this post


Link to post
Share on other sites

I found a pretty big bug with 1.83 and 1.82 (both latest versions incl. betas).

I put in a port I wish to use in uT (say 61555), have disabled upnp and nat-pmp, my router indicates that uT will use port 61555 and will attempt many random ports as well.

The net result according to my tomato 1.23 firmware's QOS graph, is that uT is now doing perhaps 60% of my upload bandwidth on some random ports (there are a whole bunch of them), and 40% on port 61555. This kills any QOS on the router since most QOS implementation depends on the source port you put in and expects the application to abide by the port chosen.

uT 1.9.1x DOESNT have this bug. Can someone please look into this?

In case you're wondering, yes my port is properly fowarded - I get a green arrow on bottom of uT. This issue only occurs for 1.82 and 1.83 but not for 1.9x

Share this post


Link to post
Share on other sites

@callous:

outgoing connections are not bound to the listen port. You can set the net.outgoing_port and net.outgoing_max_port to specify a range of ports to bind outgoing sockets to. If this is not what you're talking about, I'm not sure I understand what you mean.

Share this post


Link to post
Share on other sites

It looks like i have hole in my understanding of how uT works - my apologies.

1.9x seems to have outgoing connections on the listening port only though. That part I am confused about.

Share this post


Link to post
Share on other sites

Ok I set used net.outbound_port=51555 and net.outbound_max_port=51561. uT is still sending out my upload data on the listening port on 52555.

What am i doing wrong here?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.