Jump to content

uTorrent port forwarding doesn't work in Vista


Recommended Posts

I was previously running XP 32-bit and had port forwarding set up fine on my Router (a Netgear Rangemax, but it doesn't matter). Without changing any settings on my router I upgraded to Vista 64 bit, set a static IP and set the port in uTorrent so that they both match what was being forwarded by my router. Port forwarding does not work, even when I disable the windows firewall completely (I have exceptions in the firewall for uTorrent anyway) and run uTorrent as administrator. I've verified that the IPv4 address is correct in the network settings and double checked it many times. I've tried changing the IP address and ports (and correspondingly what the router is forwarding) several times (although that really shouldn't be necessary) and am not getting any luck. UDP and TCP are being forwarded in the router settings. I tried checking other options like Ipv6 and Upnp in uTorrent settings, but that didn't fix it.

As a sanity check, I created a virtual machine running 32-bit windows on my 64-bit Vista with bridged networking (VMware default settings) and installed uTorrent in the virtual machine. I had absolutely no problem getting port forwarding to work within the virtual machine, which confirms that it has something to do with Vista -- or with the way that uTorrent interacts with Vista.

Has anyone else successfully got port forwarding working with Vista?

Link to comment
Share on other sites

What internet security software do you have installed?

Have you created an exception in the windows firewall for uTorrent's listen port?

uTorrent has added exceptions to the windows firewall for TCP-in and UDP-in. I've also manually created exceptions for the ports I was forwarding. However, as I stated in the original post, the problem occurs when the firewall is completely disabled.

Link to comment
Share on other sites

I seem to have the same problem.

I'm running windows vista 32x

I have norton internet security (but i have turn it off)

my router is d-link dir-615 (i have set up all the port forwards and static ips on my pc)

I keep getting that annoying yellow icon, and when testing using speed guide the port is never forwarded.

some times the icon will turn green when i restart utorrent, but it never stays green for long.

from what you have said its a problem with vista?

this is driving me crazy someone please help.

Link to comment
Share on other sites

ok uninstalled norton. tested the port still not forwarded.

so it cant be a problem with the firewall. and my windows fire wall is off.

but for some reason that icon is now green, but tested it using using speed guide its still not forwarding the port.

why is it green and not forwarding?

edit correction lol its nolonger green it went back to that evil evil yellow.

Link to comment
Share on other sites

well here is the log

Logfile of HijackThis v1.99.1

Scan saved at 3:10:09 AM, on 08/03/2009

Platform: Unknown Windows (WinNT 6.00.1904)

MSIE: Internet Explorer v7.00 (7.00.6000.16809)

Running processes:




C:\Program Files\Windows Defender\MSASCui.exe


C:\Program Files\ASUS\Ai Suite\AiNap\AiNap.exe

C:\Program Files\Corel\Corel MediaOne\Corel Photo Downloader.exe

C:\Program Files\Common Files\Ulead Systems\AutoDetector\Monitor.exe

C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe


C:\Program Files\Windows Sidebar\sidebar.exe

C:\Program Files\DAEMON Tools Lite\daemon.exe

C:\Program Files\Windows Sidebar\sidebar.exe


C:\Program Files\Mozilla Firefox\firefox.exe


R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =

O1 - Hosts: ::1 localhost

O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll

O2 - BHO: Groove GFS Browser Helper - {72853161-30C5-4D22-B7F9-0BBC1D38A37E} - C:\PROGRA~1\MICROS~1\Office12\GRA8E1~1.DLL

O4 - HKLM\..\Run: [Windows Defender] %ProgramFiles%\Windows Defender\MSASCui.exe -hide

O4 - HKLM\..\Run: [RtHDVCpl] RtHDVCpl.exe

O4 - HKLM\..\Run: [skytel] Skytel.exe

O4 - HKLM\..\Run: [Ai Nap] "C:\Program Files\ASUS\Ai Suite\AiNap\AiNap.exe"

O4 - HKLM\..\Run: [QFan Help] "C:\Program Files\ASUS\Ai Suite\QFan3\QFanHelp.exe"

O4 - HKLM\..\Run: [Cpu Level Up help] C:\Program Files\ASUS\Ai Suite\CpuLevelUpHelp.exe

O4 - HKLM\..\Run: [Corel Photo Downloader] "C:\Program Files\Corel\Corel MediaOne\Corel Photo Downloader.exe" -startup

O4 - HKLM\..\Run: [ulead AutoDetector v2] C:\Program Files\Common Files\Ulead Systems\AutoDetector\monitor.exe

O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files\Adobe\Reader 8.0\Reader\Reader_sl.exe"

O4 - HKLM\..\Run: [GrooveMonitor] "C:\Program Files\Microsoft Office\Office12\GrooveMonitor.exe"

O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\Windows\system32\NvCpl.dll,NvStartup

O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\Windows\system32\NvMcTray.dll,NvTaskbarInit

O4 - HKCU\..\Run: [sidebar] C:\Program Files\Windows Sidebar\sidebar.exe /autoRun

O4 - HKCU\..\Run: [DAEMON Tools Lite] "C:\Program Files\DAEMON Tools Lite\daemon.exe" -autorun

O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~1\Office12\EXCEL.EXE/3000

O9 - Extra button: Send to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~1\Office12\ONBttnIE.dll

O9 - Extra 'Tools' menuitem: S&end to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~1\Office12\ONBttnIE.dll

O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~1\Office12\REFIEBAR.DLL

O10 - Unknown file in Winsock LSP: c:\windows\system32\nlaapi.dll

O10 - Unknown file in Winsock LSP: c:\windows\system32\napinsp.dll

O11 - Options group: [iNTERNATIONAL] International*

O13 - Gopher Prefix:

O17 - HKLM\System\CCS\Services\Tcpip\..\{5830404E-77D4-4133-9767-5E87AF9BEF05}: NameServer =,

O18 - Protocol: grooveLocalGWS - {88FED34C-F0CA-4636-A375-3CB6248B04CD} - C:\PROGRA~1\MICROS~1\Office12\GR99D3~1.DLL

O18 - Protocol: ms-help - {314111C7-A502-11D2-BBCA-00C04F8EC294} - C:\Program Files\Common Files\Microsoft Shared\Help\hxds.dll

O18 - Filter hijack: text/xml - {807563E5-5146-11D5-A672-00B0D022E945} - C:\PROGRA~1\COMMON~1\MICROS~1\OFFICE12\MSOXMLMF.DLL

O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\11\Intel 32\IDriverT.exe

O23 - Service: NVIDIA Display Driver Service (nvsvc) - NVIDIA Corporation - C:\Windows\system32\nvvsvc.exe

O23 - Service: ProtexisLicensing - Unknown owner - C:\Windows\system32\PSIService.exe

O23 - Service: @%SystemRoot%\system32\qwave.dll,-1 (QWAVE) - Unknown owner - %windir%\system32\svchost.exe (file missing)

O23 - Service: @%SystemRoot%\system32\seclogon.dll,-7001 (seclogon) - Unknown owner - %windir%\system32\svchost.exe (file missing)

O23 - Service: @%ProgramFiles%\Windows Media Player\wmpnetwk.exe,-101 (WMPNetworkSvc) - Unknown owner - %ProgramFiles%\Windows Media Player\wmpnetwk.exe (file missing)

Link to comment
Share on other sites

i really think it might be vista now, cause my os is a newly installation with nothing on. and i just uninstalled all my fire wall.

and i'm sure i have all the port forwarding working. that speed guide port test have never passed

update. i've taken the router completely out of the equation (connected my pc directly to the modem)

and it seem to be forwarding the port correctly. and i dont see how i could of screw up the forwarding on my router any ideas?

Link to comment
Share on other sites

I had previously installed Comodo Internet Security, although the program was not running. I tried uninstalling Comodo and restarting, and now port forwarding is working. I think it was probably something Comodo did.

Something you didn't do more likely. EVERY firewall on a computer needs to be configured. The only one that stops blocking when turned off is the windows firewall.

Link to comment
Share on other sites

  • 3 weeks later...

I have not read everybodys post as to what they use. Here is what I have and how I fixed it.

I'm running V Home Premium 32bit and Zone Alarm Free Firewall, It always blocks every UDP incoming connection, so my little 'thing' never goes green. All I do is disable ZA before starting a D/L then when its finished, reboot and ZA is re activated and it turns off windows firewall. My system is also with a Netgear Router that supports UPnP so a 'random port' can be selected on start-up.

P.S. If you use a firewall testing site, it only tests router firewall.

Happy Downloading.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...