Jump to content

large torrent >100gb and fileserver bug


Recommended Posts

i have been monitoring this for a while and i believe it to be a utorrent bug

this has occured on both xp32 and vista64 networks

utorrent 1.6 to present beta

system is 1 fileserver and 1 user pc

running utorrent on the user pc and storing data on fileserver

it will run perfectly fine if the torrent files are small-ish e.g max 30gb

however if i run, as i am now 3 torrent files, 1x130gb,1x60gb and 1x40gb (this is tosec stuff btw)

it will eventually bomb out taking the network drives out of action for the user pc

giving The network path was not found error on all torrents

the network drives are still accessable from laptop or other pc's if put on the network after, just not from the user pc

if i store the torrents on the local user pc drive, all is fine

bittornado does not give this error, ever, running exact same 3 torrents, so this points to a utorrent bug

any ideas on this problem

any questions, please ask


Link to comment
Share on other sites

just normally. i believe if the torrent is over 50ish gb this happens. even more so if a few (3 or more) torrents are running together (leeching and seeding). i dont believe it has anything to do with the filecounts as these are iso tosec sets.

the disk based tosec sets have many thousands more files but have no trouble (approx 10gb sized).


the bug also happens here

if i am downloading a torrent (18gb) to the fileserver no problems on its own

if i then attempt to download the 60gb torrent to the local drive, it eventually kills the 18gb torrent with the same error: The specified network name is no longer available.

Link to comment
Share on other sites

If it's not related to the number of files, maybe it's related to the size of the largest file?

Is that a single 130 GB iso or is it split up into smaller DVDs like 4 GB or 8 GB images?

Also, you have this problem by seeding these large torrents alone, right? Or does it only happen when you download?

Link to comment
Share on other sites

to be honest i dont think it is

the largest file is probably 600mb in the torrents. these are tosec iso torrents.

to be honest i cant get to the seeding stage to test it natrually. if i download the 130gb torrent to local drive and then move it to the server it still does the error when part way through checking the torrent. so in answer the bug can happen at any time or state.

i personally believe it is something to do with the total size of the torrent but i can't say why as it only seems to happen on 40gb+ torrents.

Link to comment
Share on other sites

From looking at the BitTornado source, the only significant difference I can see is that you optionally can lock files while they are open. Do you know if you use this option?

The other thing I can see is that it calls fsync() before reading files.

Btw. In uTorrent, did you try play around with the disk IO options? It might help to uncheck the "Disable Windows caching of disk writes". This wouldn't explain why it didn't work in versions all the way back to 1.6 though.

Link to comment
Share on other sites

i use bittornado with default options

i have unchecked "Disable Windows caching of disk writes" and am testing now but so far so good

i'll give an update after i have torture tested it

thanks for relpys do far by the way

all good so far, no errors occured

will keep on testing and keep you all updated


no its still doing it

[2009-03-23 07:07:08] IO Error:64 line:400 align:1 pos:1584485580 count:16384 actual:-99

[2009-03-23 07:07:08] IO Error:64 line:650 align:512 pos:1584485580 count:16384 actual:0

it seems once it has done it once, then the error occurs easier

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...