Jump to content

Version 0.9.1.1 has been released


Firon

Recommended Posts

  • Replies 76
  • Created
  • Last Reply

The previous version 0.9.1.1 used up 100% of my CPU after about 2 minutes of use. The new version 0.9.1.2 works well for about the first two minutes also, however after instead of spiking my cpu usage to 100% on a consistent basis, it spikes to about 85% and then corrects this issue temporarily and then goes back to 85%. This cycle continued for the rest of my download. Will keep on trying and see if this trend continues. Let me know if you want more info.

Link to comment
Share on other sites

Just testing the 0.9.1.2 RC. The unwanted port randomization on startup is still there, occasionally keeping the manual setting, but if it manages to keep it, on next restart it's always set to port 0, and then it's randomized again next time. The status light sometimes goes green even though the current port is not open when checking with the port checker page. No excessive CPU values so far after a half hour of work. CPU usage stays around 10% with close to a hundred torrents seeding simultaneously. Occasionally, it goes up to about 50 % and back to normal after 4-5 seconds, but it happens rarely. Multiple torrents are seeding and downloading, attaining same speeds as with 0.9.4, speed limiters are working.

Edit: Now CPU went up to 100% and stayed there for a while, here's a sample:

http://bluesprite.my.contact.bg/files/Sample%20of%20uTorrent.txt

Link to comment
Share on other sites

firon,

the new build, 0.9.1.2 RC, has dramatically increased how many seeds and peers I can connect to with multiple torrents running (and therefore, much higher speeds). kudos to the team on this build. however, the 100% cpu problem persists. utorrent will float at 6% cpu usage when downloading two torrents, and then spike to 97.4% - 100%, then go back down to 6%. i'll post a sample when I can.

running

macbook pro unibody 2.53ghz, 4gb ram, 10.5.6

sample - http://dl.getdropbox.com/u/157212/Sample%20of%20uTorrent.txt

Link to comment
Share on other sites

I downloaded the 0.9.1.2 build. It works great, thingy is green, downloading at full speed, nice! :-). I do sometimes have the CPU peak problem. Not a lot but I managed to get a sample: http://dl.getdropbox.com/u/974111/Sample%20of%20uTorrent.txt

This sample was taken when cpu was between 80 - 90%

Macbook Pro (old one) 2.6 GHz, 4GB Ram, OSX 10.5.6

Keep up the good work!! :-)

Link to comment
Share on other sites

I am facing a wierd issue with 0.9.1.2 RC. The display in the window does not update at all. The percentage bars on the torrents as well as the details tabs remain at same value no matter what happens. Eg. when I open a torrent file, the torrent details always show 0% downloaded no matter how much it downloads. When I quit and restart uT, then the value being displayed is the percentage completed amount when utorrent started.

Link to comment
Share on other sites

Build 15220 crashes 10-20 minutes after launch. While it's loaded, there's no abnormal CPU usage (force-seeding over 200 torrents). It still doesn't keep the port number and it's randomized at launch, occasionally setting it to zero, but at least UPnP seems to be working now. The crash occurs without any notification, it just quits silently after a while. Here's the system log messages:

22.04.09 16:08:17 uTorrent[1058] Could not find image named 'SplitViewGrabber'.

22.04.09 16:08:17 uTorrent[1058] Could not find image named 'HideStats'.

22.04.09 16:08:17 uTorrent[1058] Could not find image named 'ShowStats.tiff'.

22.04.09 16:08:17 uTorrent[1058] **** Posting Msg: BitTorrent_TorrentFileAdded ****

22.04.09 16:08:17 uTorrent[1058] **** Posting Msg: BitTorrent_TorrentFileAdded ****

22.04.09 16:08:17 uTorrent[1058] **** Posting Msg: BitTorrent_TorrentFileAdded ****

...

22.04.09 16:08:18 uTorrent[1058] **** Posting Msg: BitTorrent_TorrentFileAdded ****

22.04.09 16:08:18 uTorrent[1058] **** Posting Msg: BitTorrent_TorrentFileAdded ****

22.04.09 16:08:18 uTorrent[1058] *** _networkReachabilityChangedCallback got flags: -r-----

22.04.09 16:08:18 uTorrent[1058] networkReachabilityDidChange: NSConcreteNotification 0x116b60 {name = BitTorrentNetworkReachabilityDidChangeNotification; object = 1}

22.04.09 16:08:18 uTorrent[1058] networkReachabilityDidChange: NSConcreteNotification 0x116b60 {name = BitTorrentNetworkReachabilityDidChangeNotification; object = 1}

22.04.09 16:12:02 com.apple.launchd[373] ([0x0-0x67067].com.bittorrent.uTorrent[1058]) Exited abnormally: Broken pipe

22.04.09 16:12:02 com.apple.launchd[373] ([0x0-0x67067].com.bittorrent.uTorrent[1058]) Exited abnormally: Broken pipe

______________________________________________

And another one:

22.04.09 13:16:02 uTorrent[659] An instance 0x24efe0 of class PrefsController is being deallocated while key value observers are still registered with it. Observation info is being leaked, and may even become mistakenly attached to some other object. Set a breakpoint on NSKVODeallocateBreak to stop here in the debugger. Here's the current observation info:

<NSKeyValueObservationInfo 0x1a9a7520> (

<NSKeyValueObservance 0x2b5a50: Observer: 0x20aaa0, Key path: uploadRateLimitAuto, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x28f4e0>

<NSKeyValueObservance 0x2b5f40: Observer: 0x20aaa0, Key path: uploadRateLimitedManual, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b5f20>

<NSKeyValueObservance 0x2b6310: Observer: 0x20aaa0, Key path: uploadRateLimitManual, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b5a70>

<NSKeyValueObservance 0x2b6660: Observer: 0x20aaa0, Key path: seedRatioLimited, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b5f60>

<NSKeyValueObservance 0x2b6900: Observer: 0x20aaa0, Key path: seedRatio, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b6330>

<NSKeyValueObservance 0x2b6bf0: Observer: 0x20aaa0, Key path: downloadRateLimited, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2a3d90>

<NSKeyValueObservance 0x2b6f40: Observer: 0x20aaa0, Key path: downloadRateLimit, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b69b0>

<NSKeyValueObservance 0x16a6e220: Observer: 0x22f300, Key path: autoAddTorrentFiles, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x18c646e0>

<NSKeyValueObservance 0x16a6a2d0: Observer: 0x22f300, Key path: autoAddFolder, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x18c618e0>

<NSKeyValueObservance 0x1abde6f0: Observer: 0x1abcd270, Key path: uploadRateLimitAuto, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x28f4e0>

<NSKeyValueObservance 0x18c69f10: Observer: 0x1abcd270, Key path: uploadRateLimitedManual, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b5f20>

<NSKeyValueObservance 0x18c69f30: Observer: 0x1abcd270, Key path: uploadRateLimitManual, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b5a70>

<NSKeyValueObservance 0x1abdc9d0: Observer: 0x1abcd270, Key path: seedRatioLimited, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b5f60>

<NSKeyValueObservance 0x16a920c0: Observer: 0x1abcd270, Key path: seedRatio, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b6330>

<NSKeyValueObservance 0x1abdc9f0: Observer: 0x1abcd270, Key path: downloadRateLimited, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2a3d90>

<NSKeyValueObservance 0x1abdca10: Observer: 0x1abcd270, Key path: downloadRateLimit, Options: <New: NO, Old: NO, Prior: NO> Context: 0x0, Property: 0x2b69b0>

And again:

22.04.09 16:30:23 uTorrent[1139] An instance 0x169820 of class MainWindowController is being deallocated while key value observers are still registered with it. Observation info is being leaked, and may even become mistakenly attached to some other object. Set a breakpoint on NSKVODeallocateBreak to stop here in the debugger. Here's the current observation info:

<NSKeyValueObservationInfo 0x1aad70> (

<NSKeyValueObservance 0x164790: Observer: 0x12e920, Key path: sidebarMenuText, Options: <New: NO, Old: NO, Prior: NO> Context: 0x15b480, Property: 0x19ddb0>

)

Link to comment
Share on other sites

It crashed after 5 minutes 4/22/09 3:49:06 PM uTorrent[43260] 55,13

4/22/09 3:49:06 PM uTorrent[43260] apple

4/22/09 3:49:23 PM uTorrent[43260] 55,13

4/22/09 3:49:23 PM uTorrent[43260] apple

4/22/09 3:49:24 PM uTorrent[43260] 55,13

4/22/09 3:49:24 PM uTorrent[43260] apple

4/22/09 3:49:43 PM uTorrent[43260] 55,13

4/22/09 3:49:43 PM uTorrent[43260] apple

4/22/09 3:50:33 PM uTorrent[43260] 55,13

4/22/09 3:50:33 PM uTorrent[43260] apple

4/22/09 3:52:13 PM com.apple.launchd[128] ([0x0-0x644644].com.bittorrent.uTorrent[43260]) Exited abnormally: Broken pipe

Link to comment
Share on other sites

Can confirm 100% CPU usage, some times even 101% and 102%!

Was not able to record 100%, right now getting 96-99%:

http://www.2shared.com/file/5455958/61026a2c/Sample_of_uTorrent.html (96KB)

_____________

Unibody MacBook Pro:

Version 10.5.6

Processor 2.53 GHz Intel Core 2 Duo

Memory 4 GB 1067 MHz DDR3

UTorrent Version 0.9.1.1 (14940)

Also, some times after i quit UTorrent after 100% CPU usage, it resets my port to 0 (option to randomize port each start is disabled), happened already 4-6 times, after setting new port it sometimes not recognizes what i changed it, so i quit it again, and again till it recognizes port.

Link to comment
Share on other sites

Just found about rc2, i completely cant change port!

Wan i first time started it port was set on 0, wan i tried to apply my port 10001 it told me "Listen Error". Now it shows me wrong port(11218) and tells me what "Connection working" that cant be 11218, all ports are closed except 10001, means only 10001 can be green, all others will be yellow or red. I think UTorrent somehow shows one port in Preferences, but in real he uses other port.

________

EDIT: Option to randomize port was not selected.

________

EDIT2: in rc1 i simply got always 96-102% CPU usage, now it jumps up and down, from 9% to 100%, but does not stay for to long on 100%...

________

EDIT3: UTorrent rc2 crashes periodically whiteout any error display.

UTorrent continues to show every time i start it new port in preferences, however it seems what in real he continues to use 10001 port...

Link to comment
Share on other sites

the 9.1.1 and 9.1.2 releases both have a bug where the Incoming TCP Port is not being saved and set to 0 every time the app launches.

This is probably causing all the connection errors people are having.

A current work around is to have the "radomise port during launch" option set - but for people who need a static routing table this isn't going to help.

Link to comment
Share on other sites

maybe this will help:

reset your router.. set DMZ for your mac.. activate uPnP

install 0.9.1.2RC2 run it for a while

reinstall 0.9.1.1 run for 5 minutes orf lesss

reinstall RC2....

now µtorrent will run better...

at all 40% cpu usage / 275 kb download /30 kb upload / more than 40 torrents working

ADSL 6MB/320KB

Link to comment
Share on other sites

I hope they havnt given up... even though it doesnt work well i still get faster speeds than anything else out there...but then it crashes haha. Quick question...since utorrent is owned by bittorrent, should we assume that the bittorrent client is the best they will be able to come up with?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...