Jump to content

Logger - IO Error: 13, job status - Error: The data is invalid.

mickey torman

Recommended Posts

First, the information requested to be sent with every problem report:

I am running utorrent 1.8.2 build 14458.

I have a DSL connection with nominal rating of 2,000kb/s from pldtdsl.net (Philippines).

My network status light both before and after the error (described below) occurs is green.

The Speed Guide shows my upload limit is 51.0kB/s, upload slots = 3, connections per torrent = 55, connections (global) = 80, max active torrents = 1, max active downloads = 1.

The speed test at dslreports.com shows 216ms latency, 94Kb/s download, 56Kb/s upload (to/from Megapath San Francisco). I redid the speed test at speedtest.net and got 515 ms ping, 550 kb/s download and 90 Kb/s upload (to/from Unwired, San Francisco). I don't understand the big difference in download times or the huge difference between download and upload times.

The port checker shows that the port is open and accepting connections.

net.max.half_open is set to 8 (I have never changed it.)

I am using Windows XP SP2. Utorrent is running in a 180GB hard disk partition that is only about half full.

My modem is a Zyxel Prestige 650R-31. My router is a Linksys WRT110. Only one computer was connected and operating during the entire period in which the problems described below occurred.

My computer is a Compaq EVO-D510, Intel Pentium 4 CPU, 2.00GHz, 1.25GB RAM, Intel 845G

chipset. My hard drive is a 360GB Seagate ST3320620AV, divided into two 180GB partitions.

A HijackThis log follows the problem description below.

*********************************Below is the description of the problem****************************

I am downloading only one torrent containing approx 2,000 files. I have selected about 1,000 of them for downloading (representing 51GB of a 142GB torrent). I have successfully downloaded 100% of 603 of the 1,000 selected files. The remaining 397 files are at various stages of completion ranging from 0 to 98%+ .The download is stuck at about 70% completion with 14.9GB remaining to be downloaded out of a total of 51GB .

I am getting logger error code " IO Error: 13" very frequently. When the error occurs, the job status changes from "Downloading" to "Error: The data is invalid." Below is a copy of the relevant portion of the logger file:

[2009-04-29 23:08:13] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-04-30 00:34:00] IO Error:13 line:1787 align:-99 pos:15254994944 count:655360 actual:-99

[2009-04-30 00:45:19] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-04-30 02:33:00] IO Error:13 line:1787 align:-99 pos:140325950876 count:76388 actual:-99

[2009-04-30 02:42:37] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-04-30 03:37:02] IO Error:13 line:1787 align:-99 pos:140326043648 count:622592 actual:-99

[2009-04-30 06:52:14] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-04-30 07:13:37] UPnP: Device error "": (10061) No connection could be made because the target machine actively refused it.

[2009-04-30 09:13:20] UPnP: Device error "": (10061) No connection could be made because the target machine actively refused it.

[2009-04-30 10:33:35] IO Error:13 line:1787 align:-99 pos:44570509312 count:1638034 actual:-99

[2009-04-30 12:31:33] IO Error:13 line:1787 align:-99 pos:66232795136 count:116276 actual:-99

[2009-04-30 12:35:14] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

Note that the logger error always contains either "line: 1787" or "line: 1820". Every time I get one of these errors I "Force Recheck". Sometimes the error code occurs during the recheck, and when it does, the job's "Done" entry is always about 3.7%. I then "Force Recheck" again, the checking runs to successful completion, and the job's "Done" entry changes to "Stopped". I then "Start" and the downloading resumes for about 5 or 10 minutes after which I again get one of the logger error codes listed above.

Rechecking of the 36GB of data already downloaded takes about 15 minutes, and I have to be

watching to catch the job status when it changes from "Checked xx.x%" to "Stopped" so that I can Start the downloading again without delay.

I have read all the utorrent Help and FAQ information, searched the utorrent Troubleshooting Forum, and done lots of googling using various search parameters related to the utorrent logger error codes I am getting, but I have found nothing at all that is of any help to me in resolving the problem.

Can someone tell me what "IO Error: 13 is"? Also what are the meanings of "line", "align", "pos", and "count"? It would seem to me that there must be enough data in the logger error code for me to identify exactly where the invalid data is so that I can remove it. Can anyone tell me how to do this or what to do so that I can continue the download without these frequent errors?

Thanks in advance for whatever help you can give me to solve this problem!

************************************HijackThis log follows***********************************

Below is a HijackThis log as requested in the post listing information to be provided when reporting a problem. The log shows that both Avast and AVG anti-virus software have running processes, but during the period when the problems occurred, Avast was disabled and only AVG was running. Also, Windows Desktop Search was turned off although the log below seems to show a running process.

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 3:25:46 PM, on 4/30/2009

Platform: Windows XP SP2 (WinNT 5.01.2600)

MSIE: Internet Explorer v7.00 (7.00.6000.16827)

Boot mode: Normal

Running processes:








C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe

C:\Program Files\Alwil Software\Avast4\ashServ.exe


C:\Program Files\AVG\AVG8\IdentityProtection\agent\Bin\AVGIDSAgent.exe


C:\Program Files\AVG\AVG8\IdentityProtection\agent\Bin\AVGIDSWatcher.exe

C:\Program Files\MSI\BToes Bluetooth Software\bin\btwdins.exe

C:\Program Files\Java\jre6\bin\jqs.exe

C:\Program Files\Google\Update\GoogleUpdate.exe

C:\Program Files\Linksys\Linksys Updater\bin\LinksysUpdater.exe





C:\Program Files\Alcohol Soft\Alcohol 120\StarWind\StarWindService.exe






C:\Program Files\Webroot\Washer\WasherSvc.exe


C:\Program Files\Common Files\Pure Networks Shared\Platform\nmsrvc.exe

C:\Program Files\AVG\AVG8\avgcsrvx.exe

C:\Program Files\HP\HP Software Update\HPWuSchd2.exe




C:\Program Files\Common Files\Pure Networks Shared\Platform\nmctxth.exe

C:\Program Files\AVG\AVG8\IdentityProtection\agent\bin\AVGIDSUI.exe


C:\Program Files\Skype\Phone\Skype.exe


C:\Program Files\uTorrent\uTorrent.exe

C:\Program Files\Windows Live\Messenger\msnmsgr.exe

C:\Program Files\AVG\AVG8\IdentityProtection\agent\bin\AVGIDSMonitor.exe

C:\Program Files\HP\Digital Imaging\bin\hpqtra08.exe

C:\Program Files\Linksys\Linksys EasyLink Advisor\Linksys EasyLink Advisor.exe



C:\Program Files\HP\Digital Imaging\bin\hpqSTE08.exe

C:\Program Files\Skype\Plugin Manager\SkypePM.exe

C:\Program Files\HP\Digital Imaging\bin\hpqnrs08.exe

C:\Program Files\Mozilla Firefox\firefox.exe


C:\Program Files\Common Files\Real\Update_OB\realsched.exe




C:\Program Files\Internet Explorer\IEXPLORE.EXE



C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.msnbc.com/

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL =


R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL =


R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page =


R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page =


R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = *.local

R3 - URLSearchHook: isoHunt Toolbar - {a6e4a4eb-d169-4e99-8988-250fcbafe767} - C:\Program Files\isoHunt\tbisoH.dll

O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program

Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll

O2 - BHO: Skype add-on (mastermind) - {22BF413B-C6D2-4d91-82A9-A0F997BA588C} -

C:\Program Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll

O2 - BHO: RealPlayer Download and Record Plugin for Internet Explorer -

{3049C3E9-B461-4BC5-8870-4C09146192CA} - C:\Program


O2 - BHO: WormRadar.com IESiteBlocker.NavFilter -

{3CA2F312-6F6E-4B53-A66E-4E65E497C8C0} - C:\Program Files\AVG\AVG8\avgssie.dll

O2 - BHO: (no name) - {5C255C8A-E604-49b4-9D64-90988571CECB} - (no file)

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program


O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} -

C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll

O2 - BHO: AVG Security Toolbar - {A057A204-BACC-4D26-9990-79A187E2698E} -


O2 - BHO: isoHunt Toolbar - {a6e4a4eb-d169-4e99-8988-250fcbafe767} - C:\Program


O2 - BHO: AcroIEToolbarHelper Class - {AE7CD045-E861-484f-8273-0445EE161910} - C:\Program Files\Adobe\Acrobat 6.0\Acrobat\AcroIEFavClient.dll

O2 - BHO: (no name) - {CDE8EAB9-CEF3-4885-B12F-26960A25C800} - (no file)

O2 - BHO: MSN Toolbar Helper - {d2ce3e00-f94a-4740-988e-03dc2f38c34f} - C:\Program


O2 - BHO: Java Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} -

C:\Program Files\Java\jre6\bin\jp2ssv.dll

O2 - BHO: JQSIEStartDetectorImpl - {E7E6F031-17CE-4C07-BC86-EABFE594F69C} - C:\Program Files\Java\jre6\lib\deploy\jqs\ie\jqs_plugin.dll

O3 - Toolbar: Adobe PDF - {47833539-D0C5-4125-9FA8-0819E2EAAC93} - C:\Program

Files\Adobe\Acrobat 6.0\Acrobat\AcroIEFavClient.dll

O3 - Toolbar: isoHunt Toolbar - {a6e4a4eb-d169-4e99-8988-250fcbafe767} - C:\Program


O3 - Toolbar: AVG Security Toolbar - {A057A204-BACC-4D26-9990-79A187E2698E} -


O3 - Toolbar: MSN Toolbar - {1E61ED7C-7CB8-49d6-B9E9-AB4C880C8414} - C:\Program


O4 - HKLM\..\Run: [NvCplDaemon] "RUNDLL32.EXE" C:\WINDOWS\system32\NvCpl.dll,NvStartup

O4 - HKLM\..\Run: [HP Software Update] "C:\Program Files\HP\HP Software Update\HPWuSchd2.exe"

O4 - HKLM\..\Run: [nwiz] "nwiz.exe" /install

O4 - HKLM\..\Run: [AVG8_TRAY] C:\PROGRA~1\AVG\AVG8\avgtray.exe

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_01\bin\jusched.exe"

O4 - HKLM\..\Run: [NvMediaCenter] "RUNDLL32.EXE" C:\WINDOWS\System32\NvMcTray.dll,NvTaskbarInit

O4 - HKLM\..\Run: [nmctxth] "C:\Program Files\Common Files\Pure Networks Shared\Platform\nmctxth.exe"

O4 - HKLM\..\Run: [AVGIDS] "C:\Program Files\AVG\AVG8\IdentityProtection\agent\bin\AVGIDSUI.exe"

O4 - HKLM\..\Run: [spySweeper] C:\Program Files\Webroot\Spy Sweeper\SpySweeperUI.exe


O4 - HKLM\..\Run: [TkBellExe] "C:\Program Files\Common Files\Real\Update_OB\realsched.exe" -osboot

O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe

O4 - HKCU\..\Run: [skype] "C:\Program Files\Skype\Phone\Skype.exe" /nosplash /minimized

O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe

O4 - HKCU\..\Run: [uTorrent] "C:\Program Files\uTorrent\uTorrent.exe"

O4 - HKCU\..\Run: [swg] "C:\Program Files\Google\GoogleToolbarNotifier\GoogleToolbarNotifier.exe"

O4 - HKCU\..\Run: [msnmsgr] "C:\Program Files\Windows Live\Messenger\msnmsgr.exe"


O4 - Global Startup: HP Digital Imaging Monitor.lnk = C:\Program Files\HP\Digital


O4 - Global Startup: Linksys EasyLink Advisor.lnk = C:\Program Files\Linksys\Linksys EasyLink

Advisor\Linksys EasyLink Advisor.exe

O4 - Global Startup: Windows Desktop Search.lnk = C:\Program Files\Windows Desktop


O8 - Extra context menu item: E&xport to Microsoft Excel -


O8 - Extra context menu item: Send To &Bluetooth - C:\Program Files\MSI\BToes Bluetooth


O9 - Extra button: Skype - {77BF5300-1474-4EC7-9980-D32B190E9B07} - C:\Program

Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll

O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} -


O9 - Extra button: @btrez.dll,-4015 - {CCA281CA-C863-46ef-9331-5C8D4460577F} - C:\Program Files\MSI\BToes Bluetooth Software\btsendto_ie.htm

O9 - Extra 'Tools' menuitem: @btrez.dll,-4017 - {CCA281CA-C863-46ef-9331-5C8D4460577F}

C:\Program Files\MSI\BToes Bluetooth Software\btsendto_ie.htm

O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe

O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe

O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program

Files\Messenger\msmsgs.exe (file missing)

O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe (file missing)

O16 - DPF: {02BF25D5-8C17-4B23-BC80-D3488ABDDC6B} (QuickTime Object) -


O16 - DPF: {156BF4B7-AE3A-4365-BD88-95A75AF8F09D} (HPSDDX Class) -


O16 - DPF: {1E54D648-B804-468d-BC78-4AFFED8E262E} (System Requirements Lab) -


O16 - DPF: {215B8138-A3CF-44C5-803F-8226143CFC0A} (Trend Micro ActiveX Scan Agent 6.6) - http://housecall65.trendmicro.com/housecall/applet/html/native/x86/win32/activex/hcImpl.cab

O16 - DPF: {48DD0448-9209-4F81-9F6D-D83562940134} (MySpace Uploader Control) -


O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) -


O16 - DPF: {67A5F8DC-1A4B-4D66-9F24-A704AD929EEE} (System Requirements Lab) -


O16 - DPF: {6E32070A-766D-4EE6-879C-DC1FA91D2FC3} (MUWebControl Class) -


O16 - DPF: {74DBCB52-F298-4110-951D-AD2FF67BC8AB} (NVIDIA Smart Scan) -


O16 - DPF: {BDBDE413-7B1C-4C68-A8FF-C5B2B4090876} (F-Secure Online Scanner 3.3) -


O16 - DPF: {CF40ACC5-E1BB-4AFF-AC72-04C2F616BCA7} (get_atlcom Class) -


O16 - DPF: {D71F9A27-723E-4B8B-B428-B725E47CBA3E} -


O16 - DPF: {E06E2E99-0AA1-11D4-ABA6-0060082AA75C} -

O16 - DPF: {EF791A6B-FC12-4C68-99EF-FB9E207A39E6} (McFreeScan Class) -


O18 - Protocol: linkscanner - {F274614C-63F8-47D5-A4D1-FBDDE494F8D1} - C:\Program


O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} -


O20 - Winlogon Notify: avgrsstarter - C:\WINDOWS\SYSTEM32\avgrsstx.dll

O23 - Service: Adobe LM Service - Unknown owner - C:\Program Files\Common Files\Adobe

Systems Shared\Service\Adobelmsvc.exe

O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - ALWIL Software - C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe

O23 - Service: avast! Antivirus - ALWIL Software - C:\Program Files\Alwil


O23 - Service: avast! Mail Scanner - ALWIL Software - C:\Program Files\Alwil


O23 - Service: avast! Web Scanner - ALWIL Software - C:\Program Files\Alwil


O23 - Service: AVG8 E-mail Scanner (avg8emc) - AVG Technologies CZ, s.r.o. -


O23 - Service: AVG8 WatchDog (avg8wd) - AVG Technologies CZ, s.r.o. -


O23 - Service: AVGIDSAgent - AVG - C:\Program


O23 - Service: AVGIDSWatcher - AVG - C:\Program


O23 - Service: Bluetooth Service (btwdins) - Broadcom Corporation - C:\Program Files\MSI\BToes Bluetooth Software\bin\btwdins.exe

O23 - Service: getPlus® Helper - NOS Microsystems Ltd. - C:\Program


O23 - Service: Google Update Service (gupdate1c9a2c262d406ec) (gupdate1c9a2c262d406ec) - Google Inc. - C:\Program Files\Google\Update\GoogleUpdate.exe

O23 - Service: Google Updater Service (gusvc) - Google - C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe

O23 - Service: Java Quick Starter (JavaQuickStarterService) - Sun Microsystems, Inc. - C:\Program Files\Java\jre6\bin\jqs.exe

O23 - Service: Linksys Updater (LinksysUpdater) - Unknown owner - C:\Program Files\Linksys\Linksys Updater\bin\LinksysUpdater.exe

O23 - Service: Pure Networks Platform Service (nmservice) - Pure Networks, Inc. - C:\Program

Files\Common Files\Pure Networks Shared\Platform\nmsrvc.exe

O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation -


O23 - Service: Port Reporter (PortReporter) - Unknown owner - C:\Program

Files\PortReporter\portreporter.exe (file missing)

O23 - Service: ServiceLayer - Nokia. - C:\Program Files\PC Connectivity Solution\ServiceLayer.exe

O23 - Service: StarWind iSCSI Service (StarWindService) - Rocket Division Software - C:\Program Files\Alcohol Soft\Alcohol 120\StarWind\StarWindService.exe

O23 - Service: Webroot Spy Sweeper Engine (WebrootSpySweeperService) - Webroot Software, Inc. (www.webroot.com) - C:\Program Files\Webroot\Spy Sweeper\SpySweeper.exe

O23 - Service: Window Washer Engine (wwEngineSvc) - Webroot Software, Inc. - C:\Program



End of file - 14067 bytes

Link to comment
Share on other sites

The relevant data would be from your running processes log(s)... Something is corrupting/locking the data after it goes from RAM to disk. Does it happen on all files? Does it happen in all locations? (Where are you saving now?) Are you skipping many insequential files? To find out, highlight all your files set to SKIP in the Files tab, right click, show first piece #, sort by that...

INVALID_DATA means... something is amiss. If you're unsure about the hardware connection, you could try disconnecting and reseating the hardware cables in the drive, and then doing the device manager > IDE controller check to be sure there's no errors.

Link to comment
Share on other sites

Thanks very much for your suggestions.

I am experiencing corruption/locking only with the torrent download described above. The torrent downloads are being saved to C:\Documents and Settings\admin\My Documents\Downloads.

I am not experiencing corruption/locking with any other files saved to this location or to any other location in the system.

Many files are being skipped out of sequence. I sorted the files according to first piece number as you suggested and counted the groups of selected files, skipped files, selected files, etc. I found that there were 181 groups. The torrent contains a total of 18,285 pieces. The torrent contains a total of 1,756 files of which 868 have been selected and 888 skipped. Of the 868 selected files, 571 have been 100% downloaded. Of the remaining 267 files, 85 have been 0% downloaded and 182 have been partially downloaded, with percentages ranging from 0.1% to 98.7%.

The sequence of events is always the same:

(1) After downloading for 5-15 minutes, the downloading stops with job "Done" about 70.5% and job status "Error: The data is invalid". The logger error at this point is always "IO Error:13 line: 1787..."

(2) I then "Force recheck" and the recheck always ends with job "Done" at about 3.8% and job status "Error: The data is invalid." The logger error at this point is always "IO Error: 13 line: 1820..."

(3) I then "Force recheck" again and the recheck runs to completion without error after which job "Done" is 100% and job status is "Stopped".

(4) I then "Start" and downloading begins and continues for about 5-15 minutes after which it stops as in (1) above.

The cycle of (1) - (4) then repeats on a regular basis thereafter.

When I noted that the rechecking is done in order by piece #, I then did the recheck with the files listed in order by first piece to see if I could identify the file in which the invalid data error occurs. When the recheck error occurred, I removed the last selected file with "blue" pieces and the first selected file after that. (There were 4 skips in between that I left alone.) I moved these two files from the download directory to a "Problems" folder hoping that utorrent would consider them 0% loaded and not find any more invalid data. After doing this, some files that had been 100% downloaded now had one or more missing pieces and the recheck ended again with an invalid data error at this point. No matter how many files I moved to the "Problems" folder, the invalid data error kept recurring. So I gave up on that ploy and put the "Problems" files back into the download directory. I am now back where I was when I first reported this problem and don't know what to do next (except labor through the (1) to (4) cycle described above.)

Device Manager reports that all IDE ATA/ATAPI controllers are working properly:

(1) Intel 82801DB Ultra ATA Storage Controller - 24CB

(2) Primary IDE channel, and

(3) Secondary IDE channel.

The recent logger entries are as follows.

[2009-05-01 04:23:47] IO Error:13 line:1787 align:-99 pos:153386565632 count:524288 actual:-99

[2009-05-01 04:29:09] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-05-01 09:10:22] UPnP: Device error "": (10061) No connection could be made because the target machine actively refused it.

[2009-05-01 11:09:45] IO Error:13 line:1787 align:-99 pos:16242884608 count:573440 actual:-99

[2009-05-01 12:15:04] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-05-01 13:28:07] UPnP: ERROR removing TCP port 35214: (714) The specified value does not exist in the array

[2009-05-01 13:28:08] UPnP: ERROR removing UDP port 35214: (714) The specified value does not exist in the array

[2009-05-01 14:08:45] IO Error:13 line:1787 align:-99 pos:7115259904 count:457542 actual:-99

[2009-05-01 15:28:25] UPnP: ERROR removing TCP port 35214: (714) The specified value does not exist in the array

[2009-05-01 15:28:25] UPnP: ERROR removing UDP port 35214: (714) The specified value does not exist in the array

[2009-05-01 17:16:54] IO Error:13 line:1787 align:-99 pos:66229043200 count:1146880 actual:-99

[2009-05-01 17:28:03] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-05-01 18:16:57] IO Error:13 line:1787 align:-99 pos:66228060160 count:425984 actual:-99

[2009-05-01 18:32:58] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-05-01 21:09:47] UPnP: ERROR removing TCP port 35214: (714) The specified value does not exist in the array

[2009-05-01 21:09:47] UPnP: ERROR removing UDP port 35214: (714) The specified value does not exist in the array

[2009-05-01 21:41:55] IO Error:13 line:1787 align:-99 pos:53150515200 count:278528 actual:-99

[2009-05-01 22:04:21] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-05-01 22:30:03] UPnP: Could not map UPnP Port on this pass, retrying.

[2009-05-01 23:30:22] UPnP: Could not detect external IP on this pass, retrying.

[2009-05-01 23:38:27] IO Error:13 line:1787 align:-99 pos:7114670080 count:983040 actual:-99

[2009-05-01 23:50:42] UPnP: Could not detect external IP on this pass, retrying.

[2009-05-01 23:52:50] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-05-02 01:08:20] UPnP: Device error "": (10061) No connection could be made because the target machine actively refused it.

[2009-05-02 02:14:47] IO Error:13 line:1787 align:-99 pos:140326125568 count:294912 actual:-99

[2009-05-02 03:37:08] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-05-02 04:19:55] IO Error:13 line:1787 align:-99 pos:7114670080 count:999424 actual:-99

[2009-05-02 04:25:10] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-05-02 05:07:49] UPnP: Device error "": (10053) connection closed by peer

[2009-05-02 06:01:54] IO Error:13 line:1787 align:-99 pos:53150220288 count:278528 actual:-99

[2009-05-02 07:15:38] UPnP: ERROR removing TCP port 35214: (714) The specified value does not exist in the array

[2009-05-02 07:15:43] UPnP: ERROR removing UDP port 35214: (714) The specified value does not exist in the array

[2009-05-02 09:16:15] UPnP: ERROR removing TCP port 35214: (714) The specified value does not exist in the array

[2009-05-02 09:16:15] UPnP: ERROR removing UDP port 35214: (714) The specified value does not exist in the array

[2009-05-02 09:50:57] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

[2009-05-02 13:14:30] IO Error:13 line:1787 align:-99 pos:109504970752 count:278528 actual:-99

[2009-05-02 13:16:52] UPnP: ERROR removing TCP port 35214: (714) The specified value does not exist in the array

[2009-05-02 13:16:52] UPnP: ERROR removing UDP port 35214: (714) The specified value does not exist in the array

[2009-05-02 13:19:58] IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99


The Process Explorer log for utorrent (obtained by highlighting utorrent in the upper pane and entering CTRL+S follows:

Process: uTorrent.exe Pid: 3692

Name Description Company Name Version

ACTIVEDS.dll ADs Router Layer DLL Microsoft Corporation 5.1.2600.2180

adsldpc.dll ADs LDAP Provider C DLL Microsoft Corporation 5.1.2600.2180

ADVAPI32.dll Advanced Win 32 Base API Microsoft Corporation 5.1.2600.3520

AhJsctNs.dll avast! Script Blocking lib ALWIL Software 4.8.1335.0

appHelp.dll App. Compatibility

Client Library Microsoft Corporation 5.1.2600.2180

ashShell.dll avast! Shell Extension ALWIL Software 4.8.1335.0

ATL.DLL ATL Module-Win XP-

Unicode Microsoft Corporation 3.5.2284.0

Audiodev.dll Portable Media Devices

Shell Extension Microsoft Corporation 5.2.5721.5145

avgse.dll AVG Shell Extension AVG Tech. CZ, s.r.o.


AVIFIL32.dll MS AVI File support lib Microsoft Corporation 5.1.2600.2180

browseui.dll Shell Browser UI Library Microsoft Corporation 6.0.2900.3059

btncopy.dll BTNCopy Module Broadcom Corporation

CFGMGR32.dll Config Mgr Forwarder DLL Microsoft Corporation 5.1.2600.2180

CLBCATQ.DLL Microsoft Corporation 2001.12.4414.308

COMCTL32.dll User Experience

Controls Library Microsoft Corporation 6.0.2900.2982

comdlg32.dll Common Dialogs DLL Microsoft Corporation 6.0.2900.2180

COMRes.dll Microsoft Corporation 2001.12.4414.258

credui.dll Credential Manager

User Interface Microsoft Corporation 5.1.2600.2180

CRYPT32.dll Crypto API32 Microsoft Corporation 5.131.2600.2180

CRYPTUI.dll Microsoft Trust UI Provider Microsoft Corporation 5.131.2600.2180

CSCDLL.dll Offline Network Agent Microsoft Corporation 5.1.2600.2180

cscui.dll Client Side Caching UI Microsoft Corporation 5.1.2600.2180


davclnt.dll Web DAV Client DLL Microsoft Corporation 5.1.2600.2180

DnsApi.dll DNS Client API DLL Microsoft Corporation 5.1.2600.3394

drprov.dll MS Terminal Server

Network Provider Microsoft Corporation 5.1.2600.2180

GDI32.dll GDI Client DLL Microsoft Corporation 5.1.2600.3466

gdiplus.dll Microsoft GDI+ Microsoft Corporation 5.1.3102.3352

hnetcfg.dll Home Networking

Configuration Manager Microsoft Corporation 5.1.2600.2180

ieframe.dll Internet Explorer Microsoft Corporation 7.0.6000.16825

ieframe.dll.mui Internet Explorer Microsoft Corporation 7.0.6000.16414

iertutil.dll Run time utility for IE Microsoft Corporation 7.0.6000.16825

IMAGEHLP.dll Windows NT Image Helper Microsoft Corporation 5.1.2600.2180

IMM32.DLL Windows XP IMM32

API Client DLL Microsoft Corporation 5.1.2600.2180

Iphlpapi.dll IP Helper API Microsoft Corporation 5.1.2600.2912

kernel32.dll Windows NT BASE

API Client DLL Microsoft Corporation 5.1.2600.3541

LameACM.acm Lame MP3 codec engine http://www.mp3dev.org/

LINKINFO.dll Windows Volume Tracking Microsoft Corporation 5.1.2600.2751


mbamext.dll Malwarebytes Anti-Malware Malwarebytes Corp.

mdnsNSP.dll Bonjour Namespace

Provider Apple Inc.





MPR.dll Multiple Provider Router DLL Microsoft Corporation 5.1.2600.2180

MPRAPI.dll Windows NT MP Router

Administration DLL Microsoft Corporation 5.1.2600.2180

MSACM32.dll Microsoft ACM Audio Filter Microsoft Corporation 5.1.2600.2180

MSASN1.dll ASN.1 Runtime APIs Microsoft Corporation 5.1.2600.2180

mscms.dll MS Color Matching Sys DLL Microsoft Corporation 5.1.2600.3396

MSCTF.dll MSCTF Server DLL Microsoft Corporation 5.1.2600.3319

msctfime.ime MS Text Frame Work

Service IME Microsoft Corporation 5.1.2600.2180

MSGINA.dll Win NT Logon GINA DLL Microsoft Corporation 5.1.2600.2180

msi.dll Windows Installer Microsoft Corporation 3.1.4000.4039

MSIMG32.dll GDIEXT Client DLL Microsoft Corporation 5.1.2600.2180


Windows Desktop Search

Namespace Manager Microsoft Corporation 6.0.6000.16431

MSVCP60.dll Microsoft C++ Runtime Lib Microsoft Corporation 6.2.3104.0

MSVCP80.dll Microsoft C++ Runtime Lib Microsoft Corporation 8.0.50727.3053

MSVCR80.dll Microsoft C Runtime Library Microsoft Corporation 8.0.50727.3053

msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.0.2600.2180

MSVFW32.dll MS Video for Windows DLL Microsoft Corporation 5.1.2600.2180

mswsock.dll MS Win Sockets 2.0

Serice Provider Microsoft Corporation 5.1.2600.3394

mydocs.dll My Documents Folder UI Microsoft Corporation 6.0.2900.2180

netapi32.dll Net Win32 API DLL Microsoft Corporation 5.1.2600.3462

netshell.dll Network Connections Shell Microsoft Corporation 5.1.2600.2180

NGSCM.DLL Next Generation Suite

Common Modules Nokia

Normaliz.dll Unicode Normalization DLL Microsoft Corporation 6.0.5441.0

ntdll.dll NT Layer DLL Microsoft Corporation 5.1.2600.3520

NTMARTA.DLL Win NT MARTA provider Microsoft Corporation 5.1.2600.2180

ntshrui.dll Shell extensions for sharing Microsoft Corporation 5.1.2600.2180

nvcpl.dll NVIDIA Display Properties

Extension NVIDIA Corporation

nview.dll NVIDIA nView Desktop &

Window Manager 111.75 NVIDIA Corp.

nvshell.dll NVIDIA Desktop

Explorer V111.75 NVIDIA Corporation

nvwddi.dll NVIDIA nView Display Driver

Interface Library V175.19 NVIDIA Corp

ODBC32.dll MS Data Access -

ODBC Driver Manager Microsoft Corporation 3.525.1117.0

odbcint.dll MS Data Access-

ODBC Resources Microsoft Corporation 3.525.1117.0

ole32.dll Microsoft OLE for Windows Microsoft Corporation 5.1.2600.2726

OLEACC.dll Active Accessibility

Core Component Microsoft Corporation 4.2.5406.0

oleaccrc.dll Active Accessibility

Resource DLL Microsoft Corporation 4.2.5406.0

oleaut32.dll Microsoft Corporation 5.1.2600.3266

OLEPRO32.DLL Microsoft Corporation 5.1.2600.2180

PDFShell.dll PDF Shell Extension Adobe Systems, Inc.

PhoneBrowser.dll Phone Browser Nokia


Nokia Phone Browser

language resources Nokia


Nokia Phone Browser

graphics resources Nokia


Win Portable Device

API Components Microsoft Corporation 5.2.5721.5145

PSAPI.DLL Process Status Helper Microsoft Corporation 5.1.2600.2180

quartz.dll DirectShow Runtime. Microsoft Corporation 6.5.2600.3497


rasadhlp.dll Remote Access AutoDial Hlpr Microsoft Corporation 5.1.2600.2938

RPCRT4.dll Remote Proc Call Runtime Microsoft Corporation 5.1.2600.3173

rsaenh.dll MS Enhanced Crypto Provider Microsoft Corporation 5.1.2600.2161

rtutils.dll Routing Utilities Microsoft Corporation 5.1.2600.2180

SAMLIB.dll SAM Library DLL Microsoft Corporation 5.1.2600.2180

Secur32.dll Securty Suport Providr Intrface Microsoft Corporation 5.1.2600.3518

SETUPAPI.dll Windows Setup API Microsoft Corporation 5.1.2600.2180

shdoclc.dll Shell Doc Obj & Cntrl Library Microsoft Corporation 6.0.2900.2180

shdocvw.dll Shell Doc Obj & Cntrl Library Microsoft Corporation 6.0.2900.3059

SHELL32.dll Windows Shell Common Dll Microsoft Corporation 6.0.2900.3402

SHELLW~1.DLL Window Washer

Shredding Shell Extension Webroot Software

shfolder.dll Shell Folder Svc Microsoft Corporation 6.0.2900.2180

shgina.dll Windows Shell User Logon Microsoft Corporation 6.0.2900.2180

shimgvw.dll Windows Pic and Fax Viewer Microsoft Corporation 6.0.2900.2180

SHLWAPI.dll Shell Light-weight Utility Lib Microsoft Corporation 6.0.2900.3059

shmedia.dll Media FileProperties

Extractor Shell Extension Microsoft Corporation 6.0.2900.2180



splitter.ax Haali Media Splitter

sti.dll Still Image Device client DLL Microsoft Corporation 5.1.2600.2180

SXS.DLL Fusion 2.5 Microsoft Corporation 5.1.2600.3019


URL.dll Internet Shortcut Shell

Extension DLL Microsoft Corporation 7.0.6000.16825

urlmon.dll OLE32 Extensions - Win32 Microsoft Corporation 7.0.6000.16825

USER32.dll Win XP USER API Client DLL Microsoft Corporation 5.1.2600.3099

USERENV.dll Userenv Microsoft Corporation 5.1.2600.2180

uTorrent.exe µTorrent BitTorrent, Inc.

uxtheme.dll Microsoft UxTheme Library Microsoft Corporation 6.0.2900.2180

VERSION.dll Version Check & File

Installation Libraries Microsoft Corporation 5.1.2600.2180

wiashext.dll Imaging Devices Shell Fldr UI Microsoft Corporation 5.1.2600.2180

WININET.dll Internet Extensions for Win32 Microsoft Corporation 7.0.6000.16827

WINMM.dll MCI API DLL Microsoft Corporation 5.1.2600.2180

winrnr.dll LDAP RnR Provider DLL Microsoft Corporation 5.1.2600.2180

WINSPOOL.DRV Windows Spooler Driver Microsoft Corporation 5.1.2600.2180

WINSTA.dll Winstation Library Microsoft Corporation 5.1.2600.2180

WINTRUST.dll MSTrust Verification APIs Microsoft Corporation 5.131.2600.2180

WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 5.1.2600.2180

WMASF.DLL Windows Media ASF DLL Microsoft Corporation 11.0.5721.5238

WMVCore.DLL Win Media Playback/

Authoring DLL Microsoft Corporation 11.0.5721.5251

wpdshext.dll Portable Devices Shell Ext. Microsoft Corporation 5.2.5721.5145

WS2_32.dll Win Socket 2.0 32-Bit DLL Microsoft Corporation 5.1.2600.2180

WS2HELP.dll Win Socket 2.0 Hlpr for WinNT Microsoft Corporation 5.1.2600.2180

wshtcpip.dll Windows Sockets Helper DLL Microsoft Corporation 5.1.2600.2180

WZSHLSTB.DLL WinZip Shell Ext. DLL WinZip Computing LP

xpsp2res.dll Service Pack 2 Messages Microsoft Corporation 5.1.2600.2180


Again, thanks in advance for any additional help you can provide.

Link to comment
Share on other sites

I am having a similar problem with the latest utorrent+wine on Ubuntu.

It happens quite often with the largest torrents.

Downloading is OK; the files are OK, but the seeding torrent stops seeding after some times; It gives me an "Error: not ready: plus an "IO error:21" in the logger. I can restart the torrent as much as I want. It will always seed for a few hours and then will stop again.

Did you by chance solve your problem?

Link to comment
Share on other sites

I put the files in order by first piece # and noted that utorrent does the recheck (after an IO error) in ascending order by piece #. I then noted that I got the IO error on the first file in sequence with priority "skip". I then selected all the skip files for downloading up to first piece # 5,000 and, sure enough, I got the IO error on the first skip file after piece # 5,000. So then I selected for downloading all the files in the torrent I had previously marked for skipping. The downloading then continued without any further IO errors. In the midst of the downloading, I then marked a lot of files back to skip (because the complete torrent is too big to fit in the unused space on my hard disk!) Even so, the downloading is continuing without any further IO errors.

I must admit I am a newbie in this torrent business and don't really understand why I had the problem in the first place or why the problem now appears to be solved!

Link to comment
Share on other sites

@mickey Well I'must say I'm relieved that your problem is fixed though I cannot say for certain whether I expected SKIP files to be the cause or only a trigger for the underlying cause. Could you give some more information on your setup so that others might get help with possible similar specs. I see the XP from the log. What kind of hard drives? And the built in controller.. not an add-in card correct?

Also to answer your previous question, like I mentioned 13 means INVALID_DATA (It's a windows error code), but pos: is a tag for the offset in BYTES for the file it's checking, or it may be offset from the beginning of the torrent. Count is the piecesize AFAIK. I presume line is the point in the code which triggered the fault, align and expected are unknown to me so.. no help.

@arettera 21 appears to be DEVICE_NOT_READY and as such are you... also skipping files? Or downloading to an external/networked drive?

Link to comment
Share on other sites

  • 3 weeks later...

To jewelisheaven: Re your latest comments,

Sorry for the delay in posting. I have been away for 2 weeks.

The hard drive I am using now is a Seagate SV35.2 Series, ST3320620AV, 320GB, 7200 RPM, 16MB Cache, IDE Ultra ATA100, 3.5" Internal Hard Drive. It is divided into two 160 Gig partitions and the torrent download is running and storing data in one of the partitions.

The above is a replacement for both the single original drive that came with the system and for an additional drive I installed later. The original drive was a Seagate Barracuda 7200.7, ST340014A, 40GB, 7200 RPM, 2MB Cache, IDE Ultra ATA100, 3.5" Internal Hard Drive. I replaced that drive with a Maxtor DiamondMax Plus 8 40GB ATA/133 internal hard drive which became the C drive (primary). I kept the Seagate as the D drive (secondary).

My computer has an Intel 845G chipset. The hard drive controller is a built-in Intel 882801DB Ultra ATA Storage Controller - 24CB. Both are original equipment that came with the computer.

I don't think my problem is hardware-related because the torrent download is still continuing (since my last post) with no further IO errors and I haven't had any storage-related errors with any software I have run since installing the current 320-Gig drive about 2 months ago.


I further noted that the "line: 1820" errors were all identical:

IO Error:13 line:1820 align:-99 pos:2617777430 count:131072 actual:-99

while the "line: 1787" errors all had different values for pos and count

I checked out your suggestion that pos may be the offset in bytes from the beginning of the torrent, which is 142 GB in size. I put the files in first piece order and then used Win Explorer file properties to get the exact size of each file. I added up the sizes until I found the file that contained byte # 2,617,777,430. (I used "size on disk" rather than "size", and in this regard I might have made the wrong choice.)

According to utorrent, the piece size is 8 MB and the block size is 16 KB (512 blocks per piece). Using the file size info, I calculated that the error occurred in the 17th file, a file of 125,693,952 bytes (15 and a fraction pieces). However, utorrent said that file contained 19 pieces rather than 16, so perhaps I had better go back and recalculate using "size" rather than "size on disk".

Once I do that, I will have to calculate the block# and piece# where the error occurred and then calculate the actual vs the stored checksum of the block/piece/file. To do that I will need a utility (which I don't have) that can open a file in hex and calculate checksums. I am not sure whether utorrent puts checksums at the end of each block, each piece, each file or maybe all three. If I find a bad checksum, then I will have solved the problem.

I don't know how P2P handles fractional pieces, but I feel sure that if a file contained pieces of size 8 MB and was just 1 byte bigger than an integer number of pieces, there would not be an extra 8 MB tacked onto the end of the file just for the sake of that 1 byte. I could believe, however that if the file were 1 byte bigger than an integer number of blocks of size 16 KB, that an extra block would be attached to the end of the file to hold that 1 extra byte. This would suggest that each block has a checksum.

But the process described above is A LOT OF WORK, and maybe not worth the bother since I am no longer having problems with the torrent.

However, if anyone can recommend a good utility for opening files in hex and calculating checksums, I might just be willing to put out all that effort just to get a better understanding of how torrents and P2P work.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...