Archived

This topic is now archived and is closed to further replies.

Ultima

µTorrent WebUI

Recommended Posts

in chrome 19.x, my labels in webui don't align well:

chromebuge.jpg

reseting the columns doesn't fix. is there any workaround?

hmm, even tried resetting webui settings to default, same behaviour.

anyone encounter same problem?

Share this post


Link to post
Share on other sites

Bug Report

I have notiiced an annoying bug with the rss filter settings. When modifying an existing filter and clicking apply all, of the check boxes are reset. I then have to recheck the check boxes and click apply again to make them stay. The bug has been there for quite a while.

I am using WebUI v0.387 and uTorrent server alpha 3.0 build 27079 (x64 version) I am also using Firefox 13 (x64 Linux).

Share this post


Link to post
Share on other sites
in chrome 19.x' date=' my labels in webui don't align well:

http://img824.imageshack.us/img824/2738/chromebuge.jpg

reseting the columns doesn't fix. is there any workaround?

hmm, even tried resetting webui settings to default, same behaviour.

anyone encounter same problem?

I've encountered the problem on my chrome browser too.

you need to reset the column arrangement. right click on the column, then click reset. done.

have a nice day! ;)

Share this post


Link to post
Share on other sites
Bug Report

I have notiiced an annoying bug with the rss filter settings. When modifying an existing filter and clicking apply all, of the check boxes are reset. I then have to recheck the check boxes and click apply again to make them stay. The bug has been there for quite a while.

I am using WebUI v0.387 and uTorrent server alpha 3.0 build 27079 (x64 version) I am also using Firefox 13 (x64 Linux).

At least you can get them to stay. Some boxes if you check them another box will be unchecked. Recheck that box and another will uncheck itself. Very annoying and makes RSS adjustments through webui useless.

@rocketman221: http://forum.utorrent.com/viewtopic.php … 88#p586888

Yes, the API design flaw has been there in the µTorrent backend for quite a while. I still don't consider this a bug in WebUI.

When will that be fixed.

Share this post


Link to post
Share on other sites

1. Is there anything in the interface which protection from the external monitor?

2. Compressing the data transfer can speed up the exchange with a large number of torrents.

3. Why is the main server is an older version of the package?

Share this post


Link to post
Share on other sites

There was this option to set the number of torrents I can view per page. I think it was set to 20 by default and inturn that would bring up the search function. Strangely from today all the torrents are been shown together as opposed to being pagewise and I can't seem to find that option to set number of torrents per page. Any help ?

Using WebUI v0.387 with uTorrent 2.0.4 Build 22150

Share this post


Link to post
Share on other sites

I know its not supported mate but I was asking about a functionality that was working till a while ago and it doesn't now without doing any updates. So was wondering if you or someone else can guide on the options to set number of torrents I can view per page in the WebUI.

Share this post


Link to post
Share on other sites

I have been looking for a way to get the download directory of a torrent not the default download dir, but the dir each individual torrents files are saved it. can the API do this for me?

like a IP:port/gui/?action=getsavedir ????

Share this post


Link to post
Share on other sites

I would really like to see a enhancement where label can be set at the same time as adding torrent, like this:

http://[iP]:[PORT]/gui/?action=add-url&s=[TORRENT URL]&label=[TORRENT LABEL]

Share this post


Link to post
Share on other sites

I have problems with russian names of folders to save torrents.

They are displayed as "1.jpg" in WebUI and I can't get list of directories from web api in my .Net application.

I receive message from DataContractJsonSerializer while trying to deserialize tne answer:

There was an error deserializing the object of type System.String. "1.jpg" contains invalid UTF8 bytes.

Share this post


Link to post
Share on other sites

i was getting this confused with utorrent remote can now finally access this via lan and also access from the web with some port forwarding. not have to wait ages to login and for server problems

theres only 1 thing that annoys me,

with utorrent remote in the added on and completed on headings it says 2 hrs ago or 1 day ago or 2 days ago etc nice and easy to read

with the web ui its listed as

2012-11-06-T16:00:20+10-30

anyway that can be changed?

Share this post


Link to post
Share on other sites

It would be so helpful to add a right click menu to change priority (enter number) rather then just up and down and the arrows.

clicking 200 times when you want to add a torrent top is not fun.

Maybe it's possible to make the queue up and down keyboard shortcut work with the web gui also? (I think it's ctrl+ shift+ arrow direction.

Share this post


Link to post
Share on other sites

I get also little error

TEXT : "{\"build\":25053,\"label\":.....\"messages\": [\n]\n}\n"
FILENAME : http://IP:port/gui/mootools.js
LINENUMBER : 1

its probably same character thing but how do i fix this? I tried upgrading newest version but that was total fail. I hope someone help me upgrade to newest version without loosing my current data.

Edit: I figured out where the problem is. I have there one broken RSS feed. How i delete that feed without damaging anything else?

Edit2: Now the feed is fixed and i get in again i found that all my .torrent files are just gone. How that can happen??? I surelly did not delete them. Had download all .torrent files again.

I downloaded latest utorrent server version and i saw that there is different webui. Is that newer or older? I like that v0.387 way more because that contain RSS downloader but default one dont. So I replaced it.

Share this post


Link to post
Share on other sites

I am using WebUI 0.387 and the "Trackers" tab functionality is missing in the "Detailed Info" bottom pane. Is there any way to enable/add this functionality? Thanks.

This functionality is quite necessary when using Private Trackers in which a person's account ID is often embedded into the tracker URL - the private tracker often returns messages to the user about their ratio/etc. via the "Trackers" tab.

Share this post


Link to post
Share on other sites

Hoping this is the right place to ask this question

I have WebUI v0.387 running on uTorrent 3.3 (build 28830) on Windows XP home SP3

I'm trying to access the UI from a Mac Running OSX 10.8.2 with Firefox 17.0.1

I can successfully log in, however, the interface only shows the torrent list, and nothing else (screenshot attached)

Is there a fix for this, or a configuration change I can make? I can only access the functions that would be accessible in just the torrent list too.

Screenshot (Ignore the blanked torrent names, that was a modification made after taking the screenshot)

11k9kib.png

Share this post


Link to post
Share on other sites
In the web UI:

Preferences -> WebUI -> Then you can turn on or off the available features.

As I said "I can only access the functions that would be accessible in just the torrent list"

I had this posted somewhere else, and they've given me the solution,

Click a torrent, and hit the Esc Key, gives a Reset UI Option Box which fixed it.

Share this post


Link to post
Share on other sites

Yep, the "Esc -> Reset UI" sets the Web UI Options to their defaults, which can also be accessed via the method I posted.

Both methods are solutions.

Share this post


Link to post
Share on other sites