Archived

This topic is now archived and is closed to further replies.

Ultima

µTorrent WebUI

Recommended Posts

I have FF 4 and when I connect from one PC to the one running uTorrent I get the webui and am constantly being prompted for my un and pw so I switched to IE9 which only prompts me once and the webui works great. One issue though when I click on the browse button to upload a torrent file the window opens up to my desktop but I want it to open to a different folder. How can this be done?

Thanks!

Share this post


Link to post
Share on other sites
I have FF 4 and when I connect from one PC to the one running uTorrent I get the webui and am constantly being prompted for my un and pw

Then it's something in your FF4 settings. I don't get that.

Share this post


Link to post
Share on other sites

Hi Ultima, is it possible to access your non-minified source code? I'm experiencing a problem with downloading torrent files through the rss interface using an private tracker, but the auto-downloader (rss favorites) is able to download the torrents. Its also possible for me to download torrents manually from a non-private tracker. I'd love to be able to do a litte debugging of my own to identify the problem :)

Share this post


Link to post
Share on other sites

Yeah i know it is, but I couldn't find the source anywhere :( But thanks a lot man :)

Edit: How do i then use the basic source code? :D I tried just adding the un-compressed source to webui.zip, but uTorrent wouldnt load it up.. And it still really sucks to modify the minified code :S

Share this post


Link to post
Share on other sites

The scroll bar seems having some gaps,both in torrents list and torrent file list.

My torrent list has about 100 torrents,and the torrent file list has about 1000 files.

Web UI v0.380 WIP 2011-03-19

google chrome 11.0.696.34 beta

utorrent server 3.0 25053

ubuntu 10.10

Share this post


Link to post
Share on other sites

I've been looking around the files in the zip, and I can't manage to find a way to turn the hash in the general tab clickable (as a magnet link). It's a feature that I would use a lot, since I have utorrent on a home server, and I use it to transfer downloaded files to my main computer... Is there anyway to do that?

Share this post


Link to post
Share on other sites

@DjDx: I'm not sure why that would be at all necessary, given the changes I already made to the most recent build.

v0.380 WIP (2011-03-19)

+ Feature: "Copy Magnet URI" menu item for torrent jobs

+ Feature: "Copy" menu item for torrent jobs, General, Peers, and Files tabs

@sa: It's unclear to me what you mean by the scrollbar having gaps.

Share this post


Link to post
Share on other sites
@sa: It's unclear to me what you mean by the scrollbar having gaps.

Some rows never show while scrolling up/down.

><:scroll window

scroll down: correct case


>1 2 3<4 5 6 7 8 9 10
1>2 3 4<5 6 7 8 9 10
1 2>3 4 5<6 7 8 9 10
1 2 3>4 5 6<7 8 9 10
1 2 3 4>5 6 7<8 9 10

scroll down: fail case


>1 2 3<4 5 6 7 8 9 10
1>2 3 4<5 6 7 8 9 10
1 2 3 4 5 6 7>8 9 10<

Share this post


Link to post
Share on other sites
@sa: It's unclear to me what you mean by the scrollbar having gaps.

Some rows never show while scrolling up/down.

><:scroll window

scroll down: correct case


>1 2 3<4 5 6 7 8 9 10
1>2 3 4<5 6 7 8 9 10
1 2>3 4 5<6 7 8 9 10
1 2 3>4 5 6<7 8 9 10
1 2 3 4>5 6 7<8 9 10

scroll down: fail case


>1 2 3<4 5 6 7 8 9 10
1>2 3 4<5 6 7 8 9 10
1 2 3 4 5 6 7>8 9 10<

I see this too in torrents with lots of files

Share this post


Link to post
Share on other sites

have a trouble while logging to webui:

after filling log\pass nothing going... only "Loading..."

but when logging from "guest" everything is fine

tried with ff 4, chrome, opera. ie

Share this post


Link to post
Share on other sites
I have FF 4 and when I connect from one PC to the one running uTorrent I get the webui and am constantly being prompted for my un and pw so I switched to IE9 which only prompts me once and the webui works great. One issue though when I click on the browse button to upload a torrent file the window opens up to my desktop but I want it to open to a different folder. How can this be done?

Thanks!

I changed my port and it does not constantly prompt me for the un/pw anymore.

Share this post


Link to post
Share on other sites

Good day.

There was a problem with the WebUI.

Why is that when you choose the Russian language in the interface WebUI, headings are displayed as:

b49d1cd1d428fffe181aeaf785f85a9f.png

All right? How to deal with it?

Share this post


Link to post
Share on other sites

Is there currently a way to change the base folder of a torrent, or at least see what it is? I am having to use the windows client to load up the torrent, see what the base folder everything is going into, and then rename my existing to that if i'm trying to join at a percentage.

It'd be nice to have the option to rename the base part of the torrent, or set exactly where on the filesystem the torrent files will go, instead of having to relocate the individual files.

Thanks! Loving this client.

Share this post


Link to post
Share on other sites

@pgjensen:

v0.380 WIP (2011-03-19)

+ Feature: Save As field in Detailed Info Pane (uTorrent 3.0 and newer only)

@Lemark: Damn. I guess the translation got broken somewhere along the way. Kind of a pain for me to fix though, as I don't speak/read/write Russian. I'll try seeing what I can do -- no guarantees though.

@sa: I'll try looking into it. If it's bothering you, then for the time being, you can set the listviews to use paging again by setting the max number of rows in Preferences > WebUI to some value greater than 0, and that'll be guaranteed to not have any unnatural skips (at the expense of ease-of-use).

Share this post


Link to post
Share on other sites
v0.380 WIP (2011-03-19)

+ Feature: Save As field in Detailed Info Pane (uTorrent 3.0 and newer only)

I see the Save As field, but it only lists where it's saved to. Is there no way to change it? When the torrent has its own base folder for everything, there's no way to change that.

Share this post


Link to post
Share on other sites

@Lemark: Damn. I guess the translation got broken somewhere along the way. Kind of a pain for me to fix though, as I don't speak/read/write Russian. I'll try seeing what I can do -- no guarantees though.

Hello.

I think the problem is not the correct placement of separators.

Thanks in advance if you can solve the problem.

Share this post


Link to post
Share on other sites

Lemark, я вышел из этой ситуации редактированием файла нашего языка - заменил проблемные участки простыми словами (приём, отдача)

Share this post


Link to post
Share on other sites

I have to give a big thanks to the maintainer of this gui. I thought utserver was awesome and fit my needs before, but all the work put into this and the availability of all those options that I did not know were enabled server-side really makes it seem more like I'm using full fledged client.

By the way, the best way I've found to bypass password prompt is to simply insert the UN/PW into the url like this:

http://[username]:[password]@[ip]:[port]/gui/

Share this post


Link to post
Share on other sites

So what's the future of this WebUI Ultima? Will you continue to maintain it with µTorrent Web and all in the works? I hope you do, it looks like I want it to and has always worked great.

Share this post


Link to post
Share on other sites

I'm doing this mostly independently of anything going on with µTorrent Web. Lack of time is always an issue for me, but nevertheless, I don't currently have any plans to drop maintenance. Things are still going on in my local copy of the code, albeit at a slowed pace due to Real Life™.

Share this post


Link to post
Share on other sites