Jump to content

µTorrent WebUI


Recommended Posts

Not happening. IE is retarded, and I don't care enough to work around its bugs.

What is it this time? It doesn't seem to request whatever favicon.ico I tell it to pick up because the icon sits behind HTTP authentication. Sniffing the traffic indicates that it tries to retrieve the icon without HTTP authentication (and from the wrong location), fails, and just decides to give up.

IE is notorious for having problems with favicon (search the Internets if you'd like), so I'm in no way surprised.

Hmm surprised! ;) I guess it's an IE9 issue with favicons behind auth as I believe the last time I saw it work with the WebUI was with IE8.. I think the standard is favicons sitting at the root of the server which posses a problem with the rest of the UI being behind /gui/ so that might explain the location issue at least..

Link to comment
Share on other sites

@gargamon: If the Directories option you mention is missing, then µTorrent Server doesn't support it. As far as network status goes, there is (to my knowledge) no such API.

@IAmThePat: Should be relative unless you have a leading slash. You'd probably be better off testing this than just taking my word for it though -- I don't have access to a Linux machine handy at the moment to verify.

@Zenshi: No -- not without backend support anyway.

@marklodge: Not a whole lot I can do about that. I've never used WebUI-Shell.

Link to comment
Share on other sites

Thanks for the reply Ultima, much appreciated.

Now I have a small problem when using the RSS Downloader...

It looks like I can't select "Filter matches original name instead of decoded name" and "Give download highest priority" at the same time, the radio buttons cancel each other if i select both and I can only select one or the other.

Any help would be appreciated, thanks.


Link to comment
Share on other sites

hello everyone. im having problem with new uTorrent 3.0 Build 25583 and WebUI 0.385. After updating it all to latest available 2 days ago.

The login became mad only on google chrome. The password box come over again and again. while firefox browser seems fine. tried rollback both utorrent client and webui. no luck. any suggestions?

Link to comment
Share on other sites

Hello, could you tell about proxy API in uTorrent?

Which value have the parameter "service".

Parameter "qos" it is "Quality of Service"? and what values it takes?

What else options have proxy?

"Proxy API" I mean the url in UI: http://username:userpassword@host:port/proxy?sid=<sid torrent>&file=<file number>&disposition=<???>&service=<???>&qos=<???>

Link to comment
Share on other sites

I'm having this issue with WebUI 0.382 and 0.385 when I try to login:


It seems something related to RSS. Hope the screens helps understanding the issue.

I had the same issue. It was indeed due to a new RSS feed had added with an embedded control character.

The gui was effectively hung up so I couldn't fix it that way. I couldn't find anything I could do to the server and hand editing the rss.dat file was unsuccessful.

So to repair the damage without having to reenter all the flters and paths again I just copied the rss.dat to a windows utorrent directory(in my case running under wine), deleted the bad feed via utorrent, and copied the repaired rss.dat back to the utserver directory.

I hope it is as easy for you.

Link to comment
Share on other sites

  • 2 weeks later...

unless im doing something wrong this version of webui doesnt work with utserver.conf directory settings. if i use this version it will default the directories, but if i switch back to the one that comes with utserver it reads the directory paths i put into the config file.

Edit: i was doing something wrong :)

Link to comment
Share on other sites

I finally think I discovered the reason behind a bug I have been running into since RSS support was added to the webui.

There was one URL that got cut off in the "Feed URL:" field when I edditted a Feed URL. It turns out the culprit is the pipe symbol. The site (TVTorrents) uses the | as a delimiter in the include and exclude fields of the URL. However, the | is also a field separator in the rss.dat config file. So the following line:


will show up in the edit box as:


even though the length of the entire line should be known, it looks like it's not checked:

i1e3:url204:TVTorrents Exclude|http://www.tvtorrents.com/mytaggedRSS?digest=****************************************&hash=****************************************&exclude=(720p|Season.*Complete|NUKED)&interval=2+week

In this example, the name of the RSS feed + separator + URL is 204 characters

Is this something that can be checked?



Link to comment
Share on other sites

At the very least, it's clear where in the code this is causing problems, but to get to the root cause, I must ask: from where are these URLs being generated? A "|" character is not technically valid in a URL -- it's supposed to be percent-encoded.

I could sorta put a hack in to fix this, but it still wouldn't be guaranteed to always work for all feeds. µTorrent accepts feed URLs without the "name|" portion of the "name|url" format as well, so if the URL itself contains a pipe character, it would still potentially fail anyway. I could start adding more heuristics to determine if the thing is supposed to be a standalone "unnamed" URL, but then if someone puts "http://somestupidfeedname|http://real.feed.url/blah.rss", it still would fail. We could then blame whomever (poorly-)constructed the "name|url" string as the RSS feed, but then we could say the same about the URL you're having problems with (though your example is certainly relatively sane).

It all comes down to 2 things:

  1. µTorrent shouldn't even be using "name|url" to specify feeds in the first place. Both parameters should be separate.
  2. Feed URLs should always be properly percent-encoded.

Anywho, that aside, I'll see about fixing things for your particular "name|url" string. Standalone URLs with a "|" character would still fail, but that's probably less likely an edge case to occur.

Link to comment
Share on other sites

I can't use "File Priority" context menu through Web UI to mark files which should not be downloaded - it appears to be inactive


I'm using uTorrent 2.2.1 build 25130for Windows with Web UI v0.385 from 2011-09-03 - downloaded today from first post but browser title shows v0.370

I tried through IE 8 and Chrome 14

Link to comment
Share on other sites

Hi Ultima, Thanks for all help you have given to me so far. Got another request if you have time.

I need to remove the HDD size report from the add torrent box as im using the multi-user shell and the quota feature but the HDD size is a bit confusing for people as it reports the entire hdd instead of their quota.

Do you know which bit I need to edit to disable it?

Thanks in Advance.

Link to comment
Share on other sites

@Aramaki: Then you didn't install WebUI correctly. And no, it wasn't always impossible to use the menu. Browsers simply changed they way they interpreted some bits of JavaScript, so what did previously work stopped working on modern browsers. You can still double-click files to change their priorities in v0.370, but don't expect to receive support for such old versions.

@TheSPAWN: Look for the string ' free] ' in webui.js. You should be able to figure it out from there.

Link to comment
Share on other sites


I have a problem with my WebUI. It only shows the torrent list:......................................................................................

I does not show the left and bottom panel. This turned my WebUI to almost useless.

Please help me fix it. I've already tried downloading a new WebUI and potting it in the %appdata%\uTorrent, but it didn't help.


See red area on the screenshot!:


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...