Jump to content

µTorrent WebUI


Recommended Posts

  • 2 weeks later...

I have problem with webui. The download rate limiting is not working. Any idea how to fix this problem?


Global Download Rate Limiting is set to x value.

Apply rate limit to UTp connections is enabled.

Utorrent still working on full speed.

Another problem is with private trackers and cookies:

which is working:

adding torrent via url like this:


Which not:

1,Add Torrent via URL, manually enter cookie:


1, via the cookie manager. I tried to set cookie based on the working URL (nick=mynick;pass=mypass), without success:


Is this correct? Because not working. I tried to make cookie :COOKIE:nick=mynick;pass=mypass, not working. I have no more idea.

Link to comment
Share on other sites

Rate Limiting:

If the rate limits are being saved between sessions (reload WebUI), then there's not a whole lot I can do from the WebUI side of things. And really, what do you mean by "not working" anyway? In what way is it not working?


Hah. Inconsistent URI component encoding. To be fair, I've never really used any sites that require cookies, so it's kinda hard for me to test these things carefully. But enough with the excuses :P


Download this file, rename it to webui.js.gz, replace the one inside webui.zip, and try again.

Link to comment
Share on other sites


I replaced the file, but it is still not working:


(URL: http://xy/torrents.php?action=download&id=1002452 + I click on detect cookie, which loads: "nick=xy;pass=e24bb2c5eb3a490da ")

When I add new torrent via URL, like this:


This is working, and torrent starts downloading.

Is there any way to debug this bug? :/

I am here to help you.

Link to comment
Share on other sites

Is there a way to change the font / font size in WebUI? The default WebUI had a smaller font, and for me was easier to view. These builds change the font to a much larger font size. Is this expected or necessary for some reason?

Link to comment
Share on other sites


connections made from browser to WEB UI never closed properly, *it's even keep labeled as "established"

like this..
*25 my local port at server listening WEBUI

and it will multiply from time to time, i dont knw why..

But i heard it's been long time since last fix, so .. will it to get fixed or ..?

*thank you :P

Link to comment
Share on other sites

@adriankoooo: Clear your browser cache, and try redownloading WebUI from the first post too while you're at it. The fix made it such that adding by manually inserting :COOKIE: in the URL, and adding with the cookie field populated generate the same exact request to the WebUI backend, so if one works, there's no reason the other wouldn't (or conversely, if one seriously doesn't work, then there's no reason the other should work either).

@mfrazzz: Uncheck Preferences > Advanced > Web UI > Use system fonts. If you're seeing this on Chrom(e|ium) on Linux, then the browser probably still don't have proper support for basic system fonts as defined in the CSS2 font shorthand spec. Read: Not My Fault the Browser is Broken™ :)

@aa_gun: I have no idea what "last fix" you're talking about. And to be honest, I'm not really sure how connection close issues are even WebUI's fault. What WebUI does as far as connections goes isn't exactly sophisticated: it sends a request, reads the response, then sleeps (letting the request object go out of scope, which should be picked up by the garbage collector). If your browser never closes the connection, then maybe the browser holds several connections open for reuse since connection setup/teardown can be relatively costly (and so this should not be any of your concern). If it never closes any connection, and only ever opens more and more connections, then that's a bug in your browser -- not WebUI. I've never observed continuously-opened-but-never-closed connections with any browser I've tested, and all browsers have a per-server connection limit to prevent hammering anyway.

Link to comment
Share on other sites


I've been using utorrent 3.0.0 and webui 0.385 for a while now, with some issues with it not adding torrents on some occasions. Right now it won't load any torrents from my monitored folder or from using transdroid on android phone but used to work. I've tried updating utorrent to 3.1.3 and webui to 0.387 but its still the same. Sometimes it will work adding a torrent using webui locally and adding a downloaded torrent, but i can't get it to work with my monitored folder or transdroid.

Link to comment
Share on other sites

In version 0.387 and Chrome 19 I'm using a "http://Username:Password@YourIP:UTport/gui/" bookmark to access WebUI but it still constantly asks me for a username and password. It wasn't doing this before I last updated uTorrent and WebUI, but I'm not sure what version I was using. I verified the username and password in the bookmark are correct, anything else I can do?

Link to comment
Share on other sites

@chris_h16: Monitored folders and Transdroid have nothing to with this WebUI. Nothing I do in this UI can change the way they work.

Ok forget about transdroid.

In webui there is the option to monitor a folder and load torrents from it automatically. It used to work but doesn't any more

Link to comment
Share on other sites

I come from China, used Chinese characters.

when I use webui to adding .torrent file, there is a problem

For example:

LOVE Chinese character expression = 爱

Add subpath when I entered "爱"


However, in windows explorer, garbled


Any other Chinese characters subpath will have problems

Please tell me, how can I do, in addition to waiting for the new version of the WEBUI



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...