Jump to content

µTorrent WebUI


Recommended Posts


Download this file, rename it as webui.js.gz, and replace the corresponding file at the root of webui.zip. Not as much testing as I should have (I had to step out for a few hours), but this is just a quick fix :P

On the plus side, I also made it so that the "Checked" status also shows the checked percentage. That is, instead of showing "Checked ??%", it shows "Checked 32.7%" or whatever now.

Link to comment
Share on other sites

First of all I have to thank the authors of this awesome webinterface, I've been using this for ages now so that should be said.

Now I have some questions regarding this webinterface.

I have been working on a server console (as I call it, more like a portal of several webinterfaces tide together in one interface, see here for a feel; http://tinyurl.com/yl8wcku ).

I've been running into this stupid IE bug I can't seem to figure out maybe any of you have some ideas for me. First things first this problem is caused by the way I have setup the server console, everything that I link from is loaded into an iframe, this means the same for utorrent. It works ok when I do not load the webui in an iframe.

In IE (whatever version, does not mather) I had this problem that the width of some elements are not set correct (possibly due to the fact that the iframe takes up a bit of width in IE, I have set frameborder to 0 which helps a bit although not really valid xhtml). This results in the right upper pane (the ones which lists the torrents) being pushed below the left upper pane (the filter pane with downloading etc).

At first I had this constantly (so upon first entering the page in IE), after adding the frameborder=0 I have it only when I select a torrent in the list. I'm totally clueless how to get this fixed. It can be some JS interacting with eachother (iframe being dynamically resized by my JS code) which bugs it up, not sure.

Any insides or help is greatly appreciated as I'm clueless, just to be clear this is an IE only bug only occuring when utorrent webui is loaded in an iframe.

If someone is interested in the code (which might also help you figure it out) I'm willing to share but it's far from being something generic.

This is however easily reproducable by just making a simple iframe and loading the webui in there, using any IE.

Link to comment
Share on other sites

Don't know what to say. Firstly, without frameborder=0, IE seems to behave inconsistently. Sometimes, it has the problem you described, but after a few refreshes, it has no issues whatsoever. Secondly, with frameborder=0, IE never seems to exhibit the problem, ever -- even if I click a torrent or do anything in the UI.

As far as I can tell, this is just IE being made of fail.

Link to comment
Share on other sites

Thanks Ultima for the reply.

I know IE sucks when it comes to these sorta specifics.

The refresh you suggest does work, sometimes ctrl+f5 works better (neglecting cache).

I do not really mind myself cause I'm a firefox user but nevertheless would like to get it fixed for my stuck to IE room mate.

Isn't there somewhere I could add an IE exception in webui to leave a bit of margin for this problem? :) Yeah I know, dirty hack... And you wouldn't want that in a release for the public but I'm not against running my own build for this.

Link to comment
Share on other sites

  • 4 weeks later...

Ho ho ho!

v0.362 WIP (2009-12-24)

+ Feature: #55 (Progress bar)

~ Change: Don't toggle toolbar if F4 is pressed with Ctrl

~ Change: No longer has to be installed at root of webui.zip

~ Change: Show torrent job checking percentage progress

* Fix: Divider sizes not saved in Opera

* Fix: Esc not resetting interface

* Fix: Guest page attempting to update non-existent speed graph

* Fix: Incorrect status parsing in some edge cases

* Fix: IPv6 support

* Fix: Logger tab showing error about an invalid XML expression

* Fix: Redirecting on port change not working in some situations

Find the "present" in the first post.

Link to comment
Share on other sites

I wasn't really scheduling this release for today or anything. Everything just came together this way -- I got some time to work on it, and by the time I finished what I'd mainly set out to finish, it was already... today :P Anyhow, this release is just a bit of polishing and bugfixing. Not really worthy of "present" status, but who's counting? ;D

Link to comment
Share on other sites

First of all merry christmas and thanks for the new release!

I just updated and ran into a little snag.

I run utorrent thru apache with the Proxypass method described on these forums.

It worked until this new version. It hangs on the loading animation and firebug tells me that there are some 404 requests being done.

I run webui on /utorrent/

The 404 requests are done on /ut/

Is there some JS interacting with the URL and doing some ajax POSTing/GETing or something?

these are the ones that result in 404;




Link to comment
Share on other sites

Oh, er... I don't have any web server installed for me to test URL rewriting, so... I guess you'll need to be the guinea pig ;D


Can you grab this, rename it to webui.js.gz, replace it in webui.zip, and see how it works out?

Edit: As an aside, I do believe .torrent file uploading may potentially be broken when using rewritten URLs (and if so, may have been for a while).


Can you grab this file, rename it to main.js.gz, replace it in webui.zip, and see how it works out?

Even if .torrent file uploading isn't broken for rewritten URLs, it is broken when one takes advantage of this change:

~ Change: No longer has to be installed at root of webui.zip

This updated main.js.gz should fix it, but I can't tell if it'd break URL rewriting (being unable to test), so it would definitely be nice if someone who does use rewriting could try it out for me :)

Link to comment
Share on other sites

Hey ultima,

thanks for the quick response. I hope i can test for you late tonight (gmt+1). I'd gladly be your guineau pig to help nip this in the butt.

I used to be able to upload torrents, i Will test that as well. I am not gonna be using the new change which makes it possible to have webui sitting in subdirs of the zip but if you want i can test that also.

Typing all of this on my (i)phone so excuse the typo's


I was just testing out the new fixes for url rewriting. The 404 requests are now fixed but basic authentication is fired for each request (as it seems, so for each image etc.).

I can login if I put in the right credentials in the first login popup and then cancel the rest.

Not sure by what that's caused.

Link to comment
Share on other sites

Is it possible to create an option so that the WebUI's column locations and disabled/enabled column names are consistent between both the WebUI & the running version residing on my Media Server? If I modify/move/enable/disable one of the columns, the other one gets changed also.


Link to comment
Share on other sites

From what I can tell, it's not possible.

@joz: That I can't reproduce or explain by any changes to my code. It must be something else. Try clearing your browser cache or something. I've seen similar behavior when trying to test MiniUI using the Android emulator, but it went away on its own after upgrading the OS.

Link to comment
Share on other sites

Since it's not possible to for the column names of the webui to be consistent with uTorrent, then would it be possible to make it so that the default (1st run) of the webui will have the same positioning of the columns names and with the same ones enabled/disabled as the default (1st run) of uTorrent?

Link to comment
Share on other sites

Having WebUI with the same columns activated & in the same position as uTorrent's default 1st run would be great as the default WebUI position of the columns are a bit confusing to new users who's use to seeing them in the uTorrent positions & using uTorrent's descriptions of the columns. On a previous old version of WebUI, I had great difficulty moving the columns names around.

Link to comment
Share on other sites

I was just testing this again with apache proxypass and still having the same basic authenticication issue.

I have not changed anything regarding apache configuration so it cannot be that.

I digged in a little further and saw that the request token.html is now done on /gui (none existent) instead of /utorrent.

Might that be the cause of the constent login prompts? There has to be some cause and since I did not change anything on this aspect except for the new webui release (the one before that works beatifully, still have that one backed up (and also in production system) just in case) I believe it has to be something in webui.

To be clear this problem only appears when running it thru apache not when directly accessing webui.

I also tried adding /gui/ as a proxypass but that did not resolve the 404 for some reason.

This is a bit weird and complicated to me.

Don't get me wrong here I really appreciate the effort you have put into all of this, it's really a handy tool but I'd like to get it fixed

Link to comment
Share on other sites

Here's an interesting one for you. Previously I had been using v0.310, running through stunnel and using the firefox extension which allows you to use https. Utorrent is set to only allow connections on localhost so the only access to the the webui remotely is via stunnel i.e. SSL.

When using the latest WIP v0.362 of the WebUI everything works fine except the Preferences page appears blank except for the left menu. Back in the early days of the firefox extension I modified it to copy the whole URL including the "https" instead of it attempting to use the normal http thereby adding supporting SSL. I wonder if something similar is happening with the latest WebUI?

Note that this only happens when connecting remotely via stunnel, if I am local on the machine the WebUI works just fine (but I'm not use https).

The fix for this might be very simple (it was for the firefox extension) so I'm just letting you know.

Cheers, and great work on WebUI!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...