Jump to content

µTorrent 1.8.3 released


Firon

Recommended Posts

Come one, it's only minor fixes or fixes relative to crashes. A lot of devs of freewares don't provide detailed changelog, and often you can read 'many bugfixes' without more details.

Mozilla released 3 RC for Firefox 3.5 in 2 weeks and the changelog wasn't displayed on the main website.

Link to comment
Share on other sites

  • Replies 135
  • Created
  • Last Reply

Top Posters In This Topic

Logically thinking and speaking from 15728 to 15772, it is a difference of 44 (whatever: points, numbers).

In every normal guys mind , it means, there were about 44 changes (for better or for worse).

Now you guys wanna tell me, we made only 1 (ONE) change.

Every half year an upgrade should be about enough.

Link to comment
Share on other sites

--- 2009-04-15: Version 1.8.2 (build 15167)

- Change: Scam site warning in installer

- Change: Cancel in installer now aborts the process

--- 2009-02-03: Version 1.8.2 (build 14458)

And you're telling me there were 709 user-facing changes here? No. The build numbers do not reflect the number of user-facing changes. It reflects the number of SVN checkins made, and because this project developed by several people, checkins have to be made often to keep everyone's copy of the source in sync, even if a single changelog entry worthy change hasn't yet been fully made. The repository is shared between all the various versions of µTorrent, whether 1.8.x and 1.9.x, or Windows and Mac builds, so just because a checkin is made doesn't mean it's for v1.8.3 Windows only.

Link to comment
Share on other sites

After upgrading to 1.8.3 I have the feeling that something is not working exactly as it should:

30sec.jpg

5sec.jpg

1sec.jpg

This happened few times actually... the problems with utilizing whole available seem to appear in seeding mode only.

The speed settings are pretty much defaults for my upload (2Mbit), except one thing - I'm using unlimited global upload rate (zero) with automatic turned off (just in case: yes, my ISP does the queuing thank you, and yes, I have a good reason to keep my upload unlimited instead restrain it"properly" at ca 180kB/s)

Anyway, I didn't have such problems at 1.8.2.

Any ideas?

Link to comment
Share on other sites

kurahashi, it's possibly caused or at least aggravated by having over 100 peer connections per torrent. Mix in some uTP and/or Teredo/IPv6 connections...and uploads to some peers WILL stall, causing uTorrent to reevaluate your upload as slower than it really is.

Link to comment
Share on other sites

Having 100 or more connections per torrent didn't prevent 1.8.2 from working correctly (BTW I'm not connected through any router, only direct fast ethernet uplink)

And when I download (not only seed as in the example above) the number of connections is more or less the same, yet somehow it doesn't choke upload then. You can see part of the correct download/upload graph here http://h.imagehost.org/view/0239/30sec on the left. Actually upload wavers twice there (when first two files finished downloading and went into seeding mode), still it come back correctly, but when third file also finished download and there was nothing more to do except seeding them - problems with upload began.

Link to comment
Share on other sites

kurahashi said:

"Actually upload wavers twice there (when first two files finished downloading and went into seeding mode), still it come back correctly, but when third file also finished download and there was nothing more to do except seeding them - problems with upload began."

This is EXACTLY what I mean by uTP connections stalling. In that case, it almost seems like uTorrent was still trying to estimate the upload capacity based on dying uTP connections.

Link to comment
Share on other sites

I was keeping an eye on uTorrent yesterday, and now I'm almost 100% sure: it's a bug related to uTP.

When in seeding mode (let me remind, I'm using unlimited upload rate, no auto) with no active uTP connection everything works just fine...

...but when uTP connection becomes active (upload begins) then suddenly all other (TCP ones) are capped to the actual speed of that uTP connection.

So if the uTP connection transfer manages to get 2kB/s only, all others are getting 2kB/s max (per TCP connection) - no wonder my upload can't be used fully then.

If uTP connection dies (or become inactive) then limits on TCP connections are lifted and transfer is ok again.

Link to comment
Share on other sites

Thanks for the best torrent client ever.

I'm using Zonealarm free version 8.0.298.000 with TrueVector security for the stealth reason but found a compatibility problem with µTorrent 1.8.3 build 15728 and the TrueVector engine on my system (Windows XP sp3) which leads to the truevector service crashes. Do you now why and are there anything I can do to workaround? This problem did not exist within the previous version of µTorrent

Thanks in advance

Frogmaster

Well - my problem is solved. It's seems something did go wrong during the upgrade. After an uninstall, download and a clean install of µTorrent 1.8.3, everything is just fine - thanks again for making µTorrent ;)

Link to comment
Share on other sites

Changelog posted. Don't be so bitchy about it, guys. When Firon disappears for a week, it means he's offline. It also means no changelog because I have to post the build as quickly as possible and run off.

The SVN repository has a lot of projects on it, so those 44 changes were largely not for win ut.

Just fyi, 1.8.3 is on the updater, but it's currently a staggered rollout so it's not tons of people getting the update at once (and hammering the servers). The rollout was a bit slowed due to my absence.

Link to comment
Share on other sites

-- 2009-06-24: Version 1.8.3 (build 15772)

- Change: detect nvlsp too (previously it only detected nvappfilter). This means it warns about it and also adjusts the processor affinity like for nvappfilter. This should reduce the crash frequency.

- Fix: more installer problems on Vista

The date is wrong (06-24)

Link to comment
Share on other sites

Always I see in the Tracker tab, in a udp:// url the message "invalid URL".

I have the Preferences > Advanced > bt.transp_disposition with 15 to enable uTP protocol too.

The url I have for example, is udp://tracker.openbittorrent.com:80/announce. What could be the problem?

Greetings

Link to comment
Share on other sites

kurahashi said, "when uTP connection becomes active (upload begins) then suddenly all other (TCP ones) are capped to the actual speed of that uTP connection."

Try turning off bt.tcp_rate_control

...dang, I guess that setting is only in the v1.9 alpha. :(

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...