Jump to content

Linux: running uTorrent without X


Recommended Posts

System info

Virtualbox VM: Debian 5.0 GNU/Linux / kernel - 2.6.26-2-686.

+ wine 1.0.1 (not compiled)

+ uTorrent 1.8.3 - settings.dat copied from host machine.

I'm runnig uTorrent, wine without X now. It works for 75%. Wine will complain about not being able draw the gui, but it does not hamper functionality much because the webui still works. You can upload torrents, manage them, and change the majority uTorrent's settings trough Firefox.

However, I have one main issue: uTorrent will not automatically load torrents from a given directory xyz'.

The directories I tried uTorrent to scan are:



C:\Program Files\uTorrent\scan

Not running X or a desktop for that matter, saves me 200 mb memory. Which is awesome (!). In general I'm really impressed that uTorrent still works. I'd really appreciate your thoughts, because I suspects its a trivial thing.

Link to comment
Share on other sites

  • 2 weeks later...

Thanks for the replies. X is crucial for autoload to work. After having setup X a couple of times on the VM, I noticed that I can startup X without a real window-manager, such as gnome or KDE on top of it.

So I decided to test:

A - wine + uTorrent


B - xorg + wine + uTorrent

A, does not allow me to auto load torrents, with B it does work. Apparently, x and wine together allow uTorrent to read the /home/burger/scan folder.

More suggestions?

@ DreadWingKnight: Compiled wine 1.1.24, but still does not work though.

Link to comment
Share on other sites

Perhaps Wine has somehow implemented whatever API µTorrent is using, with a dependency on X. I don't see any reason why periodic scanning for folders should be any different from any other feature with regards to X dependency unless it's a Wine issue.

Link to comment
Share on other sites

  • 1 month later...

I'am also interested in running uTorrent on linux (currently ubuntu 8.04 LTS server) in wine, but without X.

Because I don't want set up X and a lots of other dependecies, I decided to compile wine myself.

The following things are left out from wine:

--without-xcomposite --without-xcursor --without-xinerama --without-xinput --without-xml --without-xrandr --without-xrender --without-xshape --without-xshm --without-xslt --without-xxf86vm --without-x --without-alsa --without-audioio --without-capi --without-cms --without-coreaudio --without-esd --without-jack --without-nas --without-oss --without-ldap --without-libgsm

Other dependencies are fulfilled.

Configure, make dep && make, and make install are done without any error.

winecfg cannot be run, because there is no X installed, neighter compiled in to wine.

I installed utorrent latest stable 1.8.3 with webui and set up for linux usage on a windows machine, then moved all the stuff to the linux machine.

After that with "wine uTorrent.exe" I am able to start utorrent without X, the webui works like it should, but I have a big problem: the 682MB memory footprint.

After I start uTorrent in wine, the following messages appearing in the console:

root@ubuntest:~/.wine/drive_c/Program Files/uTorrent# wine uTorrent.exe

fixme:heap:HeapSetInformation 0x110000 0 0x479e3c 4

Application tried to create a window, but no driver could be loaded.

The X11 driver is missing. Check your build!

Application tried to create a window, but no driver could be loaded.

The X11 driver is missing. Check your build!

err:ole:apartment_createwindowifneeded CreateWindow failed with error 126

fixme:heap:HeapSetInformation 0x5d0000 0 0x479e3c 4

fixme:winsock:WS_setsockopt Unknown level: 0x00000029

fixme:winsock:WS_setsockopt Unknown level: 0x00000029

fixme:winsock:WS_setsockopt Unknown level: 0x00000029

fixme:dbghelp:MiniDumpWriteDump NIY MiniDumpScanMemory

wine: Unhandled page fault on write access to 0x00000000 at address 0x43d0d6 (thread 0009), starting debugger...

err:seh:start_debugger Couldn't start debugger ("winedbg --auto 8 408") (31)

Read the Wine Developers Guide on how to set up winedbg or another debugger

fixme:heap:RtlCompactHeap (0x5d0000, 0x0) stub

After this, 3 utorrent.exe instance came up, and both of them had a 682MB memory footprint. The overall memory footprint of the 3 utorrent instance was 682MB each and every time I started them. The CPU is almost idle, so that part is not involved.

So what could be the cause of this? Maybe I have to compile in the X parts even if it will not open any windows ever?

Any suggestions?


Link to comment
Share on other sites

I'am compiled wine from source 1.1.27

Should I try some other version?

Anyway, it is possible to set up wine from apt source, or deb, but without it's depencies (especially without X)?



I tried two more things:

1. I reinstalled ubuntu 8.04 LTS, then installed wine 1.1.27 from the offical deb source with all of it's dependencies.

It also starts, but the huge memory footprint occures again.

2. Because my testenvironment is on a virtual machine, I tried to reduce the amount of memory from 1024MB to 200MB, then see what happens if I start utorrent in wine.

The result is that utorrent starts as before, it eats up all memory, but seems there is no other problem.



gotya :-D

I managed to run utorrent 1.8.3 latest stable with wine (1.1.27), but without any graphical interface in a total system memory footprint of 38MB :-D

It turns out that wine causes the tremedous memory allocation, but with Xvfb (a virtual frambuffer device) it is possible to show wine a fake display where it "can draw". With this trick all the error messages and the tremedous memory consumption is gone.

Further info:


I will going to test this on a live system for 1-2 week, and if it turns out to be good, I will report back with a detailed guide how to do this.


Link to comment
Share on other sites

Ultima: thank you, the link was very helpful.

Now I'am working on a simple init script for utorrent to start, stop, maybe restart it.

I think the point is that we are able to run utorrent with working webgui, without any running X server or any desktop manager, and with a very low memory footprint or system resources.

On my test environment, I set up an Ubuntu 8.04 LTS server, set up wine with all of its depencies and Xvfb, SSH and ftp server, and followed the utorrent install guide for linux here.

This system consumes 655MB on hard drive, and has a 38MB of total memory footprint, and almost none CPU usage.

Actually, my rtorrent system with a webgui consumes more :-)

I will do a one or two week regression test period to see it acutally works with even heavy load. After that, I wil report back with the results.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...