Jump to content

Cannot establish new tcp/ip connections with µtorrent running


Recommended Posts


this isn't covered by the FAQ and even though my forum search has come up with a number of similar errors, none quite match the phenomena I'm observing.

I began downloading torrents with Azureus quite a while back. Everything was dandy at first (except for the crazy mem usage--130MB for a p2p client? Thank you, Java), but at some point I noticed that I couldn't browse the web and do certain other things (we'll get to that in a moment) with Azureus running. Reinstalling Az/Java didn't help at all, so I blamed it on shitty netcode in Java and looked around for a better torrent client.

We all know what I found ;P

So I love µtorrent so much that I switched to US Intl keyboard just to type the mu ;P It's great and slim and generally achieved wonderful download speeds. It also didn't block me like Azureus did--at first.

I started using the latest stable (1.4) and out of sheer curiosity switched to the beta after a while. Everything was going fine. I'd been using build 406 of the beta until very recently with not a single problem.

Then the same problem I had with Azureus months ago resurfaced. I'll go into detail now.

What happens is this: while µtorrent is running, my PC seems to be unable to establish new tcp/ip connections. Existing ones can be used without a problem. Example: if I download from an FTP and start µtorrent while that download is already running, it continues without problems. If I'm already logged into GMail's webmail interface and then start µtorrent, I can continue to use gmail (god bless their ajax magic--which, come to think of it, should have to open a new connection for each interaction... strange. Anyway, GMail keeps working). If I'm already connected to IRC, I can keep chatting, and so on. But if I start µtorrent FIRST and then try to do any of these things--connect to IRC, load any webpage, connect to that ftp server...--nothing happens. Firefox shows me that it's "Connecting to <whatever>", but nothing happens. IRC and FTP also time out.

This has started happening all of a sudden, as far as I can tell. I did not change any setting in µtorrent, nor did I install a new version or anything like that. I didn't even start a new torrent between the time when everything worked fine still and everything suddenly stopped working. It's constantly like this right now: whenever I open µtorrent, I can make no new tcp/ip connections. It's been like this for about a day, and needless to say this isn't a happy situation ;)

My first step was to go back to the stable release. Same observation. Then I downloaded the latest build of the beta. Still the same thing. Then I searched these forums a bit. The TCPIP.sys patch does not apply to me--I don't have SP2. I tried messing around with the halfopen number in the advanced settings, to no effect. I turned off DHT--again, no difference. I'm also very certain it's not a maxed out bandwidth. I've been using the same settings all the time (up capped at 6k, down uncapped), and I've had times with a maxed downstream (that'll be 45k in my case) where I could still browse no problem (just a little slow, of course). This time, though, I wasn't downloading any particularly fast torrent. I was at about 5 up / 20-30 down, but I can observe the same effect with a freshly started µtorrent at 0/0.

I have an Athlon 2100+ with 1 gig of ram and a shitty German DSL connection that does about 9 up / 45 down. I'm using Windows XP Professional with SP1.

Any help is much appreciated!

Link to comment
Share on other sites

I saw no pressing reason to upgrade, and if given the choice of installing lots of MS updates on my OS or not, I usually go for not.

Do you think SP1 could have anything to do with my problem?

(don't worry about the security things in SP2; I'm also a linux user with a dual boot on this PC, and I've pretty much made sure my Windows is safe; I have also run a spyware check again, just to be sure, and my regular virus check also turned up nothing)

[edit]: also, it's been running just fine for at least two months on SP1 now. I doubt it's got something to do with that.

Link to comment
Share on other sites

Hmm, I'm connected to a wireless router over a Siemens Gigaset USB 11 Adapter. This setup has not changed, and that's the thing I don't get: why would everything run fine with just this setup for about two months and then suddenly it'd stop working? Doesn't seem to make sense.

Link to comment
Share on other sites

I'm having the same problem. uTorrent was working great, for about a month. Then all of a sudden I can't use it and surf the web at the same time. Now all of a sudden, without changing anything, even running it at 10kB/s up (My cap is 120) will choke my internet. I didn't change anything about my set-up, and it happens at two different houses for me.

Link to comment
Share on other sites

P2P is often stressful to hardware...

Okay, so you connected directly to the modem without using wifi and used a cat5 cable? To rule out the router and the USB wifi being the problem.

The last thing you can do is try a different modem, but that's easier said than done, I'm sure.

Link to comment
Share on other sites

im haveing this problem as well same exact scenerio but ill add that i loose my digital phone service as well and like you said if there was all ready a connection its fine but if i refresh the page or anything it wont connect the very moment i turn on any torrent client az utorrent and this just started last night out of the blue! If i turn x torretn client off it seems to go back online ok! this is very strange! It cant posssibly be a utorrent bug as it seems to effect any client i use and its not my system as far as i can tell. Could this be an attempt by certain individuals and corporations at flooding and or hindering the torretn community from illegal file shareing??? As of right now i can not dl or ul any torrent without loosing tcp functionality! Please help if any one has this same issue and has been able to correct it!

Link to comment
Share on other sites

This is really interesting. I'll summarize the most interesting features of this behaviour:

1) it starts suddenly and for no reason the users can tell. "Out of the blue" is a good description

2) it seems to happen with multiple clients (the very same thing happened with az to me before; interestingly, though, it went away exactly the moment I started using µtorrent as my client, so there's gotta be SOME connection to the client used)

3) SP1/SP2 don't seem to be an issue.

4) it happens with very different ISPs (I guess most of you guys are in America; I'm in Germany, using our biggest ISP (T-Online))

5) while the problem affects the establishing of OTHER tcp/ip connections, µtorrent itself seems to have no problems to make new connections. For instance, I've added torrents while this effect was going on and they came in just fine.

This is mysterious ;) Just out of sheer curiosity, I'll try and install Azureus again and see what'll happen. I prefer µtorrent a LOT; it's SO much faster, slimmer, easier to use, and just plain sexier, but I just want to try out what would happen if I switched clients again.

The factors outside our control--or rather, the factors we cannot easily look at exactly--would be:

* Our ISPs and whatever tweaking they're doing on their side.

* The exact set of torrents being downloaded, and more precisely:

* the size of torrents

* the amount of files in torrents

* the trackers used

I'm just throwing these thoughts out there right now; if someone with a little bit more networking knowledge would like to make some more educated guesses, I'd be grateful.

Link to comment
Share on other sites

Well, I somehow fixed it. I ran Ad-Aware and cleaned out my registry with RegistryCleaner. The really weird thing is, I was doing both of those before. I did them when I was having troubles sooner. But when I did them both, it somehow worked.

I'd recommend running both programs for anyone who has this problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...