Jump to content

Uploading problems in Windows Server


Recommended Posts

Hello everybody,

I recently purchased a server which I also use as a seedbox, among other things. The server runs Windows Server 2003 Enterprise R2 SP2, and I really thought it would get along with uTorrent. The server has a 20Mbit symmetric connection.

When trying to download using uTorrent, I usually download at my maximum speed (which is about 2.5MiB/s). The uploading part is where my problem lies.

My uTorrent port is open, and is found to accept remote connections (I'm using port 53249). I read almost all of the guides provided here, but I didn't seem to find any solution to my problem.

Usually, I'm the only uploader at the torrents I'm uploading, and I usually get at least 10 peers connected. The program is uploading, but at really low rates (~200KiB/s). I checked almost everything - I changed the settings using the guides I read here, I even tried resetting and reinstalling uTorrent.

At first, I used version 1.8.3 but then decided to go back to version 1.8.2 since I had better experience with this version on my other server, that's running CentOS linux distribution.

I'm 100% sure my peers have their ports open, since I tried downloading on my own PC and got low downloading speeds (when I tried to download through my other server, I got maximum speeds). Also, when I tried downloading via FTP, my server uploaded the files in my maximum speed.

I'm really sure the problem lies in the Windows configuration, but I'm not sure exactly where. I really don't know what else to do, since I feel I really went through it all.

Thanks in advance.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...