Jump to content

Speed Fluctuation Problem (ONLY when using individual torrent limits)


Recommended Posts

Hi guys, I have a weird problem in utorrent, when I am using an overall upload limit, its fine the speed will remain pretty much constant as long as my WLAN holds up fine .. however when i for example limit a specific torrent or number of torrents to say 20kb/s upload the speed will drop randomly down (overall upload speed) to anything between 30-60kb/s , after about 30seconds or so the speed will then rise back to around 140-170 depending what limit i have imposed for the total (if any limit, it does it with or without the limit on)

any help/experience on the matter is appreciated.


Link to comment
Share on other sites

thanks for the response... it seems to just do it when I limit single torrents (one or more than one), global limits dont really affect it... actually my pics are similar but less frequent/not constantly doing the switch from high to low




also "open more upload slots if under 90%" is not enabled

forgot to mention I am running 1.8.3, havent tried 1.9 (beta im assuming?) and dont know what uTP connections are, could u let me know what uTP refers to please

another thing, i am on Be pro for my ISP, they are known to not throttle any p2p traffic so I doubt thats the problem

Link to comment
Share on other sites

I'm still not understanding if you're lowering ALL your torrents individually to 20 KB/sec upload speed each or just 1.

It's remotely possible you're close to uncovering the trigger conditions for a possible bug in uTorrent v1.8.3 that is causing some speed problems for a few users.

So I'll need you to check a lot more details. :(

Do you have Teredo/IPv6 enabled or IPv6 enabled some other way?

(If so, do you get any IPv6 connections?)

Are you getting uTP connections (a uTorrent v1.8.x and v1.9 feature only atm)?

These have been notorious for causing VERY strange speed fluctuations!


(load the pics in separate tabs/windows to see them clearly)

Try the 1st link in my signature, slow speed/interrupted internet part.

Link to comment
Share on other sites

I am lowering individual torrents to any speed (10kb/s 20kb/s), this can be just one torrent or a few torrents out of the collective whole. (for example 6 can be limited individually but another 10 are not limited individually)#

the install toredo button is greyed out I have IPv6 disabled on my wireless adapter which is probably the reason for that being greyed out right?

uTP is something I havent come across until looking into this situation so il try and check for that but Im not sure where im looking, im guessing uTP is just another protocol rather than udp or tcp?

edit: as u can see there are no uTP connections active:


edit 2: (2nd post but it wouldnt let me double post)

also to add to the weirdness iv seen that the only way i can limit individual torrents and keep a steady upload is by putting the upload on the "automatic" setting, it shows very weird behaviour where periodically the automatic setting will completely unlimit the global upload, this "spike" int he upload (slightly higher than the automatic sets when it is limiting) seems to help prevent the upload dipping

so to reiterrate, it seems that global limit set is fine so long as there isnt individual limits on any of the torrents (this will cause the dips); automatic setting on global will work with individual limits on any of the torrents although shows some strange behaviour (may be normal for auto im not sure)

unlimited global with individual limits causes dips also.

another thing that helped minimize the effect of the dips when I couldnt work out how to get rid of them was this little tool someone wrote for vista: http://www.martin-majowski.de/wlanoptimizer/ (to make it work on windows 7 compatibility mode is fine set to vista)

hope this helps explain it a bit more

Link to comment
Share on other sites

The "automatic" upload limit setting tests the upload limit by unlimiting the upload speed for awhile...then running

You don't seem to understand how the "automatic" upload limit setting works, so best not use it. :P It tests the upload limit by unlimiting the upload speed for awhile. It is NOT a very good method!

uTP connections are supposed to auto-regulate upload speed...but even in v1.8.3 they're a little unreliable. You have to change uTorrent's default settings to make outgoing uTP connections by default. uTP peers and seeds actually use UDP packets.

The install Teredo button is grayed out *IF* you are not running Windows XP SP2 or later...and the button might also be disabled if it's already activated. CORRECTION: Disabling IPv6 on the adapter disables Teredo as well. Teredo is IPv6 tunneled over IPv4 UDP packets.

I set torrents to LOW priority and lower their upload slots to 1 when I want to horribly cripple their upload speeds. :P I don't do that to all torrents, just a few. And I allow extra upload slots for when everything else is running slow.

Link to comment
Share on other sites

i knew that the automatic setting did that at first I just didnt realise it "re-evaluates" by unlimiting ona regular basis after doing it the first time, I dont usually use automatic the only reason i tried it today is to see if it helped the dropping issue.

Im on windows 7 so it must be greyed out from being enabled somehow then.

Link to comment
Share on other sites

well my nod32 has not had any problems with win7 and im only using the windows inbuilt firewall atm. Anyhow I've switched clients now (which is working fine no dips or anything) :(, as much as I loved utorrent when it was working up until recently the problem is preventing me from downloading/uploading a lot :P

Link to comment
Share on other sites

NOD32 may not work so well with Win 7 as it appears.

What client you using now?

Deluge or Vuze hopefully...BitComet is pretty much not a proper BitTorrent client. :(

I've asked a uTorrent dev to look at your problem, but we don't really know what triggers it...as setting individual upload speed limits on torrents doesn't normally cause me problems. :(

Link to comment
Share on other sites

am using vuze, havent used azures for a very long time though i've used utorrent since i can remember! :P aye it didnt cause me problems either before, its really weird.. ah well cant really do more than report the problem ^^ cheers for the help anyways

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...