Jump to content

Error: The semaphore timeout period has expired.


Recommended Posts

Recently, I was downloading a torrent and then decided to shutdown my machine. After rebooting, I got back to downloading the torrent but the above error shows up.

Anyone knows why and how to overcome this?

Do I need to delete the torrent and start all over again?

Link to comment
Share on other sites

None of this links have helped anybody!

If u look at them u will see, that no one had a solution for this Problem. Damn it!!!

Anyway. Hi Forum. I have the same problem for about 1 Week.

I havent changed anything on my System except installed the one or other Vista Update!

Actually its frustrating that here are about 5 "Semaphore" Threads and in no one is something i can call a "smart solution"

I have tried to uninstall the Vista updates and now i will see if it works.

I figured out that it is not a Hardware issue even when the messages leads to this idea!

There are too many with the same problem here. It has to do something with the trackers or with torrent itself!

with regards

p.s.: im not good in english^^

Link to comment
Share on other sites

Thanks for commenting and trying to help. While I posted here, which is natural if one has a problem, I have also at the same time search the threads for a solution. I could not remember which thread, but it seems to be saying that it is a hardware problem. Taking that as true, what I did was just changed the destination folder and download the torrent all over again. It worked. Now, whether I do have a bad sector or not, frankly, I don't know. But who cares until I face the bad sector again, if it ever was bad in the first place.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...