Jump to content

Port Aches...


Recommended Posts

I just updated uTorrent from 1.8.1 (which I had no issues with at all) to 1.8.3. When I did this it changed the port that it had been using and now the Port Checker (http://www.utorrent.com/testport) and uTorrent itself (little orange exclamation point icon on the bottom status bar) tell me the port is blocked.

First off, it can't be fully blocked because I am getting some peer connections. Overall I am getting only about 10% of the connections and less than 10% of the speeds I used to get though.

Secondly, I have gone every guide on this site about port forwarding, firewall exceptions and maximizing speed and still the port appears to be inaccessible.

I would just change the port back to what it was when I was running 1.8.1 but I honestly can't remember what it was and I never had to set up any kind of port forwarding for it then. Currently this computer has a static IP to my router, the router has port forwarding set up to this computer, my firewall has both the utorrent.exe listed as well as the port for TCP and UDP as exceptions and I am not running any kind of IP or Port blocking software like PeerGuardian.

I have also tried to change the port to a new random one, going back through all the steps to re-forward and so on all to the same affect.

Anyone advice for what else I can try?

Link to comment
Share on other sites

Just deleted and recreated all three exceptions (program, port TCP and port UDP) in Windows Firewall and restarted computer (just for fun) and still no glory.

I could try randomizing the port again and re-doing forwarding and exceptions again, but like I said in OP, I already did that once.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...