Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.0 beta 17539

Recommended Posts

im suing uTorrent build 17427.

in the 'Created On:' field, it is displaying ...uTorrent/200b instead of uTorrent/2.00b

also an FYI: when upgrading to 2.0, it wipes out your personal default comment in the torrent comment field, so reenter it after upgrade. i didnt notice until after i built 2 torrents.

I would also like to state that 2.0 beta 17427 works great. no crashes and speeds are where they should be and everything works.

I know this isnt the suggestion forum so i applogize but im already here. It would be nice if we could have it automatacly start seeding a stopped torrent when it drops below a certain amount of seeders. maybe it has that feature and ive missed it.

thanks

Share this post


Link to post
Share on other sites

Hi all - a word about the auto restart feature (Change: Added auto restart feature for use in minimized mode.):

Here's how this works:

Note: This feature is only available in stable releases. (It is not compiled into betas or alphas)

If you have uTorrent minimized, and you haven't been active at the computer in the past minute, uT will automatically restart if it crashes.

uT will not restart this way more than once an hour. If it crashes again within an hour, it will stay dead - another restart won't be rescheduled. No crashdumps are sent, but a notification of the crash is sent.

The idea is that you may depend on having uT running, but if you are away from the computer, you can't do anything about it. However, if the user is present, we use the old behaviour and display the crash dialog.

You can disable this feature by changing gui.auto_restart to false

Share this post


Link to post
Share on other sites

There is something weird going on with the GUI... When I add torrents from magnet links, the "scroll down" button (standard gray windows button) is showed instead of the normal blue square with the white arrow.

However if i restart the application, then it will switch to the right icon...

Share this post


Link to post
Share on other sites

Any word on the alpha? It hasn't been updated in a while. Should I be using the beta instead for faster updates?

Share this post


Link to post
Share on other sites

@420: If you don't need the features being tested in 2.1, stick with the 2.0 beta series.

2.1 is 2.0 plus other features.

Share this post


Link to post
Share on other sites

Thanks. I get that part. I was just trying to find out if you guys plan on updating the alpha as frequently as the other versions.

Share this post


Link to post
Share on other sites

2.0 is getting close to release, so it will get more updates for now. 2.1's pace will quicken once 2.0 hits stable.

Share this post


Link to post
Share on other sites
- Change: tell user about buggy 3rd party software that might degrade uTorrent performance

Out of curiosity, is the list of software uTorrent checks for available?

Share this post


Link to post
Share on other sites

I just tried to auto update to the latest beta, and something went terribly wrong. I see utorrent.exe and uTorrent.exe.10787.tmp in my ut folder, the process won't restart because it can't kill the old one. I can't kill forcefully kill it in cmd, or with procexp.

Share this post


Link to post
Share on other sites

i don't know if its just me or what but when im using the latest build 17539 with switech conservative setting and tcp_rate_control - false its too slow... i cant even reach my maximum download speed which is 180KBps but when ive reverted back to 17427 it reach the maximum speed in 15 min but in 17539 its only reaches 30-50KBps in 1 hour

Share this post


Link to post
Share on other sites

Hello.

I have 3 years of using the uTorrentet - good to program.All expenditure was a little mistake. Last night I let you upgrade to the 2.0 B.17539 away. And I do not see the headline in the (%)

If this will not be folded back - I will not use this version.

I'm with impaired vision - a lack of blue indicating the process.

Help me - please.

Thanks.

Share this post


Link to post
Share on other sites

gendouhydeist, your conditions?

Hostile ISP?

Few torrents? Few seeds/peers on those torrents?

Private torrents/trackers?

Even if the problem is a uTorrent bug, knowing the conditions that make it WORSE might help the developers.

Share this post


Link to post
Share on other sites

i have 5 torrents at that time, the conditions.. with your conservative setting, tcp_rate_control = false, net_calc = true, limiting the upload bandwidth to 3KB, Hostile ISP... yes cause its limiting my download speed on TCP protocol but not in uTP which i could say that its really a successful one..., yes i have private and the open trackers on it..

Share this post


Link to post
Share on other sites

It seem uTorrent 2.0 build 17539 cause 100% cpu usage on my Windows 2003 R2 Sp2 server. about 605 of the usage is utorrent itself and the other 40% comes from "System" but only when utorrent is running.

Never mind on the above it was avast even though everything but standard shield was disabled.

But this is still happening.

I tried the 2.1 alpha but it just crashes out on startup, I did tell it to send the dumps.

Share this post


Link to post
Share on other sites

well ive found something interesting... my ISP is blocking extension .torrent through proxy well there's one website that converts your link by adding .txt on extension so you could download it normally well it works like charm, I just wanted to share this

Share this post


Link to post
Share on other sites

gendouhydeist, my settings chart contains *MANY* settings. So telling me you've used them really tells me nothing. I know nothing about the capabilities of your internet connection as well.

Share this post


Link to post
Share on other sites

Good to see that the transfer cap counting issue has been fixed. That will be useful, but would it be possible to set the transfer to reset on a particular date each month, rather than every certain amount of days?

ie. Have time periods of "Since the start of this month" or "Since the start of this week" etc.

Share this post


Link to post
Share on other sites

Running µTorrent 2.0 Beta (build 17539) on Windows 7 U(x64) & Windows XP H(x32) through a city wide WiMax provider, each with their own WiMax modem. Yay IPv6 native service :)

Performance has been great, except it will hang periodically on the W7, the reports are going out, so I hope it helps.

I did want to mention a few things that I don't see anyother way to report, except directly.

I love the fact that you can use multiple file or torrent selection to do group changes, this will help integrate multi-touch capabilities into the system. I noticed that on W7 if I select multiple files inside a multifile torrent, right click, and select open containing folder, then it opens one directory for every file I selected. I thought it was odd and did not remember that behavior on XP, so I investagated...

As it turns out XP doesn't do this, so I thought, what would be the prefered action? Here are senarios I have come across or forseen and its sugestion for action...

1: 1 Selected File in root folder - Explore to Root Folder (define root as torrent download location)

2: 1 Selected File in subfolder - Explore to SubFolder (currently the action on XP or 7 is to open root)

3: 2+ Selected Files in root folder - 1 Explore to Root Folder (not multiple)

4: 2+ Selected Files in subfolder - 1 Explore to SubFolder (not multiple)

5: 2+ Selected Files in different subfolders - 1 Explore to EACH Subfolder

6: 2+ Selected Files in both root and some or multiple subfolder - 1 Explore to Root Folder & 1 Explore to EACH SubFolder

It will be interesting to see what people think of these ideas as prefered actions.

As a side note, with the addition of RSS feeds, I think µT needs to consider the idea that it can be more that just a file download engine, and more of a content management, playing and subscription service. I have tried the program Miro with the RSS's I usually use for µT, and it impressed me with the concept it would handle showing me what was new and how long I have had it and it kept an eye on available recording space. I did NOT like how slow and unresponsive it was, so I just use it for showRSS only. In my eyes combining the µT with MPC-HC and a Hulu playlist type idea would be great.

I picture the fundamental elements involved are the following:

Recognizing the primary media file inside a torrent file.

Tracking file status: Not Ready, Unplayed, Played, Started (If stopped in first 10% or less), Finishing (if stopped in last 95%), Playing (Durring play and if stopped between Started and Finishing), Publication Time, Ready Time, Est Time left (based on ratio, hdd space left, age of file)

Allow for a Playlist tab that only shows when you are selecting an Feed.

Allow for creation of subfolders in the Feed area (to sort)

Add an Unplayed / Played / Started / Finishing feed (like All feeds) to give the unplayed playlist

Allow for sorting by the feed tags under any feed

The primary things to be tracked are unplayed/started/"finishing"/played How possible would this be with either 1) adding it as a feature or 2) creating it with the WebUI or 3) integrating a dlna server to provide the media (and the rest of the when to delete and played/unplayed is taken care of by the settings)?

Robert L. Sawyer III

sawyeriii @ assorted

Share this post


Link to post
Share on other sites

the 2.0 version is great but i find some imperfections...when is open the pc works very hard and also the internet...i read the posts and i show that the nod32 firewall could be the problem and i have desable it, but no change, and when i have restarted the pc i received this error: http://wer.microsoft.com/Responses/Response.aspx/10/en/5.1.2600.2.00010100.2.0?SGD=2ab12872-7857-4537-a062-99df538299a4

Share this post


Link to post
Share on other sites

You can't just disable your firewall, only uninstall it.

And that error means your computer is crashing because of a broken driver.

Share this post


Link to post
Share on other sites

It seems that setting the UL limit to 0 (which is the DEFAULT...!) stops all currently running seeding tasks. This was also reported on IRC for 1.8.5. Test conditions:

- # of UL slots - 3

- calc_overhead - on or off

- UL limit 24K/0

looks like something that should be fixed ASAP. FYI .

Note: an interim solution might be setting the default for the global UL limit to 9999 except that is messes up the speed graph :( ...

Edit: important note: this seems to not happen if the uTP (so called "enable bandwith management") is disabled!

99648037.png

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.