Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 1.8.4 released

Recommended Posts

Here's a new release for the 1.8.x line with some additional bugfixes. The 1.8 line is stable, so only fixes and minor tweaks will be added from here on out. All new features will go into 2.0.

http://download.utorrent.com/1.8.4/utorrent.exe

-- 2009-09-28: Version 1.8.4 (build 16688)

- Fix: fixed potential crash in WSARecv and WSASend

- Fix: fixed piece availibility issue introduced in previous build

-- 2009-09-25: Version 1.8.4 (build 16667)

- Change: Balance CDNs to download updates

- Fix: Fixes bug where magnet links wouldn't work if PEX was disabled

- Fix: potential crash in network code

- Fix: More crashes when using magnet links

-- 2009-09-10: Version 1.8.4 (build 16442)

- Fix: Potential crashes with magnet links

-- 2009-09-04: Version 1.8.4 (build 16381)

- Change: Disable Ask for unsupported 64-bit Windows

- Fix: Buffer overrun vulnerability

- Change: Conservative network locking in installer

-- 2009-08-28: Version 1.8.4 (build 16301)

- Fix: Installer crash after download

- Fix: Crash when peers disconnect from a magnet-link torrent right as we received the metadata

-- 2009-08-27: Version 1.8.4 (build 16286)

- Fix: Fixed negative allocation in RequestChunks() for web seeds

- Fix: Fix startup race condition between network and disk I/O thread

- Fix: installer with UAC

- Fix: Crashes when removing labels

- Fix: selection of labels over 256 characters in length

-- 2009-08-12: Version 1.8.4 (build 16150)

- Feature: Enabled magnet bundles.

- Change: run the 64 bit version of explorer when running as a 32 bit app in a 64 bit windows os.

- Change: disable toolbar offers for Wine installs

- Change: uninstaller is added to all user profiles

- Fix: crash when assigning new label to torrents from RSS

- Change: Incomplete downloads sort after completed downloads if sorting by "Completed On"

- Fix: maintain category list selection on update for some edge cases

- Change: if selected, install start menu and desktop shortcuts to all users instead of only current user

- Fix: buffer overrun vulnerability in create torrent dialog

- Fix: Check at startup for incompatible versions of NVIDIA nForce firewal

Share this post


Link to post
Share on other sites

Load a torrent, add a webseed via torrent properties, press ok, remove webseed address. µTorrent reports the http seed address (which no longer exists), is wrong, each time the torrent is started. resume.dat ends up with an empty entry under webseeds for that torrent.

Also, keep getting "[2009-08-12 23:56:13] File not found during integrity check: C" whenever running without the usual files around (resume.dat, etc), "self contained" operation. What's the C for?

Share this post


Link to post
Share on other sites

You can't click the "I accept the Licence Agreement [...]" label in the installer to (un)check the option.

A new instance of explorer.exe is still opened when double clicking on a torrent (with the default action set to open containing folder) even if the option isn't checked in Explorer.

Share this post


Link to post
Share on other sites

Thanks for new version. In 1.8.3 me, and my friend was in problem with speed of download. A lot of seeds and speed is very low. I believe you fix it, or will fix it, i don't think that it's only my problem.

Share this post


Link to post
Share on other sites

Some minor glitches/bugs with uT 1.8.4 (un)installer:

1/ Align 'Downloading translations...' and (reduce too) the progress bar:

langut.th.jpg

2/ Is it possible to make URLs (like http://forum.utorrent.com/) clickable on BitTorrent's disclaimer and license like Ask.com window (about policy or EULA)?

3/ When I wanted to uninstall uT 1.8.3 for some reasons with the Program Manager of Vista, I saw the version number was 1.8.2 and hasn't been updated from 1.8.2 to 1.8.3 even if I used auto-update.

That's not the case with the other programs like Firefox.

utversion.th.jpg

4/ When I uninstalled uT 1.8.3, I checked the box 'Remove settings'.

utorrent.exe has been removed AND the entire folder %appdata%\utorrent with its subfolders/files (like my backup folder or some files useless for uT): is it the normal behavior?

I remember in uT that removing a torrent (with a folder) doesn't trash extra-files or folders not relative to this torrent.

Thanks for reading me.

Share this post


Link to post
Share on other sites

Still the same problem with 1.8.4. When seeding in max line speed, the speed suddenly falls down to almost 0 every about half an hour, for a few minutes, and then goes back to full speed.

This doesn't happen with 1.8.2.

Share this post


Link to post
Share on other sites

Samething when seeding at max, speed rarely goes to max and then bottoms out to 2-5KB/s. Reinstalled 1.82 and problem solved.

Share this post


Link to post
Share on other sites

I have exactly the same problem with speeds dropping to basically 0. It usually happens after I add a largish torrent. Can be random.

Strangely enough, as I stop other running torrents, speeds will pick up until it's fast again with all other torrents stopped. The only thing that can 'fix' this is stopping other torrents or completely exiting the client and hoping when I fire it up again that it doesn't start having the same problem immediately

This is proven to be a uTorrent issue, as Performance Monitor indicated minimal disk, RAM, network, and CPU usage.

Share this post


Link to post
Share on other sites

Oh this is me again. Version 1.8.3 (15772) tells me that "No new version is available".

Eleven days since release passed, so when this version will be pushed to normal users?

Share this post


Link to post
Share on other sites

I have had to come here and manually update the last 3 versions (1.8.2, 1.8.3, 1.8.4). Not including the individual build #'s which I have never seen it update on any version.

So my point is, what is the point of an automatic updater if it does not automatically update?

Share this post


Link to post
Share on other sites

Rubberkitty, you'll die if older version will run or your computer a little bit longer? (: It's just some precaution or maybe some kind of load balance.

Share this post


Link to post
Share on other sites

Speed problems continue in 1.8.4!

After i add new torrent this is not download or REALY slowly!

I have to quit and start it again, and then it start to download with normal (more then 100kb/s) speed.

Check it developers!!!

Share this post


Link to post
Share on other sites

If I can make a few small suggestions:

I absolutely despise the installer (or even the idea of an installer for utorrent, even self-contained), but I have to live with it, I know, so please can you make an option to SKIP it, ie, just copy EXE to the destination folder and that's it?

Also, I never asked utorrent to change my .torrent icons, could I also ask that the installer DOESN'T screw with filetype/icons associations?

That would be VERY MUCH welcome.

Thanks a lot,

TSR

Share this post


Link to post
Share on other sites

New build of 1.8.4 up fixing some of the crashes/bugs we saw in the initial release. That's why we haven't put it up on the auto-updater.

Share this post


Link to post
Share on other sites

I must say I'm confused... what's the correlation between this version and V 2.0 ? does this mean that the same issues (that were fixed) are still open in V 2.0 B16222 ?

Share this post


Link to post
Share on other sites

Not clear, does "Fix startup race condition between network and disk I/O thread" address the speed fluctuations or has that issue not been fixed?

Share this post


Link to post
Share on other sites
uncheck "install utorrent" and it'll run in-place after that.

Thanks for clarifying that, I was thinking about the effect of unchecking this box.

Does the installer appear the next time the user starts uT?

Share this post


Link to post
Share on other sites

Hi,

Starting yesterday with uTorrent v1.8.3 on WinXP I have the same problem as "tapin13".

Using uTorrent v1.8.3 I have updated today to 1.8.4 and completed torrent does not seed anymore and any new torrent does start automatically.

Seeds and peers are retrieved but torrent does not start till I restart uTorrent but any completed torrent are no more seeding. I use uTorrent since some years and never had this mistake. I have rechecked all my setting using guide and all seems good.

I'm using uTorrent beta on a Mac too and does not encountered this trouble.

Kind Regards

Moo

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.