Jump to content

Limiting the up and download speeds in 1.8.4 uT are not working


Recommended Posts

I am using utorrent 1.8.4, on WinXP SP3 on a high speed network.

A tried to set the up and download limits in

1. Options --> Preferences --> Bandwidt

2. In the torrent specific properties

3. With the taskbar menu

but none of them are working: utorrent downloads and uploads torrents without the apply of the properly set network speed limits (the speeds are much more faster, than they sohuld be)

Note that my network environment and how I use utorrent is not regular, see the below link for more info:



Link to comment
Share on other sites

I will do it tomorrow, thanks.

MOD: Here are the images:




The pictures are taken from a download point of view, but the uplink limits are also not working.

I think the root cause of this probelm is as you see on the peer list, I use an inbound SSH port forward and every traffic in and out goes thorugh the loopback interface (incoming port is:

Thank you!



Is somebody take care of this problem? Did the developement team acknowledged it? The problem is not solved yet.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...