Jump to content

µTorrent ignores my speedlimits in version 1.8.3. Bug?


Recommended Posts


Sometime last week my internet connection appeared unstable, pages would load slowly and most tings online were just slow. Checked my router and saw that I was pushing data out like there was no tomorrow and on a 20/3,6 Mbps link, the upstream killed my downstream. The large upstream came from µTorrent and I tried to set the global upload speedlimit to an lower setting but nothing changed. I also tried restricting individual torrents but they could happily pump out 200 kBps even when the limit was set at 5. I tried uninstalling µTorrent and deleted the files in C:\users\My account\AppData\Roaming\uTorrent\ to kill all settings. Reinstalled the same version (1.8.4) from this page and tried again. Speedlimiting still did nothing. Uninstalled again and tried the latest v2.0 beta. Limiting worked fine but many trackers ban beta-versions so running 2,0B isn't really an option for daily use. Then I tried µTorrent 1.8.2 (Build 14458). That one also limits speed like it should but some sites have already banned this older version so that's not to good either.

Do I really have to install third party software to keep the upstream under control, or even another BT client?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...