Jump to content

Enabling ICS kills port forwarding...


Recommended Posts

First up, this is not a firewall issue, at all.

I have an ADSL connection, and have set port 50420 to be forwarded locally for use with utorrent. I have set this on the modem. Everything was working fine, and various tests and utorrent itself shows the port as being forwarded correctly, as well as various other client programs. The status light was a healthy green.

However, after sharing my internet(LAN) connection via my wireless connection, the port stops being forwarded. Nothing gets changed on the modem, so I am unsure as to why this is happening. No firewall on any connection is enabled. I did enable the firewall briefly with utorrent exempted in order to log rejected requests, and only IPv6 ICMP stuff was rejected.

I have tried with UPnP enabled and disabled, and have DHT, peer discovery and country resolution enabled. Honestly, my utorrent settings should not be the problem, since it works fine when sharing is not enabled.

My Ethernet adapter has DHCP enabled, and gets an addresses automatically from the modem. Sharing this connection assigns my wireless connection a static IP of and allows for clients to use my computer as a gateway.

I am unsure why this prevents the port from being forwarded correctly....

Link to comment
Share on other sites

I tried that, but it did not make any difference. It seems to be a bigger problem that that, as the test on the utorrent website shows the port as closed. It is really, honestly, very very odd.

edit: actually, setting the outgoing ip worked. Why does it need to be set when ICS is enabled? I guess because tehre are two connections set as internet enabled, but this should still not cause a problem. How very odd.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...