Jump to content

Listen error: The icon is always red but when I make the port test...


Recommended Posts

My original thread is here http://forum.utorrent.com/viewtopic.php?pid=428314 and and for long time I didn't receive any answer so I start a new post because the thread doesn't get updated at all. The thread doesn't get bumped up too when I edit it which sucks. so nobody will of course go 10 pages into it to find my post.


Listen error: The icon is always red but when I make the port test it says


Port 49155 is open and accepting connections.

You will be able to receive incoming BitTorrent connections.

My question: Why is the icon in the lower middle still red, even I have no problems forwarding? To round it up, I installed Windows 7 and disabled UAC and windows firewall.

It doesnt matter what port I use, always same error. This makes me unable to seed, meaning I can't signup to any private torrent sites either.

Link to comment
Share on other sites

Finaly I fixed it, but I am sure its a dirty fix. spoolsv.exe always takes that port I use for utorrent. And the strange thing is that spoolsv.exe sends a lot of data out instead showing utorrent (which I can see with my cfosspeed console).

Simple fix:

1)Do not close utorrent

2)kill process spoolsv.exe

3)exit utorrent

4)start utorrent again and you get your green icon. strange...

Now I do not know why spoolsv.exe has to finger around in my utorrent stuff but that's the reason that every port not works because spoolsv.exe always takes it away from utorrent.

Hope it will help someone else with a similar problem.

thanks for utorrent :D

Link to comment
Share on other sites

Its not a trojan or virus. checked it already. I just rebooted and now its lsass.exe which uses that port. I killed that process and windows had to shutdown with an alert, as it should do when lsass.exe is killed. Its a bit strange whats going on here. I changed to port 60001 and at the moment it works. I had to change router portforwarding too. I wonder if in router UPNP is enabled whether some process in windows 7 just snaps that port.

I installed a fresh copy of windows 7 on my 'Acer Aspire One' Atom PC and the same problem happens. If I didn't knew better I would say its win7, because with windows XP I never had that problem for years.


Final solution: In windows 7 I can not use the range of 44xxx-50000. When I changed the port before I changed it a few ports up or down. Now I use 60001 and even after reboot it works. The same applies to my 'Acer Aspire One'. After changing to 60001 it works flawlessly. Simple like that :\

Knowledge is Power! :D

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...