Archived

This topic is now archived and is closed to further replies.

MightyZIM

Start next torrent after current one is downloaded

Recommended Posts

It already does that after it completes one torrent job in the list.

Completed == seeding priority ratio reached, default being 150% (just in case you're wondering why it's not doing that once you get 100% of the file)

Edit for clarity ;P

Share this post


Link to post
Share on other sites

Newbie question about download queue:

How do I know / control which torrents are next in the queue?

Is it just by the order in which they are shown in the download window?

I have a couple in the queue and some are more important than others for me to get.

I want to set max active dls=1 so I only d/l 1 torrent at a time (I have slower connection). Then when that 1 is done I want it to continue to next torrent (immediately if possible).

Share this post


Link to post
Share on other sites

Thanx. How do make sure that the next one in the queue starts immediately after the current one finishes? (what should the seeding priority ratio be set to?)

Share this post


Link to post
Share on other sites

you can alter the order with the up/down buttons on the toolbar/context menu, Ctrl Up/Down moves to the top/bottom of the queue.

And um, a low value I guess, if you want it unconditionally re-queue the torrent when finished.

Share this post


Link to post
Share on other sites
It already does that after it completes one torrent job in the list.

Completed == seeding priority ratio reached, default being 150% (just in case you're wondering why it's not doing that once you get 100% of the file)

Edit for clarity ;P

Ok, so I just set the seeding priority ratio to a low value to make the next torrent start right after the current one is done? Or will that result in it being started sooner?

Is there any way to start it only once the current torrent is 100% done downloading? (base it on the file being 100% done d/l and not on the seeding priority ratio.)

Share this post


Link to post
Share on other sites

When all your downloads finish, it'll start seeding them one by one. I recommend that you raise the ratio back to whatever amount (100% or so) so it prioritizes them properly.

Share this post


Link to post
Share on other sites

Don't you think it would make things easier if "Completed == 100% completed d/l file" instead of "Completed == seeding priority ratio reached" ? The finished d/l will start seeding anyway after it's completed, so I don't understand why it's done the way it is at the moment?

Share this post


Link to post
Share on other sites

because stopping before you've seeded to a good ratio is considered hit and run (the tracker doesn't know if you're gonna seed afterwards), especially if you stop immediately after.

It's generally not good practice to do what you're doing, hence why it's not the default.

Share this post


Link to post
Share on other sites

Ok, I understand that you want to prevent hit and runs, but surely the next torrent in the queue can start downloading as soon as the previous one is done d/l.

The previous one will start and continue seeding immediately after its d/l is complete, while the next one in the list starts?

Share this post


Link to post
Share on other sites

i guess u could set ur queue settings to "maximum active torrents =1" and "maximum downloading torrents = 1", it shouldn't let any torrent get to seeding status as soon as you have many downloads in queue... i dont like hit & runners anyway... and utorrent of course doesnt support 'em...

Share this post


Link to post
Share on other sites

But then I wouldnt be able to seed more than 1 torrent at a time...

Anyway, I still think "completed=100% d/l" would be a better option than "completed=seed priority ratio reached". Some torrents are very well seeded and it may take much longer for me to reach the seeding priority ratio than to finish the download. This means the next torrent in the list will be waiting longer than needed to start.

But then the reverse is also true. A torrent could get stuck at a certain % while waiting for seeds to connect. In this case it may reach the seeding priority ratio way before completing the download, if it even completes the download. Then if "completed=100% d/l" the queue would be stuck for as long as the download takes to finish.

So maybe this could work: "completed=seeding priority ratio reached OR download finished"

Share this post


Link to post
Share on other sites

Complete can't equal 100% download completion, because it'd only help leechers. If you want to do that, by all means, do that (considered leeching, by the way), but µTorrent's not going to do that for you.

Also, the completion thing only occurs when the torrent is 100% downloaded AND the seeding has been at least reached, so you won't get torrents being marked as complete but not finished downloading... that's very backwards, and people would definitely have complained a long time ago.

Share this post


Link to post
Share on other sites

Cool, thanx for explaining things.

One last stupid question: what if the seeding ratio has been reached, but the file has not finished downloading (maybe it's stuck because there are no seeds / peers) would this hold up the queue, or would the next torrent start?

Share this post


Link to post
Share on other sites

The seeding ratio only applies (obviously) to seeds.

However, if the torrent has stalled completely (<1 KB/s uploading AND downloading), then the next one would start, I believe. :P I'm not really sure how it handles no downloading but still uploading... I think it has to be below both thresholds.

Share this post


Link to post
Share on other sites

If I have max number of active downloads set to 1 and the first one stalls, the next one begins. If the first one that stalled now resumes downloading should the second one re-queue?

Share this post


Link to post
Share on other sites

you can try this if this works for you.

on torrent option:

maximum number of active torrents: 1

maximum number of active downloads: 1

on seeding priority:

set ratio to <=100, seeding time to ignore.

seeding tasks have higher priority than downloading tasks: uncheck

check the upload reate to: check: 0kB/s

hope this works.

regards!

Share this post


Link to post
Share on other sites