Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.0 released

Recommended Posts

Ambiguity in data - is undesireable. Well, I'm sure uTorrent is clever enough to disregard those illegal address, and also subtract them from the total count ... at least - users will not continue asking "why the numbers do not match".

I'm sure people will ask this same question about the speed numbers on the status bar and why they do not match, now , the set limit (with calc_overhead =true).

Share this post


Link to post
Share on other sites

i am connected using itshidden vpn and utorrent is using http proxy 95.46.120.46 port 3128 listen port 50500 and working, is this double protection or not? am i undoing vpn protection? i am also surfing on vtunnel whille using vpn, double protectior not? thanks i am slow need help thanks so much

Share this post


Link to post
Share on other sites

Its just me or "REAL" upload limit is different in net.calc_overhead=true and net.calc_overhead=false ?

Cause I get slower download speed with limit set to 15KB/s on net.calc_overhead=true, on false work better...

or simply in net.calc_overhead=true limit all upload, and false only data, but not overhead

Share this post


Link to post
Share on other sites

Yes, it behaves differently with calc_overhead turned on. It includes overhead in the limit and reduces the possibility of the overhead from downloading+uploading from choking out your connection. In turn, you can set a higher limit than before (you don't need the mythical 20% buffer for download), since the overhead is included.

Share this post


Link to post
Share on other sites

@Virtual_ManPL : and what were your actual download speeds ? and your max possible connection speeds ? and did you use the setup-guide for you limits' settings ?

Share this post


Link to post
Share on other sites

@ Firon - ahhh, thx, working fine with 25KB/s upload ;p

but odd... uT speed-test show my speed about 38KB/s (~300kb/s), but I have only max 32KB/s (256kb/s)

@ rafi - 3Mb / 256kb (12Mb/512kb in night), connection speed in default, but nvm its now working fine,

cause even speed-guide set limit to 22KB/s on my 256kb/s line, but in my tests uT1.8 works the best with 15KB/s limit on my line... but its good that now in uT2 I can upload faster with same download speed :)

but still I prefer that net.calc_overhead should be set on TRUE by default

Share this post


Link to post
Share on other sites

great :) the 256K is almost exactly like I have (but 1:10 line) but both day & night... :( 22K limit works for me well though. In your case, the problem will be at night - you will simply never get 12M download with 512K up, even if you set it to 60K limit or even unlimited... Anyways, you need to also specify ~60K limit in the uT scheduler for your nights ...

Share this post


Link to post
Share on other sites
A little bug with Russian translation - not enough space for string in torrent properties dialog box

...and also one string up:

uT2rc4_3.png

Share this post


Link to post
Share on other sites

setup guide:

should suggest the dslreport test-site ALSO and especially when the test server fails.

download test - is too short for accurate measurement with large connection speeds, and actually a bit redundent...

BTW, is the port being tested for both UDP and TCP forwarding ? (it should... )

and one more GUI improvement for 2.01... : "Stop all" for all buttons -

88835414.png

more here:

http://forum.utorrent.com/viewtopic.php?id=67212

Share this post


Link to post
Share on other sites

GUI glitch (not sure it started in 2.0) :

in the pref.->scheduler tab - when you change any of the "squares" - the "apply" button should be enabled . It stays disabled. So it's hard for you to test your limit + correct date settings in the speed-graph, since you have to press Ok and exit the setup to apply changes.

Share this post


Link to post
Share on other sites

I'd like to point out the following bug again since it got no answers:

I figured out the problem with magnet association not sticking. Using a clean install of Windows 7 and uTorrent, it doesn't mess up (ie. all stay associated after install) until I put maindoc.ico into %AppData%\uTorrent. After that icon file goes in all associations need to be redone and uTorrent simply can't redo the magnet one with a custom icon for some reason. Removing maindoc.ico allows it to reassociate correctly with magnet links again.

This is a really annoying bug if "check associations at start" is enabled, and I think that's a good option to have working so I see 3 options: 1- fix uTorrent to associate magnet links with the maindoc icon (as it should according to the skinning documentation); 2- workaround the problem by having it only associate files with the maindoc icon and associate magnets the way it would without a maindoc icon present; 3- workaround the annoyance by having Check associations ignore the error state of the magnet link association so it doesn't constantly bother one on program start about it.

Share this post


Link to post
Share on other sites

RC5 still slow speed when compare with 1.8.5 such as when starting download, It's take few seconds to my maximum connection speed while RC5 take 5 minutes or more to do that.

2.0 skin look bad, I know I can download which I like but I think this skin not OK for default.

Share this post


Link to post
Share on other sites

http://forum.utorrent.com/viewtopic.php?pid=443280#p443280

Then do elaborate: in what way is the new skin "bad"? Because just saying it's "bad" doesn't tell anyone anything.

As for the slow ramp-up in speed, is a 5 second ramp-up time really going to cost you anything? It's uTP's bandwidth management doing its job to make sure the connection isn't getting killed. If you don't like it, then disable bt.tcp_rate_control or something. You just won't get the benefit of minimized latency afforded by the extra intelligence brought with uTP.

Share this post


Link to post
Share on other sites

Ultima, Ondoy said it took 1.85 took a few seconds to get to maximum speed, but RC5 took 5 minutes (not 5 seconds)...

Ondoy -- did you already post a graph of the speed ramp up for both 1.8.5 and RC5? It would most likely help the developers assess the problem....

Also...

GUI glitch (not sure it started in 2.0) :

in the pref.->scheduler tab - when you change any of the "squares" - the "apply" button should be enabled . It stays disabled. So it's hard for you to test your limit + correct date settings in the speed-graph, since you have to press Ok and exit the setup to apply changes.

Just tested this on 1.8.5 and it has the same behaviour. I found that I can enable the Apply button by unchecking/checking "Enable scheduler" check box.

IF I was making a decision on this Pref->Scheduler bug, I would not hold up rel 2 for this issue because (a) it existed in 1.8.5 and (B) is not operation affecting.

Share this post


Link to post
Share on other sites

@xaxax: I agree, it can be done in a 2.01 release. but ... still, 2.0 should be fixing 1.8.5 bugs as well, ans since this is a 5 seconds fix... (ok, 5 minutes...) why not just do it.

Oh, and Ondoy DID post a few graphs... http://forum.utorrent.com/viewtopic.php?pid=447153#p447153 show just the opposite since he is using a local ISP cache peer...

@Ondoy: try increasing your bt.connect_speed a bit (though, it's not recommended) and reduce peer.disconnect_inactive to 100

Share this post


Link to post
Share on other sites

The latest beta is choking my network as soon as I start downloading something in uT. I didn't have this problem with RC4. :)

The scenario is as following: I'm connecting through a PPPoE protocol, start dling something in uT, I max out my connection in 10-15 seconds, then speeds drop almost to 0 and practically my internet connection is killed (uT, but also for browsing). I disconnect and reconnect again to the network (without shutting down the uT) and the second time all is good, no more choking. RC4 worked just fine for me.

I'm on a fiberlink connection, win 7 Premium x86, default settings for uT except 'bt.tcp_rate_control' and 'net.calc_overhead' to false.

Share this post


Link to post
Share on other sites

since you did not say what your connection speeds are, proper settings should be :

calc_overhead = true

upload limit - ~70-80% of your connection max (use control-G/setup guide)

And unless you have a connection with more then 1:15 UL/DL ratio, it should be fine.

RC5: Context sensitive help

in preferences: Can you please make F1 work in preference (like clicking the mouse on "?") ? Thanks... :)

In setup guide/RSS downloader related dialogs (fav/add feed)- can you make F1 work for them too ? "?" will be nice there as well...

Context sensitive help for the rest of the dialogs and even tabs-RC menu will be nice too

Share this post


Link to post
Share on other sites

rafi, my connection is (from speedtest) dl: 90Mb/s, up: 50Mb/s and I don't need to limit my dl or up. And as I already said RC4 worked just fine with the same uT settings. ;)

Share this post


Link to post
Share on other sites

I wish I had your great connection ... :) a screeshot of your uT speed-graph/# of connections when this happens - will be interesting (but with calc_overhead=true)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.