Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.0 released

Recommended Posts

I'm sure It's not about bt.connect_speed, cause maybe switching between 2 and 1.8 on testing.

I will test again and report back as soon.

I remember "peer.disconnect_inactive" It's not effect lower 300 sec?

Thank you.

Share this post


Link to post
Share on other sites

@Ondoy, you might be right. , I can't remember.

And they lowered the default for connection_speed to 5 (connections-attempts/second). I think it's a good number, especially if you have a router, but you can try a higher one.

Share this post


Link to post
Share on other sites

Speed Tab - Transfer cap

Minor GUI bug - two the same colors:

- total is magenta

- uploaded is red

- downloaded is green

- limit is green too → please change it to cyan (?)

Share this post


Link to post
Share on other sites

or maybe just the same color as each (like in the speed graph) and if possible - dotted...

Share this post


Link to post
Share on other sites

Could some 1 check this "bug"

Download for example 2 torrents (one torrent is about 2x lager than second).

When the second torrent is completed and start fully seeding, it consume all upload speed, causing uT to dont reaching maximum download speed, like in download mode.

This bug exist off course in no limited down/upload

Share this post


Link to post
Share on other sites

and how would you suggest uT should behave with no limits ? you need some free upload bandwidth for the download overhead, so it probably divides the upload 50%-50% between seeding and download.

Share this post


Link to post
Share on other sites
Ultima, Ondoy said it took 1.85 took a few seconds to get to maximum speed, but RC5 took 5 minutes (not 5 seconds)...

I suggest you take a look at all of the timestamps on his post and my reply. I don't think I am obligated to wait around for users to silently edit/correct their posts to which I've already replied just to see if my post is still relevant. But that's completely besides the point, because my reply did more than just point out the insignificance of a ramp-up time of (what was at the time specified to be) 5 seconds.

rc5 hangs when using the webui

Do you happen to be using an alternative listening port?

Share this post


Link to post
Share on other sites

@ rafi - its only my opinion, but uT in downloading and mixing (down + up) mode should prioritize downloading instead of uploading

because now option like "seeding tasks have higher priority than downloading tasks" didnt make any sense, cause uT will prioritize only upload tasks ;p

Share this post


Link to post
Share on other sites

the "sense" is as explained in the help file:

Seeding tasks have higher priority than downloading tasks will give seeding tasks higher priority than downloads, so if your maximum number of active torrents is reached, and a torrent job reaches seeding state, the downloading tasks will not force it into queued seeding state.

so you have to find a better "tactics" then 50-50 for uT in this case of concurrent UL/DL tasks...

a possible way is - you can try and use the pseudo "priority" scheme by right-click->bandwidth allocation on each task. the help-file relates this setup to only uploading tasks, but anyways, it will only work IF you set a limit (a guess - to have a reference point). So if you eventually will decide to do this right thing, who knows... it might even work for mixed tasks... try it and tell us... ;)

Share this post


Link to post
Share on other sites

I'm too lazy to test it fully, better set upload limit to 25KB/s on all tasks in my case ;p

but I'm only informing about improving some algorithms to getting faster download speed in "mixed" mode with no limiton down/upload speed

Share this post


Link to post
Share on other sites

#402: I used WebUI today and nothing hangs... But when router disable vpn, local speed was 5mb/s and torrent should be completed in 5 seconds, WebUI says: "ETA 4y 0w".

Now appear bad bug with uTorrent hang. And killing not works(((. Dump: http://rapidshare.com/files/343515087/uTorrent.rar.html or magnet:?xt=urn:btih:UZMONRAUAVXPX6Z5GOSJV4XARXC6JB4X&tr=http%3A%2F%2Fagmt.kicks-ass.org:22913%2Fannounce

P.S. "uTorrent.exe *32" exists in task manager. But I can rename all .dat files and utorrent.exe.

Share this post


Link to post
Share on other sites

I just updated to RC5 and updated webui also, but i got same problem with Webui just hangs and nothing else is happening.

I have now tried to go back with Webui 0.361 and now i can load it. But i cant add torrents. I browse and find torrent file and press add. But the torrent never adds in utorrent. :(

I have also tried with Utorrent 2.1 alpha, and same problem with adding torrents.

Share this post


Link to post
Share on other sites

This may be a dumb question but I am wondering why there are still flags missing from the flagset for peers? I am currently residing in one of the countries with a missing flag and it just bugs me for some reason. Thanks

Share this post


Link to post
Share on other sites

I updated to RC5 and I have to give kudos to the developers: the upload, including overhead, follows the limit quite well. The jigsaw transfer rate that I saw on earlier RCs seems to have been resolved.

(settings: net.calc_overhead=true. bt.connect_speed to 4 -- I had set it to 15 on 1.8.5 and, strangely, it didn't get reduced to 5 when I changed to RC5.)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.