Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 2.0 released

Recommended Posts

Yep, fixing upload limit bug should be next to crash bugs, cause its annoying on my 12Mb/512kb...

Nice will be seeing this fixed in stable 2.0 or I need to stay on 1.8.5 forever ;) ?

and many ppl will probably spamming "Found Bugs" forum, when this wont be fixed and stable 2.0 will be released...

Share this post


Link to post
Share on other sites

Hi

I was seeding two (of my own) torrents fine. I then set them both to pause, exited uTorrent and rebooted my machine.

- Now both torrents have a red exclamation mark next to them (there is a green tick at the bottom of the window).

- Under tracker both torrents are listed as 'inactive'

I tried:

- Start

- Force Start

- Force Re-Check

- Update tracker

- Download the torrent

The tracker is demonoid and seems to be fine.

WinXP SP3 with latest patches, uTorrent settings as recommended by the program., TCP/IP hack set to 100, ipfilter used, forced encryption, other settings at default, files location has not moved.

Share this post


Link to post
Share on other sites

Since I'm the original seeder...I had to delete the existing entries in uTorrent, download my own torrent, let it create the file entries in my HDD, exit uTorrent, delete the contents of the folders, replace with the original files, start utorrent, stop the torrents, force-recheck and I'm back on track...few!

P.S. By the way, is it possible to get a feature where old torrents files residing in ApplicationData/uTorrent can be deleted (apart from active ones)?

If not that, at least a button opening that folder directly, so we can do it manually? A bit of a time saver.

Share this post


Link to post
Share on other sites
emc:

rafi,

and this one does not work? http://forum.utorrent.com/viewtopic.php … 21#p441821

no , because it's missing one icon... 11 instead of 12 ...

and Firon:

I tested the UL limiter again (net.calc_overhead = true) in 1.8.5 and it works fine, limiting both the data+overhead . I hope they will attend to it here as well.

Share this post


Link to post
Share on other sites

"We rolled back the behavior where it throttles traffic to not exceed the limit due to overhead. It was bugged and too close to release.

Now it behaves more like 1.8.x."

From 1.6.x-1.8.x I had to set a 6 kB limit for my 1mb/128kb limit to be able to download with near maximum speed and to be able browse webpages. I tried build 17624 yesterday. I kept settings from 1.8.5 didn't change anything but it wasn't working anymore. The webpages were hardly loading, the download speed was fluctuating and rarely neared the maximum. So it doesn't work like 1.8.x. I switched back and everything was normal again.

Share this post


Link to post
Share on other sites

what's your average download speed ? you should have raised your limit by about 5% of that.

Share this post


Link to post
Share on other sites

2.0 RC2 out. No, loading of old skins isn't fixed yet. A nasty little bug was discovered in RC1 that affects your ability to connect to seeds, so upgrading is recommended ASAP.

Share this post


Link to post
Share on other sites

note to Firon...:

both "my" toolbar (@ post #90) and the status bar (@ post #77) are loading fine for me. So... the devs might find time to fix the more important issue of the UL limit ... :)

Share this post


Link to post
Share on other sites

I updated to RC2 and I don't see much difference in the throughput - which is poor. I am d/l-ing 3 torrents, with 18, 13, and 6 peers, respectively, and the download rates I am getting are around 1.9, 1.5, and 0.4 kB/s. I have a scheduler-limited upload rate of 35 KB (no download limit). The average download rate is much less than a quarter of the upload limit, although I see spikes up to about 25-30 kB/s but immediately decaying back to the average baseline. The upload rate is more steady and roughly 2-3x the download rate.

The poor d/l rate could be related to the peers, of course, but the sawtooth pattern and the very low throughput seems suspicious.

Share this post


Link to post
Share on other sites
[21:07] <Firon> rafi, your 'bad' screenshot sure looks like it's going over through overhead

21:09] <_rafi_> I'm not sure I follow you. It does go over and it IS due to overhead. It shouldn't do that (as it didn't in 1.8x)

[21:09] <Firon> sure it does, 1.8 always did while downloading

[21:10] <_rafi_> no, it didn't. Let me upload another one for you (from 1.8)

[21:13] <_rafi_> and I seem to have lost the screenshot from 1.8...:( have to re-run it again...

Checking of the Upload limiter - in a 2.5M/250K connection. Downloads are from good seeds. seeding seems minimal to me (1 slot/torrent).

calc_overhead = true

1.8.3 (TCP only)

http://img130.imageshack.us/i/183tcp.png/

1.8.3 (TCP+uTP)

http://img132.imageshack.us/i/183tcputpu.png/

1.8.5 (TCP+uTP)

http://img130.imageshack.us/i/185tcputp.png/

continued:

http://img191.imageshack.us/i/185tcputp2.png/

As you can see - the UL limit is effecting the upload, as well as choking the download a bit if it is set too low.

2.0 RC1 (TCP+uTP)

http://forum.utorrent.com/viewtopic.php?pid=442225#p442225

2.0 RC2 (TCP+uTP)

http://img690.imageshack.us/i/200tcputp.png/

No need to say anything on the 2.0 tests , the screenshots speek for themselves...

So, my conclusion:

Unlike 1.8.3/5 - 2.0 does not implement UL limit at all for overhead traffic.

FYI Firon... :P

Pleeeaaase fix it

Share this post


Link to post
Share on other sites

Comparing 1.8.5 (build 17414) with latest 2.0 RC2 build.

Bugs:

2.0 - upload (via web UI) on a linux system using wine is not possible (see earlier post of mine). Version 2.1 is throwing an error message saying that XYZ.tmp could not be loaded.

2.0 - incoming connections of IPs asking for "UNKNOWN" torrent. Changing to 1.8.5 the torrents are known and handled correctly.

Its also strange that a 2.0 (build 17668) doesn't connect to another 2.0 (build 17668). The one system is using win the other ubuntu server 9.10 server x64 via wine. Both are connectable from the outside but claim that their torrents are "UNKNOWN". :-/

After chaning back to 1.8.5 everything works ok. No "unknown" torrents and connection to a 2.0 version is possible.

Share this post


Link to post
Share on other sites
Its also strange that a 2.0 (build 17668) doesn't connect to another 2.0 (build 17668).

I heard such report from others as well (for RC1). I thought this was fixed in RC2...

Downgrading to 1.8 :(

Share this post


Link to post
Share on other sites

I don't know if anyone else has noticed this, but when I add a UDP tracker to utorrent my peer count explodes.

In the picture below you can see a torrent tracked by http.openbittorent.com. The tracker reports 76 peers, PEX found 243 peers and the total count which is reported at the torrent list is 276.

ut1.png

When I add the udp tracker, it still reports 76 peers (in the detailed info tab) but the general number of peers for the torrent has instantly gone up to 1329 ! ! !

ut2.png

In case you're wondering, the same happens with many other torrents and older utorrent 2.0 builds.

I'm not very familiar with udp trackers so is this a tracker problem or utorrent's problem ? ? ?

By the way, the new icons seem a little weird...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.