Jump to content

Bug with Drive Unavailable


zweinstein

Recommended Posts

Note: the entire scenario occurs while the default download directory is unavailable.

1. Add new torrent

2. Navigate to new save location and save file. The download begins.

3. Add another new torrent

4. Press the ... button to navigate to a save location. Since the default directory is unavailable, the dialog box to browse for a folder will automatically put you in the same directory that you just saved the previous torrent

5. Press ok to save the torrent in that directory

6. THE BUG: The file never changes location, resulting in an error as you start to download the torrent. It says something like the save location is unavailable.

Is that clear?

Link to comment
Share on other sites

For argument's sake, let's assume that the default save location is E:\ . But, the drive normally connected as drive E:\ is unplugged from the computer. So, you want to save the file in H:\ . The first torrent saves fine but when you open up a second torrent and click on the "..." button, it assumes that the dialog box launched at E:\ when in fact, it launched at H:\ because E:\ was unavailable. Because uTorrent thinks it launched at E:\, in order to change the save directory to H:\ from the browse for location dialog box, you must go up one level and then back so that the value returned by the dialog box is changed, and therefore the correct value is recorded.

Link to comment
Share on other sites

Still no go. Here's what I tried:

1. Set my default download location in Preferences > Directories to some nonexistent drive -- say, S:\

2. I try adding a new .torrent file. It defaults to S:\... Fine, so I change it to an existent location -- say C:\ -- and press OK to add it to µTorrent

3. I try adding another .torrent file. It defaults to S:\... OK, so I press the "..." button and press OK to have it save to C:\ as well, and press OK on the Add New Torrent dialog to confirm the add

4. I check the "Save As" path on both of the newly added torrents, and I see C:\...

Where is the problem?

Link to comment
Share on other sites

So, when you followed all the steps with both being single-file torrents and when you pressed ok on the second one, it changed the save location? I don't know what to tell you. That's not the result I am experiencing.

I just want to check that when the save dialog box for the second single-file torrent popped up, all you did was pressed save. You didn't navigate away and then back to that location? It would be my guess that the dialog box for navigating for location for a single file does not return anything unless it is changed.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...