Jump to content

Slow Speed on all torrents exept the OpenOffice, Slackware or Ubuntu


AJFRESH

Recommended Posts

I recently installed windows 7 64 and have been experiencing slow download speed since (40bpbs to 300kpbs)...while with xp sp3 I could go as high as 2mbit.

I tried everything I could find on the internet:

Added or changed in/to registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

EnableTCPA=1

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DefaultTTL=64

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

TCPMaxDataRetransmissions=7

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

SynAttackProtect=1

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\ServiceProvider\LocalPriority=4

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\ServiceProvider\HostsPriority=5

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\ServiceProvider\DnsPriority=6

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\ServiceProvider\NetbtPriority=7

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

MaxUserPort=65535

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TcpTimedWaitDelay=30

I have turned off QoS and IPv6 and played around with the Speed & Duplex option to no avail (Auto-Negotiation!)

I did patch Tcpip.sys with TCPZ64.exe (at the moment set to 252)

I have tried flushing / releasing and renewing DNS several times and have left my modem disconnected for more! then 5 min.

I have tried several settings with -netsh int tcp show global- in CMD

Current settings are:

Receive-side scaling state: Enabled

Chimney offload State: Automatic

NetDMA State: Enabled

Direct Cache Acess (DCA): Disabled

Receive Window Auto-Tuning Level: Disabled

Add-on Congestion Control Provider : None

ECN Capability: Disabled

RFC 1323 Timestamps : Disabled

Did a speed test at speedtest.net and got exactly what I was seeing but not what I should be getting, with very high ping! +400)

Now this all did nothing to solve the problem! until last night suddenly my connection was back...untill this afternoon...then it was gone again!

(Did another speed test when the line was good and everything was fine 16mbit+ Download with low ping 20)

(I must add that it popped back in when I was fiddling with the upload limits, I had to set it at 5 to get my +/- 1.8mbit connection)

Windows did install some updated so I rechecked all these things but nothing!

I did play around with the bittorrent settings for various connection speeds.

Now..........

I tried your suggestions also:

SLOW/INTERRUPTED INTERNET CONNECTION OR OFFLINE TRACKERS

All of them without success.......

BUT...

When downloading torrents from your OpenOffice and Ubuntu Links the did get the speed of 1.2 and 2mbit respectively!

But only if I stopped all other torrents I have in my list!

If I started only one (ex. top gear from EZTV, usually reasonable speeds of +600kpbs) everything dropped down to 100kpbs total.

I hope you can tell me why this happens and hoe to resolve the problem!!!

Additional info:

Color of the network status light in µTorrent's status bar:

green

What the port checker from the Speed Guide writes:

Port 10013 is open and accepting connections.

What the Speed Guide shows your settings to be:

xx20mbit connection (But I tried all of them)

What you have net.max_halfopen set to (Preferences > Advanced in µTorrent), and if you ever modified TCPIP.sys, what you patched the limit to:

Yes .252

Operating system installed:

Windows 7 64 Ultimate

Security software installed:

Standard windows 7 Firewall and Defender (I was busy with this so didn´t have time to add or change anything)

Exact router model(s), and exact modem model:

Generic Marvell Yukon 88E8056 based Ethernet Controller (UPDATED DRIVERS!)

ISP (Internet Service Provider) being used:

netvisao.pt (Portugal)

Connection type:

20Mbit

Speedtest.NET result (At this moment):

Download: 13,64

Upload: 0,96 (Never seen it this low, I don't have problems uploading!)

Ping: 23ms

Basic computer hardware specifications:

CPU: Intel Pentium D CPU 2.80Ghz

RAM: 2GB

Desktop Board: Intel® 82801GB/GR (ICH7 Family) LPC Interface Controller - 27B8

Drive Type: WDC WD3200JS-00PDB0 ATA Device

Process Explorer Log:

Process PID CPU Description Company Name

System Idle Process 0 86.51

Interrupts n/a Hardware Interrupts

DPCs n/a Deferred Procedure Calls

System 4

smss.exe 352

csrss.exe 452

wininit.exe 512

services.exe 560 0.77

svchost.exe 740

svchost.exe 812

svchost.exe 916

audiodg.exe 6732

svchost.exe 956

WUDFHost.exe 1952

dwm.exe 2060 Desktop Window Manager Microsoft Corporation

svchost.exe 980

wuauclt.exe 2280 Windows Update Microsoft Corporation

svchost.exe 796

svchost.exe 1128

spoolsv.exe 1280

svchost.exe 1336

svchost.exe 1468

svchost.exe 1932

taskhost.exe 1604 Host Process for Windows Tasks Microsoft Corporation

SearchIndexer.exe 2540

SearchProtocolHost.exe 6688

SearchFilterHost.exe 8444

svchost.exe 2044

taskhost.exe 2820

wmpnetwk.exe 972

svchost.exe 2880

svchost.exe 11140

lsass.exe 576

lsm.exe 584

csrss.exe 524

winlogon.exe 628

explorer.exe 2088 Windows Explorer Microsoft Corporation

firefox.exe 8104 6.12 Firefox Mozilla Corporation

uTorrent.exe 11544 6.89

procexp.exe 4296 Sysinternals Process Explorer Sysinternals - www.sysinternals.com

procexp64.exe 5564 0.77 Sysinternals Process Explorer Sysinternals - www.sysinternals.com

PWRISOVM.EXE 2692 PowerISO Virtual Drive Manager PowerISO Computing, Inc.

Process: procexp.exe Pid: 4296

Name Description Company Name Version

ADVAPI32.dll Advanced Windows 32 Base API Microsoft Corporation 6.1.7600.16385

advapi32.dll.mui Advanced Windows 32 Base API Microsoft Corporation 6.1.7600.16385

apphelp.dll Application Compatibility Client Library Microsoft Corporation 6.1.7600.16385

COMCTL32.dll User Experience Controls Library Microsoft Corporation 6.10.7600.16385

COMDLG32.dll Common Dialogs DLL Microsoft Corporation 6.1.7600.16385

CRYPTBASE.dll Base cryptographic API DLL Microsoft Corporation 6.1.7600.16385

GDI32.dll GDI Client DLL Microsoft Corporation 6.1.7600.16385

IMM32.DLL Multi-User Windows IMM32 API Client DLL Microsoft Corporation 6.1.7600.16385

kernel32.dll Windows NT BASE API Client DLL Microsoft Corporation 6.1.7600.16385

KERNELBASE.dll Windows NT BASE API Client DLL Microsoft Corporation 6.1.7600.16385

locale.nls

LPK.dll Language Pack Microsoft Corporation 6.1.7600.16385

MPR.dll Multiple Provider Router DLL Microsoft Corporation 6.1.7600.16385

MSCTF.dll MSCTF Server DLL Microsoft Corporation 6.1.7600.16385

msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.0.7600.16385

NSI.dll NSI User-mode interface DLL Microsoft Corporation 6.1.7600.16385

ntdll.dll NT Layer DLL Microsoft Corporation 6.1.7600.16385

ntdll.dll NT Layer DLL Microsoft Corporation 6.1.7600.16385

ntmarta.dll Windows NT MARTA provider Microsoft Corporation 6.1.7600.16385

ole32.dll Microsoft OLE for Windows Microsoft Corporation 6.1.7600.16385

OLEAUT32.dll Microsoft Corporation 6.1.7600.16385

procexp.exe Sysinternals Process Explorer Sysinternals - www.sysinternals.com 11.33.0.0

RPCRT4.dll Remote Procedure Call Runtime Microsoft Corporation 6.1.7600.16385

sechost.dll Host for SCM/SDDL/LSA Lookup APIs Microsoft Corporation 6.1.7600.16385

SHELL32.dll Windows Shell Common Dll Microsoft Corporation 6.1.7600.16385

SHLWAPI.dll Shell Light-weight Utility Library Microsoft Corporation 6.1.7600.16385

SortDefault.nls

SspiCli.dll Security Support Provider Interface Microsoft Corporation 6.1.7600.16385

USER32.dll Multi-User Windows USER API Client DLL Microsoft Corporation 6.1.7600.16385

USP10.dll Uniscribe Unicode script processor Microsoft Corporation 1.626.7600.16385

uxtheme.dll Microsoft UxTheme Library Microsoft Corporation 6.1.7600.16385

VERSION.dll Version Checking and File Installation Libraries Microsoft Corporation 6.1.7600.16385

WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 6.1.7600.16385

wow64.dll Win32 Emulation on NT64 Microsoft Corporation 6.1.7600.16385

wow64cpu.dll AMD64 Wow64 CPU Microsoft Corporation 6.1.7600.16385

wow64win.dll Wow64 Console and Win32 API Logging Microsoft Corporation 6.1.7600.16385

WS2_32.dll Windows Socket 2.0 32-Bit DLL Microsoft Corporation 6.1.7600.16385

I hope you can help!

Thanx in advance

BTW I also tried to run Utorrent under the various compatibility modes available in Windows 7 64.

Nothing changed!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...